tramp sous mswindows

Le
JJ. Rétorré
Bonjour,

J'édite des fichiers html sur ftpperso.free.fr en utilisant muse et
tramp, mais je n'arrive pas à me connecter sous mswindows.
Y a-t-il une configuration d'ange-ftp qui le permette ?

--
JJR.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Quesseveur
Le #22599671
"blah" == JJ Rétorré


blah> J'édite des fichiers html sur ftpperso.free.fr en utilisant
blah> muse et tramp, mais je n'arrive pas à me connecter sous
blah> mswindows.

Je fais plus ou moins la même chose et je n'ai pas de problèmes avec
tramp sous Windows -- GNU Emacs 23.1.1 (i386-mingw-nt6.0.6001) of
2009-07-30 on SOFT-MJASON. Par contre j'ai le souvenir d'avoir essayé
ange-ftp au début et d'avoir rencontré des problèmes. Pour tramp j'ai
ça dans ma config:

--8<---------------cut here---------------start------------->8---
(add-to-list 'tramp-default-method-alist
'("ftpperso.free.fr" "pascal.quesseveur" "ftp"))
--8<---------------cut here---------------end--------------->8---


--
Pascal Quesseveur

jean-jacques Rétorré
Le #22599961
On 22 sep, 21:51, Pascal Quesseveur
>"blah" == JJ Rétorré
  blah> J'édite des fichiers html sur ftpperso.free.fr en utilisant
  blah> muse et tramp, mais je n'arrive pas à me connecter sous
  blah> mswindows.

Je fais plus ou moins la même chose et je n'ai pas de problèmes avec
tramp sous Windows -- GNU Emacs 23.1.1 (i386-mingw-nt6.0.6001) of
2009-07-30 on SOFT-MJASON. Par contre j'ai le souvenir d'avoir essayé
ange-ftp au début et d'avoir rencontré des problèmes. Pour tramp j' ai
ça dans ma config:

--8<---------------cut here---------------start------------->8---
(add-to-list 'tramp-default-method-alist
             '("ftpperso.free.fr" "pascal.quesseveur" "ftp" ))
--8<---------------cut here---------------end--------------->8---

--
Pascal Quesseveur




J'ai téléchargé la version 23.2.1 (i386-mingw-nt5.1.2600), pensant
que ma version 22 était obsolete, j'ai ajouté ma définition de tramp-
default-method-alist, mon installation ne semble pas connaître :

Warning (initialization): An error occurred while loading `c:/
Documents and Settings/winjjr/Application Data/.emacs':
-----------
Symbol's value as variable is void: tramp-default-method-alist,

------------
et j'ai toujours les mêmes messages d'erreur quand j'essaye de
charger un fichier sur ftpperso.free.fr:

-----------
Commande d'aide non valide foo.
open ftpperso.free.fr
Connect ftpperso.free.fr.
220 Serveur de mise a jour des pages perso de Free.fr version [May 5
2008 15:14:30]
get ~ NUL
502 'PORT': command not implemented.
get ~ NUL
502 'RETR': command not implemented.
pwd
502 'RETR': command not implemented.
502 'XPWD': command not implemented.
pwd
502 'XPWD': command not implemented.
get ~ NUL
502 'RETR': command not implemented.
get ~ NUL
502 'RETR': command not implemented.
pwd
502 'XPWD': command not implemented.
pwd
502 'XPWD': command not implemented.
get ~ NUL
502 'RETR': command not implemented.
get ~ NUL
502 'RETR': command not implemented.
pwd
502 'XPWD': command not implemented.
pwd
502 'XPWD': command not implemented.
---------
Je ne pense pas faire d'erreur, j'applique la même procédure que sous
Linux, et ça marche très bien...
Mais j'aurais besoin de le faire sous mswindows de temps en temps.
Je suis actuellement sous Ouinedose XP et j'ai désactivé le firewall.

--
JJR.
Pascal Quesseveur
Le #22600011
"jR" == jean-jacques Rétorré


jR> J'ai téléchargé la version 23.2.1 (i386-mingw-nt5.1.2600), pensant
jR> que ma version 22 était obsolete, j'ai ajouté ma définition de tramp-
jR> default-method-alist, mon installation ne semble pas connaître :

Je pense qu'il faut ajouter (require 'tramp)


--
Pascal Quesseveur

jean-jacques Rétorré
Le #22604201
On 22 sep, 23:20, Pascal Quesseveur
>"jR" == jean-jacques Rétorré
  jR> J'ai téléchargé la version  23.2.1 (i386-mingw-nt5.1.2600 ), pensant
  jR> que ma version 22 était obsolete, j'ai ajouté ma définition de tramp-
  jR> default-method-alist, mon installation ne semble pas connaître :

Je pense qu'il faut ajouter (require 'tramp)




Ben ça va pas mieux....
Je n'ai pas cygwin, est il nécessaire ?
--
JJR.
Pascal Quesseveur
Le #22604281
"jR" == jean-jacques Rétorré


jR> Je n'ai pas cygwin, est il nécessaire ?

Non je ne l'ai pas installé non plus.


--
Pascal Quesseveur

Pascal Quesseveur
Le #22604271
"jR" == jean-jacques Rétorré


jR> Je n'ai pas cygwin, est il nécessaire ?

J'ai regardé un peu mieux. En fait j'avais configuré ange-ftp pour
utiliser le ftp de gnuwin32, et je pense que tramp utilise cette
configuration.


--
Pascal Quesseveur

Publicité
Poster une réponse
Anonyme