Transférer le contenu de cellules en colonne dans une seule cellule...

Le
Pierre F.
Bonjour et bonsoir à toutes et tous,

J'ai un tableau d'une trentaine de lignes qui va de la colonne A à AZ.

Dans la cellule D29 (fusionnée), je souhaiterais, par formule,
transférer (copier) le contenu des cellules de la colonne AZ si contenu
il y a).

J'ai essayé concatener et &, ça marche :-)

Mais à chaque contenu copié, je souhaiterais en plus lui associer le
contenu de la cellule de la colonne A correspondante.

Ainsi, si AZ15 contient qqchose, je souhaite copier en D29: A15 & " "&
AZ15 & " // "
Si AZ15 ne contient rien, rien n'est copié.

Pour 2-3 lignes, je saurai le libeller, mais pour 30 y'a peut-être
une formule plus magique ??

Merci pour votre aide.

http://cjoint.com/?jltNlr7dAZ

Cordialement,
Pierre F.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Trirème
Le #4749201
Bonsoir Pierre F.

Avec une seule formule, sans VBA j'y arrive pas.
Par contre, si tu acceptes de passer par une colonne intermédiaire (à masquer ou
dans une autre feuille) je te propose de copier en BA6 :
=SI(ESTVIDE(AZ6);SI(ESTVIDE(BA5);"";BA5);BA5&A6&" "&AZ6&" //")
(ou une colonne plus à droite, changer alors BA)
Puis de recopier jusqu'en BA28.
En D29, tu pourras alors écrire ²8.

Cordialement,
Trirème

Bonjour et bonsoir à toutes et tous,

J'ai un tableau d'une trentaine de lignes qui va de la colonne A à AZ.

Dans la cellule D29 (fusionnée), je souhaiterais, par formule,
transférer (copier) le contenu des cellules de la colonne AZ si contenu
il y a).

J'ai essayé concatener et &, ça marche :-)

Mais... à chaque contenu copié, je souhaiterais en plus lui associer le
contenu de la cellule de la colonne A correspondante.

Ainsi, si AZ15 contient qqchose, je souhaite copier en D29: A15 & " "&
AZ15 & " // "
Si AZ15 ne contient rien, rien n'est copié.

Pour 2-3 lignes, je saurai le libeller, mais pour 30... y'a peut-être
une formule plus magique ??

Merci pour votre aide.

http://cjoint.com/?jltNlr7dAZ

Cordialement,
Pierre F.





Pierre F.
Le #4748691
Bonsoir Pierre F.

Avec une seule formule, sans VBA j'y arrive pas.


Je soupçonnais bien ce cas de figure :-)

Par contre, si tu acceptes de passer par une colonne intermédiaire (à
masquer ou dans une autre feuille) je te propose de copier en BA6 :
=SI(ESTVIDE(AZ6);SI(ESTVIDE(BA5);"";BA5);BA5&A6&" "&AZ6&" //")
(ou une colonne plus à droite, changer alors BA)
Puis de recopier jusqu'en BA28.
En D29, tu pourras alors écrire ²8.


A défaut d'être "magique", cette solution est "Magnifique" et me
convient tout à fait :-)

Merci !!!!!

Cordialement,
Pierre F.

Publicité
Poster une réponse
Anonyme