Tri dans une colone qui comporte des occurences séparées par des virgules

Le
Fred
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par exemple ont
travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de lignesUne
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5068081
Bonjour,

Utiliser le filtre automatique: personnalisé/Contient

JB

On 21 nov, 15:27, "Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentée s comme ceci:

sarl dupont, sarl durand, satoto

Je voudrais donc pouvoir chercher toute les personnes, qui par exemple ont
travaillé pour la sarl surant ET/OU la sarltoto.

Le fichier fait environ 30 Mo, il contient donc beaucoup de lignes...Une
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.


Ellimac
Le #5068061
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par exemple ont
travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de lignes...Une
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.




Fred
Le #5067931
Merci, j'essaie cela.

FRED

"Ellimac" news:
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par exemple
ont travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de lignes...Une
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.








Fred
Le #5067811
En fait, ce que je souhaiterais fair plus particulièrement, c'est utiliser
une fonction OU, du type:

=SI(OU(E1="sarldurand";E1="sarltot");"duponttot";"Autres")
Mais j'obtiens en permanence "autres"...

FRED.



"Ellimac" news:
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par exemple
ont travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de lignes...Une
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.








Trirème
Le #5067691
Sallu Phraide
Tu peux peut être utiliser ceci :
=SI(OU(ESTNUM(CHERCHE("sarldurand";E1));ESTNUM(CHERCHE("sarltot";E1)));"duponttot";"Autres")

Cordialement,
Trirème


En fait, ce que je souhaiterais fair plus particulièrement, c'est utiliser
une fonction OU, du type:

=SI(OU(E1="sarldurand";E1="sarltot");"duponttot";"Autres")
Mais j'obtiens en permanence "autres"...

FRED.



"Ellimac" news:
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par exemple
ont travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de lignes...Une
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.












Ellimac
Le #5067671
Bonjour,

=SI(ESTERREUR(CHERCHE("sarl toto";E1));0;CHERCHE("sarl
toto";E1))+SI(ESTERREUR(CHERCHE("sarl durand";E1));0;CHERCHE("sarl
durand";E1))

Renvoie 0 s'il ne trouve ni sarl durand ni sarl toto sinon renvoie une
valeur > à 0.

Camille


En fait, ce que je souhaiterais fair plus particulièrement, c'est utiliser
une fonction OU, du type:

=SI(OU(E1="sarldurand";E1="sarltot");"duponttot";"Autres")
Mais j'obtiens en permanence "autres"...

FRED.



"Ellimac" news:
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par exemple
ont travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de lignes...Une
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.












Fred
Le #5067391
Merci beaucoup, cela semble fonctionner parfaitement !!!

Bonne journée à tous,


FRED.




"Trirème" news:
Sallu Phraide
Tu peux peut être utiliser ceci :
=SI(OU(ESTNUM(CHERCHE("sarldurand";E1));ESTNUM(CHERCHE("sarltot";E1)));"duponttot";"Autres")

Cordialement,
Trirème


En fait, ce que je souhaiterais fair plus particulièrement, c'est
utiliser
une fonction OU, du type:

=SI(OU(E1="sarldurand";E1="sarltot");"duponttot";"Autres")
Mais j'obtiens en permanence "autres"...

FRED.



"Ellimac" news:
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments
se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par exemple
ont travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de
lignes...Une
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.














Fred
Le #5067351
En revanche, pourrais-tu m'indiquer pourquoi il est nécessaire d'indiquer
"ESTNUM" ?

Merci,

FRED.

"Trirème" news:
Sallu Phraide
Tu peux peut être utiliser ceci :
=SI(OU(ESTNUM(CHERCHE("sarldurand";E1));ESTNUM(CHERCHE("sarltot";E1)));"duponttot";"Autres")

Cordialement,
Trirème


En fait, ce que je souhaiterais fair plus particulièrement, c'est
utiliser
une fonction OU, du type:

=SI(OU(E1="sarldurand";E1="sarltot");"duponttot";"Autres")
Mais j'obtiens en permanence "autres"...

FRED.



"Ellimac" news:
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des arguments
se
trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par exemple
ont travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de
lignes...Une
macro serait-elle plus adaptée?

Merci de votre aide,

FRED.














Trirème
Le #5067251
Bonjour Fred,

En revanche, pourrais-tu m'indiquer pourquoi il est nécessaire
d'indiquer "ESTNUM" ?
Dans le cas qui nous intéresse on veut une réponse globale Oui-Non ou Vrai-Faux

sans être arrêté par une bête erreur.
La fonction CHERCHE() fonctionne ainsi :
Lorsque le 'mot' cherché se trouve dans la 'phrase' la fonction CHERCHE()
renvoie sa position, un nombre. Par contre lorsque le 'mot' cherché ne se trouve
pas dans la 'phrase', la fonction CHERCHE() renvoie le résultat #VALEUR! qui
n'est plus exploitable dans un test OU().
La fonction ESTNUM() accepte tout type d'argument (nombre (ou date), texte,
vide, erreur). Elle permet alors de déterminer par VRAI ou FAUX le résultat
renvoyé par CHERCHE().

Une erreur est un résultat comme un autre. Lorsqu'une fonction renvoie une
erreur il faut s'y préparer, même si parfois ça nous en..quiquine.

Cordialement,

Trirème

Merci,

FRED.

"Trirème" news:
Sallu Phraide
Tu peux peut être utiliser ceci :
=SI(OU(ESTNUM(CHERCHE("sarldurand";E1));ESTNUM(CHERCHE("sarltot";E1)));"duponttot";"Autres")


Cordialement,
Trirème


En fait, ce que je souhaiterais fair plus particulièrement, c'est
utiliser
une fonction OU, du type:

=SI(OU(E1="sarldurand";E1="sarltot");"duponttot";"Autres")
Mais j'obtiens en permanence "autres"...

FRED.



"Ellimac" news:
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des
arguments >> se


trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par
exemple


ont travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de >>
lignes...Une


macro serait-elle plus adaptée?

Merci de votre aide,

FRED.

















Fred
Le #5067021
Merci beaucoup pour tes explications, cela me permet de comprendre avant
d'appliquer bêtement !

Excellent apétit puisqu'il se fait l'heure !!

FRED.

"Trirème" news:%23DN%
Bonjour Fred,

En revanche, pourrais-tu m'indiquer pourquoi il est nécessaire d'indiquer
"ESTNUM" ?
Dans le cas qui nous intéresse on veut une réponse globale Oui-Non ou

Vrai-Faux sans être arrêté par une bête erreur.
La fonction CHERCHE() fonctionne ainsi :
Lorsque le 'mot' cherché se trouve dans la 'phrase' la fonction CHERCHE()
renvoie sa position, un nombre. Par contre lorsque le 'mot' cherché ne se
trouve pas dans la 'phrase', la fonction CHERCHE() renvoie le résultat
#VALEUR! qui n'est plus exploitable dans un test OU().
La fonction ESTNUM() accepte tout type d'argument (nombre (ou date),
texte, vide, erreur). Elle permet alors de déterminer par VRAI ou FAUX le
résultat renvoyé par CHERCHE().

Une erreur est un résultat comme un autre. Lorsqu'une fonction renvoie une
erreur il faut s'y préparer, même si parfois ça nous en..quiquine.

Cordialement,

Trirème

Merci,

FRED.

"Trirème" news:
Sallu Phraide
Tu peux peut être utiliser ceci :
=SI(OU(ESTNUM(CHERCHE("sarldurand";E1));ESTNUM(CHERCHE("sarltot";E1)));"duponttot";"Autres")

Cordialement,
Trirème


En fait, ce que je souhaiterais fair plus particulièrement, c'est
utiliser
une fonction OU, du type:

=SI(OU(E1="sarldurand";E1="sarltot");"duponttot";"Autres")
Mais j'obtiens en permanence "autres"...

FRED.



"Ellimac" news:
Bonjour Fred,

Filtre Automatique Personnalisé :
Contient sarl durand ou contient sarl toto

Camille

"Fred"
Bonjour,

Dans un tableau, je souhaiterais effectuer un tri selon des
arguments >> se


trouvant dans une colone mais séparés par des virgules.
Du type:

A1 à A10 : NOMS
B1 à B10 : PRENOMS
C1 à C10 : AGES
D1 à D10 : DATE DE NAISSANCES

E1 à E10 : sociétés fréquentées.

Dans par exemple E1, les sociétés fréquentées sont représentées
comme
ceci:

sarl dupont, sarl durand, satoto


Je voudrais donc pouvoir chercher toute les personnes, qui par
exemple


ont travaillé pour la sarl surant ET/OU la sarltoto.


Le fichier fait environ 30 Mo, il contient donc beaucoup de >>
lignes...Une


macro serait-elle plus adaptée?

Merci de votre aide,

FRED.



















Publicité
Poster une réponse
Anonyme