tri dans une colonne

Le
Alexis
Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4448241
Bonjour.
Formule matricielle (valider avec CTRL+MAJ+Entrée) :
=MOYENNE(N(A1:A10<>0))
Cordialement.
Daniel
"Alexis"
Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite
faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les
zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.


Youky
Le #4448221
Bonjour
il y a fort a parier que la moyenne des 1 va donner 1
Il y a un soucis dans ta demande
Youky
"Alexis"
Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite
faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les
zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.


Elliac
Le #4448201
Bonjour,

Que peut renvoyer la moyenne d'une plage ne contenant que des 1 à part la
valeur 1 ?

Camille

"Alexis" wrote:

Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.


Alexis
Le #4448191
Bonjour,
Je me suis trompé et vous avez raison en fait je veux la moyenne des cellule
dont la valeur est différente de zéro.
Merci de votre aide.


Bonjour
il y a fort a parier que la moyenne des 1 va donner 1
Il y a un soucis dans ta demande
Youky
"Alexis"
Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite
faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les
zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.







Alexis
Le #4448181
Bonjour,
Je me suis trompé et vous avez raison en fait je veux la moyenne des cellule
dont la valeur est différente de zéro.
Merci de votre aide.


Bonjour,

Que peut renvoyer la moyenne d'une plage ne contenant que des 1 à part la
valeur 1 ?

Camille

"Alexis" wrote:

Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.




Alexis
Le #4448161
Bonjour et merci de ton aide,
j'ai appliqué ta méthode et il m'affiche Erreur valeur dans la cellule qui
contient le
résultat, pourtant elle est en mode nombre, je nevois pas.
Merci.



Bonjour.
Formule matricielle (valider avec CTRL+MAJ+Entrée) :
=MOYENNE(N(A1:A10<>0))
Cordialement.
Daniel
"Alexis"
Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite
faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les
zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.







Daniel
Le #4448131
Bonsoir.
Quoiqu'une cellule contenant 11111 ne contient que des 1 ;-)))
Cordialement.
Daniel
"Youky" %
Bonjour
il y a fort a parier que la moyenne des 1 va donner 1
Il y a un soucis dans ta demande
Youky
"Alexis" news:
Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite
faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les
zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.






Daniel
Le #4448111
Regarde le classeur à l'adresse :
http://cjoint.com/?enummhaBPG
Daniel
"Alexis"
Bonjour et merci de ton aide,
j'ai appliqué ta méthode et il m'affiche Erreur valeur dans la cellule qui
contient le
résultat, pourtant elle est en mode nombre, je nevois pas.
Merci.



Bonjour.
Formule matricielle (valider avec CTRL+MAJ+Entrée) :
=MOYENNE(N(A1:A10<>0))
Cordialement.
Daniel
"Alexis" news:

Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite
faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les
zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec
des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.









Jean Berti
Le #4447811
Bonsoir

Essaie
=MOYENNE(SI(A1:A7<>0;A1:A7))
Formule matricielle (valider avec CTRL+MAJ+Entrée)

Jean Berti
"Alexis"
Bonjour Tout le monde,

J'ai une colonne sous excel qui contient des 0 et des 1 et je souhaite
faire
la moyenne de cette colonne mais seulement avec les 1 et non avec les
zero.
Donc je souhaite parcourir cette colonne et éviter les cellules avec des
zéros et faire la moyenne des cellules qui contiennent que des 1.

Merci beaucoup de votre aide.


Publicité
Poster une réponse
Anonyme