Tri dans un sous-formulaire

Le
JV
Bonsoir,

Je me permets de reposer une question restée sans réponse en la reformulant.

J'ai un formulaire qui comprends un sous-formulaire.
Dans le sous-formulaire, j'ai mis en propriété que je voulais un tri par
Nom.
Le champ père et le champ fils ne sont pas le nom.
Quand je lance le formulaire, le tri ne se fait pas dans le sous-formulaire.

Est ce que j'écris mal la propriété de tri ?
Qui peut m'aider ?
Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Eric
Le #6188661
Bonsoir,

Dans les propriétés du sous-formulaire, onglet Données, sur la ligne Tri
par tu as mis : [Nom]
?

(Le critère de tri est en rien relié aux champs Pere & Fils)

Avoir un champ nommé Nom n'est pas un bon choix, il s'agit d'un mot réservé.

Bonsoir,

Je me permets de reposer une question restée sans réponse en la reformulant.

J'ai un formulaire qui comprends un sous-formulaire.
Dans le sous-formulaire, j'ai mis en propriété que je voulais un tri par
Nom.
Le champ père et le champ fils ne sont pas le nom.
Quand je lance le formulaire, le tri ne se fait pas dans le sous-formulaire.

Est ce que j'écris mal la propriété de tri ?
Qui peut m'aider ?
Merci d'avance.




--
A+
Eric
http://www.mpfa.info/
Archives : http://groups.google.fr/group/microsoft.public.fr.access?hl=fr

JV
Le #6188641
J'ai essayé avec Nom et avec [Nom].
Est ce que mon problème vient de l'utilisation du mot Nom ?
Si oui, cela me pose un problème car toute l'application utilise ce champ
Nom.


"Eric" #FEhVq$
Bonsoir,

Dans les propriétés du sous-formulaire, onglet Données, sur la ligne Tri
par tu as mis : [Nom]
?

(Le critère de tri est en rien relié aux champs Pere & Fils)

Avoir un champ nommé Nom n'est pas un bon choix, il s'agit d'un mot
réservé.


Bonsoir,

Je me permets de reposer une question restée sans réponse en la
reformulant.



J'ai un formulaire qui comprends un sous-formulaire.
Dans le sous-formulaire, j'ai mis en propriété que je voulais un tri par
Nom.
Le champ père et le champ fils ne sont pas le nom.
Quand je lance le formulaire, le tri ne se fait pas dans le
sous-formulaire.



Est ce que j'écris mal la propriété de tri ?
Qui peut m'aider ?
Merci d'avance.




--
A+
Eric
http://www.mpfa.info/
Archives : http://groups.google.fr/group/microsoft.public.fr.access?hl=fr



JV
Le #6188161
Je viens de trouver la (ou une) solution :
Créer une requête à l'aide du générateur de requête appelé dans la propriété
Source du sous-formulaire.
Dans cette requête, je mets tous les champs (*) + le champ Nom avec l'option
Tri croissant.

Merci de cet échange.

"Eric" #FEhVq$
Bonsoir,

Dans les propriétés du sous-formulaire, onglet Données, sur la ligne Tri
par tu as mis : [Nom]
?

(Le critère de tri est en rien relié aux champs Pere & Fils)

Avoir un champ nommé Nom n'est pas un bon choix, il s'agit d'un mot
réservé.


Bonsoir,

Je me permets de reposer une question restée sans réponse en la
reformulant.



J'ai un formulaire qui comprends un sous-formulaire.
Dans le sous-formulaire, j'ai mis en propriété que je voulais un tri par
Nom.
Le champ père et le champ fils ne sont pas le nom.
Quand je lance le formulaire, le tri ne se fait pas dans le
sous-formulaire.



Est ce que j'écris mal la propriété de tri ?
Qui peut m'aider ?
Merci d'avance.




--
A+
Eric
http://www.mpfa.info/
Archives : http://groups.google.fr/group/microsoft.public.fr.access?hl=fr



Publicité
Poster une réponse
Anonyme