Triage de date

Le
sabine
Bonjour à tous les exceliens,

Voilà j'ai un petit problème de tri, dans mon tableau il y a une colonne en
BH6:BH97 où les cellules comporte des dates "jj/mm/aa" mais certaine cellules
sont vides. La colonne BI6:BI97 comporte des noms propres et je voudrai qu’en
BJ6 :BJ97 les dates se classe automatiquement de manière décroissante. Et
dans la colonne BK :6BK97 il replace les noms propre correspondant. Est-ce
possible de trouver une formule magique sans devoir faire appel à une macro.
Merci d’avance pour votre aide.
Dom2623
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #20333411
Bonjour,
Une piste, avec ajout d'une colonne (CA pour l'exemple) dans laquelle tu
copies cette formule

=SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))

en BJ6 et suivant, tu utilises :

=SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)))

et en BK

=INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))

--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"sabine" news:
Bonjour à tous les exceliens,

Voilà j'ai un petit problème de tri, dans mon tableau il y a une colonne
en
BH6:BH97 où les cellules comporte des dates "jj/mm/aa" mais certaine
cellules
sont vides. La colonne BI6:BI97 comporte des noms propres et je voudrai qu’en
BJ6 :BJ97 les dates se classe automatiquement de manière décroissante. Et
dans la colonne BK :6BK97 il replace les noms propre correspondant. Est-ce
possible de trouver une formule magique sans devoir faire appel à une
macro.
Merci d’avance pour votre aide.
Dom2623



sabine
Le #20338791
Bonjour Philippe,

Je viens d'essayer tes formules, elles sont magiques. Cela fonctionne à
merveille.
Merci pour ton aide très précieuse et le travail que vous faite.
Dom2623



"Philippe.R" a écrit :

Bonjour,
Une piste, avec ajout d'une colonne (CA pour l'exemple) dans laquelle tu
copies cette formule

=SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))

en BJ6 et suivant, tu utilises :

=SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)))

et en BK

=INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))

--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"sabine" news:
> Bonjour à tous les exceliens,
>
> Voilà j'ai un petit problème de tri, dans mon tableau il y a une colonne
> en
> BH6:BH97 où les cellules comporte des dates "jj/mm/aa" mais certaine
> cellules
> sont vides. La colonne BI6:BI97 comporte des noms propres et je voudrai qu’en
> BJ6 :BJ97 les dates se classe automatiquement de manière décroissante. Et
> dans la colonne BK :6BK97 il replace les noms propre correspondant. Est-ce
> possible de trouver une formule magique sans devoir faire appel à une
> macro.
> Merci d’avance pour votre aide.
> Dom2623
>




sabine
Le #20355781
Bonsoir Philippe,

Je me permet de revenir vers vous parce que lorsqu'il y a une date identique
qui apparait 2 fois, la formule ne fonctionne plus. Y a t'il une solution à
ce problème ?

Merci de m'aider

dom2623


"sabine" a écrit :

Bonjour à tous les exceliens,

Voilà j'ai un petit problème de tri, dans mon tableau il y a une colonne en
BH6:BH97 où les cellules comporte des dates "jj/mm/aa" mais certaine cellules
sont vides. La colonne BI6:BI97 comporte des noms propres et je voudrai qu’en
BJ6 :BJ97 les dates se classe automatiquement de manière décroissante. Et
dans la colonne BK :6BK97 il replace les noms propre correspondant. Est-ce
possible de trouver une formule magique sans devoir faire appel à une macro.
Merci d’avance pour votre aide.
Dom2623



sabine
Le #20356211
Bonsoir Philippe,

Je viens de m'appercevoir que lorsqu'il y a 2 dates identique en BH6 : BH97,
le classement ne s'effectue plus. Y a t'il une solution à ce problème ?

Merci pour ton aide

dom2623


"sabine" a écrit :

Bonjour Philippe,

Je viens d'essayer tes formules, elles sont magiques. Cela fonctionne à
merveille.
Merci pour ton aide très précieuse et le travail que vous faite.
Dom2623



"Philippe.R" a écrit :

> Bonjour,
> Une piste, avec ajout d'une colonne (CA pour l'exemple) dans laquelle tu
> copies cette formule
>
> =SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))
>
> en BJ6 et suivant, tu utilises :
>
> =SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)))
>
> et en BK
>
> =INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))
>
> --
> Avec plaisir
> http://dj.joss.free.fr/trombine.htm
> http://jacxl.free.fr/mpfe/trombino.html
> Philippe.R
> Pour se connecter au forum :
> http://www.excelabo.net/web/mpfe
> News://news.microsoft.com/microsoft.public.fr.excel
> "sabine" > news:
> > Bonjour à tous les exceliens,
> >
> > Voilà j'ai un petit problème de tri, dans mon tableau il y a une colonne
> > en
> > BH6:BH97 où les cellules comporte des dates "jj/mm/aa" mais certaine
> > cellules
> > sont vides. La colonne BI6:BI97 comporte des noms propres et je voudrai qu’en
> > BJ6 :BJ97 les dates se classe automatiquement de manière décroissante. Et
> > dans la colonne BK :6BK97 il replace les noms propre correspondant. Est-ce
> > possible de trouver une formule magique sans devoir faire appel à une
> > macro.
> > Merci d’avance pour votre aide.
> > Dom2623
> >
>
>


Philippe.R
Le #20357371
Bonsoir Sabine,
Disons alors, en CA6 et suivantes :

=SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))+NB.SI(BH6:BH$97;BH6)-1

en BJ6 et suivantes :

=SI(ESTNA(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)));"";SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))))

je gratte encore un peu pour BK
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"sabine" news:
Bonsoir Philippe,

Je viens de m'appercevoir que lorsqu'il y a 2 dates identique en BH6 :
BH97,
le classement ne s'effectue plus. Y a t'il une solution à ce problème ?

Merci pour ton aide

dom2623


"sabine" a écrit :

Bonjour Philippe,

Je viens d'essayer tes formules, elles sont magiques. Cela fonctionne à
merveille.
Merci pour ton aide très précieuse et le travail que vous faite.
Dom2623



"Philippe.R" a écrit :

> Bonjour,
> Une piste, avec ajout d'une colonne (CA pour l'exemple) dans laquelle
> tu
> copies cette formule
>
> =SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))
>
> en BJ6 et suivant, tu utilises :
>
> =SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)))
>
> et en BK
>
> =INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))
>
> --
> Avec plaisir
> http://dj.joss.free.fr/trombine.htm
> http://jacxl.free.fr/mpfe/trombino.html
> Philippe.R
> Pour se connecter au forum :
> http://www.excelabo.net/web/mpfe
> News://news.microsoft.com/microsoft.public.fr.excel
> "sabine" > news:
> > Bonjour à tous les exceliens,
> >
> > Voilà j'ai un petit problème de tri, dans mon tableau il y a une
> > colonne
> > en
> > BH6:BH97 où les cellules comporte des dates "jj/mm/aa" mais certaine
> > cellules
> > sont vides. La colonne BI6:BI97 comporte des noms propres et je
> > voudrai qu’en
> > BJ6 :BJ97 les dates se classe automatiquement de manière
> > décroissante. Et
> > dans la colonne BK :6BK97 il replace les noms propre correspondant.
> > Est-ce
> > possible de trouver une formule magique sans devoir faire appel à une
> > macro.
> > Merci d’avance pour votre aide.
> > Dom2623
> >
>
>




Philippe.R
Le #20357461
Re,

Et pour BK :

=SI(ESTNA(INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)));INDEX($BI$6:$BI$97;EQUIV(LIGNE();$CA$6:$CA$97;0));INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)))

--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Philippe.R" news:
Bonsoir Sabine,
Disons alors, en CA6 et suivantes :

=SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))+NB.SI(BH6:BH$97;BH6)-1

en BJ6 et suivantes :

=SI(ESTNA(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)));"";SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))))

je gratte encore un peu pour BK
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"sabine" news:
Bonsoir Philippe,

Je viens de m'appercevoir que lorsqu'il y a 2 dates identique en BH6 :
BH97,
le classement ne s'effectue plus. Y a t'il une solution à ce problème ?

Merci pour ton aide

dom2623


"sabine" a écrit :

Bonjour Philippe,

Je viens d'essayer tes formules, elles sont magiques. Cela fonctionne à
merveille.
Merci pour ton aide très précieuse et le travail que vous faite.
Dom2623



"Philippe.R" a écrit :

> Bonjour,
> Une piste, avec ajout d'une colonne (CA pour l'exemple) dans laquelle
> tu
> copies cette formule
>
> =SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))
>
> en BJ6 et suivant, tu utilises :
>
> =SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)))
>
> et en BK
>
> =INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))
>
> --
> Avec plaisir
> http://dj.joss.free.fr/trombine.htm
> http://jacxl.free.fr/mpfe/trombino.html
> Philippe.R
> Pour se connecter au forum :
> http://www.excelabo.net/web/mpfe
> News://news.microsoft.com/microsoft.public.fr.excel
> "sabine" > news:
> > Bonjour à tous les exceliens,
> >
> > Voilà j'ai un petit problème de tri, dans mon tableau il y a une
> > colonne
> > en
> > BH6:BH97 où les cellules comporte des dates "jj/mm/aa" mais certaine
> > cellules
> > sont vides. La colonne BI6:BI97 comporte des noms propres et je
> > voudrai qu’en
> > BJ6 :BJ97 les dates se classe automatiquement de manière
> > décroissante. Et
> > dans la colonne BK :6BK97 il replace les noms propre correspondant.
> > Est-ce
> > possible de trouver une formule magique sans devoir faire appel à
> > une
> > macro.
> > Merci d’avance pour votre aide.
> > Dom2623
> >
>
>







Philippe.R
Le #20357451
Oups !

en BK6, on préfèrera :

=SI(ESTNA(INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)));INDEX($BI$6:$BI$97;EQUIV(LIGNE()+NB.SI(BH$6:BH$97;"")-6;$CA$6:$CA$97;0));INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)))

--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Philippe.R" news:
Bonsoir Sabine,
Disons alors, en CA6 et suivantes :

=SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))+NB.SI(BH6:BH$97;BH6)-1

en BJ6 et suivantes :

=SI(ESTNA(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)));"";SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))))

je gratte encore un peu pour BK
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"sabine" news:
Bonsoir Philippe,

Je viens de m'appercevoir que lorsqu'il y a 2 dates identique en BH6 :
BH97,
le classement ne s'effectue plus. Y a t'il une solution à ce problème ?

Merci pour ton aide

dom2623


"sabine" a écrit :

Bonjour Philippe,

Je viens d'essayer tes formules, elles sont magiques. Cela fonctionne à
merveille.
Merci pour ton aide très précieuse et le travail que vous faite.
Dom2623



"Philippe.R" a écrit :

> Bonjour,
> Une piste, avec ajout d'une colonne (CA pour l'exemple) dans laquelle
> tu
> copies cette formule
>
> =SI(BH6="";NBVAL($BI$6:$BI$97);RANG(BH6;$BH$6:$BH$97))
>
> en BJ6 et suivant, tu utilises :
>
> =SI(INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))=0;"";INDEX($BH$6:$BH$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0)))
>
> et en BK
>
> =INDEX($BI$6:$BI$97;EQUIV(LIGNE()-5;$CA$6:$CA$97;0))
>
> --
> Avec plaisir
> http://dj.joss.free.fr/trombine.htm
> http://jacxl.free.fr/mpfe/trombino.html
> Philippe.R
> Pour se connecter au forum :
> http://www.excelabo.net/web/mpfe
> News://news.microsoft.com/microsoft.public.fr.excel
> "sabine" > news:
> > Bonjour à tous les exceliens,
> >
> > Voilà j'ai un petit problème de tri, dans mon tableau il y a une
> > colonne
> > en
> > BH6:BH97 où les cellules comporte des dates "jj/mm/aa" mais certaine
> > cellules
> > sont vides. La colonne BI6:BI97 comporte des noms propres et je
> > voudrai qu’en
> > BJ6 :BJ97 les dates se classe automatiquement de manière
> > décroissante. Et
> > dans la colonne BK :6BK97 il replace les noms propre correspondant.
> > Est-ce
> > possible de trouver une formule magique sans devoir faire appel à
> > une
> > macro.
> > Merci d’avance pour votre aide.
> > Dom2623
> >
>
>







Publicité
Poster une réponse
Anonyme