Trigger

Le
Vbig
Bonjour

Quelqu'un a t'il mis en place une astuce afin de connaitre les
anciennes valeurs de l'enregistrement en modification dans un trigger
'avant' ?

merci d'avance

Vincent
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Béru
Le #14644031
Vbig a couché sur son écran :
Bonjour

Quelqu'un a t'il mis en place une astuce afin de connaitre les anciennes
valeurs de l'enregistrement en modification dans un trigger 'avant' ?

merci d'avance

Vincent



Oui en créant un alias et en l'utilisant pour lire l'enregistrement (ne
marche que si sa cle unique n'a pas été modifiée bien sur)

Bon dév

Béru
Vbig
Le #14644021
Béru vient de nous annoncer :
Vbig a couché sur son écran :
Bonjour

Quelqu'un a t'il mis en place une astuce afin de connaitre les anciennes
valeurs de l'enregistrement en modification dans un trigger 'avant' ?

merci d'avance

Vincent



Oui en créant un alias et en l'utilisant pour lire l'enregistrement (ne
marche que si sa cle unique n'a pas été modifiée bien sur)

Bon dév

Béru



Merci pour votre réponse.
J'abuse en vous demandant un petit exemple ? (pour la création de
l'alias et la récupération des anciennes valeur)
Béru
Le #14644011
Vbig a pensé très fort :
Béru vient de nous annoncer :
Vbig a couché sur son écran :
Bonjour

Quelqu'un a t'il mis en place une astuce afin de connaitre les anciennes
valeurs de l'enregistrement en modification dans un trigger 'avant' ?

merci d'avance

Vincent



Oui en créant un alias et en l'utilisant pour lire l'enregistrement (ne
marche que si sa cle unique n'a pas été modifiée bien sur)

Bon dév

Béru



Merci pour votre réponse.
J'abuse en vous demandant un petit exemple ? (pour la création de l'alias et
la récupération des anciennes valeur)




//creation d'un alias pour acceder aux valeurs de l'enregistrement
avant modification
SI PAS HAlias(occPiece,occPieceAvant) ALORS
Erreur("Erreur à la création de l'alias occPièceAvant",HErreur())
FinProgramme()
FIN
//changement de nom physique pour que le nom logique de l'alias soit
sur le fichier physique occPiece
SI PAS HChangeNom(occPieceAvant,"occPiece") ALORS
Erreur("Erreur au changement du nom de l'alias
occPièceAvant",HErreur())
FinProgramme()

FIN
//lecture de la piece pour calcul du nombre de pieces terminees
HLitRecherchePremier(occPieceAvant,"idoccpiece",OccPiece.IDoccPiece)

maintenant on peut comparer les valeurs

Bon Dev

Béru
Vbig
Le #14643981
Béru avait soumis l'idée :
Vbig a pensé très fort :
Béru vient de nous annoncer :
Vbig a couché sur son écran :
Bonjour

Quelqu'un a t'il mis en place une astuce afin de connaitre les anciennes
valeurs de l'enregistrement en modification dans un trigger 'avant' ?

merci d'avance

Vincent



Oui en créant un alias et en l'utilisant pour lire l'enregistrement (ne
marche que si sa cle unique n'a pas été modifiée bien sur)

Bon dév

Béru



Merci pour votre réponse.
J'abuse en vous demandant un petit exemple ? (pour la création de l'alias
et la récupération des anciennes valeur)




//creation d'un alias pour acceder aux valeurs de l'enregistrement avant
modification
SI PAS HAlias(occPiece,occPieceAvant) ALORS
Erreur("Erreur à la création de l'alias occPièceAvant",HErreur())
FinProgramme()
FIN
//changement de nom physique pour que le nom logique de l'alias soit sur le
fichier physique occPiece
SI PAS HChangeNom(occPieceAvant,"occPiece") ALORS
Erreur("Erreur au changement du nom de l'alias occPièceAvant",HErreur())
FinProgramme()

FIN
//lecture de la piece pour calcul du nombre de pieces terminees
HLitRecherchePremier(occPieceAvant,"idoccpiece",OccPiece.IDoccPiece)

maintenant on peut comparer les valeurs

Bon Dev

Béru



Merci beaucoup :)
Publicité
Poster une réponse
Anonyme