Trigger serveur non pris en compte

Le
J-M des Grottes
Bonjour,

J'ai mis en place un trigger serveur sur un fichier.
Lorsque l'on ajoute un enregistrement dans ce fichier,on modifie la
rubrique d'un autre fichier.

Voici la procédure stockée qui est déclenchée APRES ajout:

ldMaDate est une Date
ldMaDate={H.NomFichier+".Date_DIAL",indRubrique}
ldMaDate..Jour=1
MonSite est un entier={H.NomFichier+".BASE_SITE",indRubrique}
HLitRecherche(DIALYSES_TOTALES,MoisBASE_SITE,[ldMaDate,MonSite],hIdentique)
SI HTrouve(DIALYSES_TOTALES) ALORS
DIALYSES_TOTALES.Nombre++
HModifie(DIALYSES_TOTALES)
SINON
DIALYSES_TOTALES.Mois=ldMaDate
DIALYSES_TOTALES.BASE_SITE=MonSite
DIALYSES_TOTALES.Nombre=1
HAjoute(DIALYSES_TOTALES)

FIN


Cela ne marche qu'une fois sur 2.
Pas de code d'erreur.
J'ai déjajouté une ligne avec un trace, la procédure n'est même pas
exécutée!

Quid ??


Merci

J-M des Grottes
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
marcel.berman
Le #18134661
Salut !

On 13-Dec-2008, J-M des Grottes
Bonjour,

J'ai mis en place un trigger serveur sur un fichier.
Lorsque l'on ajoute un enregistrement dans ce fichier,on modifie la
rubrique d'un autre fichier.

Voici la procédure stockée qui est déclenchée APRES ajout:

ldMaDate est une Date
ldMaDate={H.NomFichier+".Date_DIAL",indRubrique}
ldMaDate..Jour=1
MonSite est un entier={H.NomFichier+".BASE_SITE",indRubrique}
HLitRecherche(DIALYSES_TOTALES,MoisBASE_SITE,[ldMaDate,MonSite],hIdentique)
SI HTrouve(DIALYSES_TOTALES) ALORS
DIALYSES_TOTALES.Nombre++
HModifie(DIALYSES_TOTALES)
SINON
DIALYSES_TOTALES.Mois=ldMaDate
DIALYSES_TOTALES.BASE_SITE=MonSite
DIALYSES_TOTALES.Nombre=1
HAjoute(DIALYSES_TOTALES)

FIN


Cela ne marche qu'une fois sur 2.
Pas de code d'erreur.
J'ai déjajouté une ligne avec un trace, la procédure n'est même pas
exécutée!

Quid ??




Nosu avons déjà eu ce problème.
Pour ne pas mettre en danger l'intégrité de notre BDD, nous sommes revenus,
à notre corps défendant, à des triggers normaux.
Nous n'avons pas pu détecter la source du problème, mais nous n'avons pu que
constater que le déclenchement des triggers serveurs était assez aléatoire
...

Bien à toi

--
Marcel Berman
Président de Be-Dev.be (www.be-dev.be) (Belgique)
Membre du CA de Wind'Asso (www.windasso.org) (France)
Be-Dev.be et Wind'Asso sont des associations d'utilisateurs des produits
PC-Soft
J-M des Grottes
Le #18138101
a écrit :
Salut !

On 13-Dec-2008, J-M des Grottes
Bonjour,

J'ai mis en place un trigger serveur sur un fichier.
Lorsque l'on ajoute un enregistrement dans ce fichier,on modifie la
rubrique d'un autre fichier.

Voici la procédure stockée qui est déclenchée APRES ajout:

ldMaDate est une Date
ldMaDate={H.NomFichier+".Date_DIAL",indRubrique}
ldMaDate..Jour=1
MonSite est un entier={H.NomFichier+".BASE_SITE",indRubrique}
HLitRecherche(DIALYSES_TOTALES,MoisBASE_SITE,[ldMaDate,MonSite],hIdentique)
SI HTrouve(DIALYSES_TOTALES) ALORS
DIALYSES_TOTALES.Nombre++
HModifie(DIALYSES_TOTALES)
SINON
DIALYSES_TOTALES.Mois=ldMaDate
DIALYSES_TOTALES.BASE_SITE=MonSite
DIALYSES_TOTALES.Nombre=1
HAjoute(DIALYSES_TOTALES)

FIN


Cela ne marche qu'une fois sur 2.
Pas de code d'erreur.
J'ai déjajouté une ligne avec un trace, la procédure n'est même pas
exécutée!

Quid ??




Nosu avons déjà eu ce problème.
Pour ne pas mettre en danger l'intégrité de notre BDD, nous sommes revenus,
à notre corps défendant, à des triggers normaux.
Nous n'avons pas pu détecter la source du problème, mais nous n'avons pu que
constater que le déclenchement des triggers serveurs était assez aléatoire
...

Bien à toi



Grrrr... c'est assez énervant!
On peut espérer peut-être dans la 14....
Publicité
Poster une réponse
Anonyme