Trouve et longueur de mot

Le
ChristianM
Bonjour,

J'utilise la fonction "TROUVE" (CHERCHE pourrait aussi faire l'affaire) et
je butte sur un problème qui est par exemple le suivant :
dans une liste de matière premières, je cherche les produits à base de
dinde, poulets, canards, oie, etc avec comme texte cible le libellé pour
en obtenir la quantitié. Dans le cas du "foie de canard" par exemple,
j'obtiens la quantité dans la colonne "canard" mais aussi dans la colonne
"oie" car "oie" est contenu dans "foie".
Est-il possible de faire la différence ?

http://cjoint.com/?ctmlC1bfFE


Merci de votre aide

--
ChristianM
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ChristianM
Le #18691331
--
ChristianM


"ChristianM" a écrit dans le message de news:

Bonjour,

J'utilise la fonction "TROUVE" (CHERCHE pourrait aussi faire l'affaire) et
je butte sur un problème qui est par exemple le suivant :
dans une liste de matière premières, je cherche les produits à base de
dinde, poulets, canards, oie, etc... avec comme texte cible le libellé
pour en obtenir la quantitié. Dans le cas du "foie de canard" par exemple,
j'obtiens la quantité dans la colonne "canard" mais aussi dans la colonne
"oie" car "oie" est contenu dans "foie".
Est-il possible de faire la différence ?

http://cjoint.com/?ctmlC1bfFE


Merci de votre aide

--
ChristianM





isabelle
Le #18691321
bonjour Christian,

=SI(ESTERREUR(TROUVE(C$1;$A2;1));0;SI(NBCAR(C$1)=3;SI(STXT($A2;TROUVE(C$1;$A2;1)-1;1)="F";0;$B2);$B2))

isabelle

ChristianM a écrit :
Bonjour,

J'utilise la fonction "TROUVE" (CHERCHE pourrait aussi faire l'affaire) et
je butte sur un problème qui est par exemple le suivant :
dans une liste de matière premières, je cherche les produits à base de
dinde, poulets, canards, oie, etc... avec comme texte cible le libellé pour
en obtenir la quantitié. Dans le cas du "foie de canard" par exemple,
j'obtiens la quantité dans la colonne "canard" mais aussi dans la colonne
"oie" car "oie" est contenu dans "foie".
Est-il possible de faire la différence ?

http://cjoint.com/?ctmlC1bfFE


Merci de votre aide




Publicité
Poster une réponse
Anonyme