Trouver et installer les headers 2-16

Le
Olivier
Bonjour,

J'utilise debian/testing et voici ma liste de depots :
--
deb http://ftp2.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp2.fr.debian.org/debian/ testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

deb http://www.backports.org/debian/ etch-backports main contrib non-free


deb http://http.us.debian.org/debian/ testing main contrib non-free
deb-src http://http.us.debian.org/debian/ testing main contrib non-free
--

ls /lib/modules donne :
--
2.6.18-4-686 2.6.21-2-686 2.6.24-1-686 2.6.24-1-xen-686
--

Ca, c'est le contexte :-)

Ce que je veux : faire fonctionner une webcam qui demande
le module uvcvideo. Ok, je lis

http://www.lea-linux.org/cached/index/Hardware-hard_image-webcam.html#

recupère la derniere version de linux-uvc (j'ai déjà installé une
version avec synaptic) et essaie make .
Problème : il me demande /lib/modules/2.6.18-4-686/build
Bon, je me dis, je vais charger linux-headers-2.6.18-4-686,
mais synaptic ne me le propose pas --
Bon, j'essaie un line symbolique de
/lib/modules/2.6.18-4-686/build sur /lib/modules/2.6.24-1-686/build
oui, je sais, pas beau, mais ça ne marche pas.
Bon, j'essaie d'jouter le depot
deb http://security.debian.org/debian-security/ etch/updates main
mais il a besoin de linux-kbuild-2.6.18 pour l'installer et il
(apt/synaptic) refuse de me le charger --
Bon, je passe à
m-a prepare : badaboum, no headers files
Alors
m-a --kernel-dir /lib/modules/2.6.24-1-686/ prepare
no good --

De l'aide sous forme consommable me serait appréciable, comme
vous pouvez le constater :-p
Amitiés,
Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien LE LEZ
Le #6545641
On Sat, 03 May 2008 18:27:29 +0200, Olivier
J'utilise debian/testing et voici ma liste de depots :

Problème : il me demande /lib/modules/2.6.18-4-686/build


Bizarre : tu sembles avoir le noyau de Etch, sur une Lenny.

Après avoir vérifié que tu as un backup de tes données, commence par
mettre ton système à jour ("aptitude upgrade" ou "apt-get upgrade").

(Normalement, sous Debian, on a un meta-package, linux-image-2.6-686
(ou quelque chose d'approchant), dont une dépendance est le noyau 2.6
en cours.)

Autre possibilité : tu as plusieurs noyaux installés, et tu n'as pas
choisi le bon au moment du boot.

D'une manière générale, un ch'tit "dpkg -l|grep 2.6" devrait t'en dire
plus.

Olivier
Le #6545631
[...]
Bizarre : tu sembles avoir le noyau de Etch, sur une Lenny.


Evidemment, au lieu de chercher de vieux headers, mettre
un noyau moderne :-)

Ca fonctionne mieux --
Bon, j'ai compilé, je change de fil pour la suite :-)
Amitiés,
Olivier

Publicité
Poster une réponse
Anonyme