Trouver la valeur maximum en limitant le résultat à une certaine valeur

Le
Esox38
Bonsoir,

Je cherche une fonction ou un code vba me permettant d'obtenir la valeur
maximum d'une colonne mais avec une valeur critère pour la valeur maximum.

J'explique:
dans la colonne A, 10 valeurs :
5
10
12
55
48
35
65
90
100
25

La formule doit me retrouver la valeur maximum dans la colonne en
dessous de 65 par exemple soit 55.
J'ai essayer avec Max et Si mais je ne trouve pas la solution.

Merci pour vos retours
Cordialement
Esox
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #22702921
Bonsour®

"Esox38" a écrit
Je cherche une fonction ou un code vba me permettant d'obtenir la valeur
maximum d'une colonne mais avec une valeur critère pour la valeur maximum.

J'explique:
dans la colonne A, 10 valeurs :
5
10
12
55
48
35
65
90
100
25

La formule doit me retrouver la valeur maximum dans la colonne en dessous de
65 par exemple soit 55.



formule matricielle
=MAX(A1:A10*(A1:A10<65))
validation Ctrl+Maj+Entrée

HTH
Tatanka
Le #22702911
Bonsoir,

Une façon de faire en supposant tes valeurs en A1:A10
et ta valeur critère en C1.
Entre cette formule dans une cellule libre :
=MAX(SI(A1:A10<C1;A1:A10;""))
et valide par Ctrl+Maj+Entrée.

Serge

"Esox38"
Bonsoir,

Je cherche une fonction ou un code vba me permettant d'obtenir la valeur maximum d'une colonne mais avec une valeur critère pour
la valeur maximum.

J'explique:
dans la colonne A, 10 valeurs :
5
10
12
55
48
35
65
90
100
25

La formule doit me retrouver la valeur maximum dans la colonne en dessous de 65 par exemple soit 55.
J'ai essayer avec Max et Si mais je ne trouve pas la solution.

Merci pour vos retours
Cordialement
Esox
Jacky
Le #22702901
Bonsoir,

+1
=SOMMEPROD(MAX(plage*(plage<65)))

--
Salutations
JJ


"Esox38"
Bonsoir,

Je cherche une fonction ou un code vba me permettant d'obtenir la valeur maximum d'une colonne mais avec une
valeur critère pour la valeur maximum.

J'explique:
dans la colonne A, 10 valeurs :
5
10
12
55
48
35
65
90
100
25

La formule doit me retrouver la valeur maximum dans la colonne en dessous de 65 par exemple soit 55.
J'ai essayer avec Max et Si mais je ne trouve pas la solution.

Merci pour vos retours
Cordialement
Esox
Esox38
Le #22703051
Le 21/10/2010 22:35, Jacky a écrit :
Bonsoir,

+1
=SOMMEPROD(MAX(plage*(plage<65)))



Bonsoir

Merci pour vos solutions c'est parfait!

Bonne soirée
Esox
Tatanka
Le #22703041
Un peu plus court sans battre Modeste :-)
=MAX(SI(A1:A10<C1;A1:A10))



"Tatanka"
Bonsoir,

Une façon de faire en supposant tes valeurs en A1:A10
et ta valeur critère en C1.
Entre cette formule dans une cellule libre :
=MAX(SI(A1:A10<C1;A1:A10;""))
et valide par Ctrl+Maj+Entrée.

Serge

"Esox38"
Bonsoir,

Je cherche une fonction ou un code vba me permettant d'obtenir la valeur maximum d'une colonne mais avec une valeur critère pour
la valeur maximum.

J'explique:
dans la colonne A, 10 valeurs :
5
10
12
55
48
35
65
90
100
25

La formule doit me retrouver la valeur maximum dans la colonne en dessous de 65 par exemple soit 55.
J'ai essayer avec Max et Si mais je ne trouve pas la solution.

Merci pour vos retours
Cordialement
Esox




Modeste
Le #22703181
Bonsour®

a écrit
=SOMMEPROD(MAX(plage*(plage<65)))



;o)))
ça y est un chirogourdiste de plus !!!
Publicité
Poster une réponse
Anonyme