tweak UI ne garde pas les paramètres

Le
siger
Bonjour,
Avec un portable sur lequel est branché une souris à roulette en PS2
sur un adaptateur qui permet aussi de mettre un clavier en PS2, avec
XP-SP2.

J'utilise Tweak UI, ça marche, mais pas pour ce paramètre : le nombre
de lignes qui doivent défiler pour chaque cran de la roulette. Ça
marche quand je le paramètre mais au redémarrage c'est perdu.

Comment faire pour que ce paramètre soit concervé ?

--
siger
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
siger
Le #14346691
houba a écrit :

siger :



Avec un portable sur lequel est branché une souris à roulette en
PS2 sur un adaptateur qui permet aussi de mettre un clavier en
PS2, avec XP-SP2.

J'utilise Tweak UI, ça marche, mais pas pour ce paramètre : le
nombre de lignes qui doivent défiler pour chaque cran de la
roulette. Ça marche quand je le paramètre mais au redémarrage
c'est perdu.





Et dans p.config>propriétes souris>onglet roulette ?



Il n'y a pas d'onglet "roulette", ni d'option qui en parle.

--
siger
siger
Le #14346671
houba a écrit :

Verifie ces 2 clés d'une souris ps2 connectée sur un port ps2.
Mais comme tu es sur un adaptateur usb/ps2, je ne sais pas quelle
gueule elle a dans la BdR...



USB ? non, c'est un adaptateur PS2.

déclaration de souris dans la BdR
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetEnumACPIPNP0F134&26d
d0f47&0 http://www.cijoint.fr/cij60086668421643.jpg
Si ce n'est pas référencé comme sur le mien, cherche sur
mouse/souris ou PS/2 Compatible Mouse/souris ps2 comptatible ?



Ce n'est pas le même dernier chiffre, mais sinon j'ai la même chose.

paramètre de la détection de la roulette,
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetEnumACPIPNP0F134&26d
d0f47&0Device Parameters
http://www.cijoint.fr/cij81465996621641.jpg
dont la valeur de 'EnableWheelDetection' devrait être sur 2
valeur 0=désactiver la roulette
valeur 1=détecter si la souris comporte une roulette, si oui
l'activer.
valeur 2¬tiver la roulette d'office, que la souris comporte ou
non une roulette



C'est une valeur hexadécimale, la valeur est 2. J'ai redémarré afin
d'avoir le paramétrage sans l'intermédiaire de Tweak UI, la valeur est
toujours 2 et la roulette ne bouge que d'une ligne pas cran. C'est à
dire que le paramétrage de Tweak UI ne change rien à cette clé.

--
siger
siger
Le #14346641
houba a écrit :

Et là ?
HKEY_CURRENT_USERControl PanelDesktop
paramètre: WheelScrollLines
type: string
valeur: xx (nb de lignes, si 5=entrer 5; si 12=entrer 12)



C'est à 15. J'ai redémarré c'est à nouveau 15 alors que dans Tweak UI
c'est à 1. Il semble que Tweak UI prenne la main sur cette valeur et
qu'en plus il ne la conserve pas à l'arrêt de Windows.

Pourtant il me semblait que Tweak UI était une interface graphique de
la base de registre.

Merci pour la peine que tu prends :-)

--
siger
siger
Le #14346611
houba a écrit :

siger :



Pourtant il me semblait que Tweak UI était une interface graphique
de la base de registre.





Je tente une explication que je peux te garantir à 20%. ;)
Ton adaptateur/dérivateur pose pb, dans le sens où au redémarrage
win a du mal à déterminer les paramètres de ta souris dans
hkey_users (ntuser.dat du doc&settingsutilisateur courant), du
coup il a pioché dans les paramètres du ntuser.dat du
doc&settingsdefault user. Tu peux le déterminer rapidement en
l'enlevant et connectant ta souris directement sur le port ps2 de
ton portable.



J'ai fait ça et ça marche, j'ai bien 15 lignes par cran. Mais Tweak UI
indique 1.
J'ai remis le clavier et... ça marche toujours !
Tweak UI indique encore 1.

Merci pour la peine que tu prends :-)





Pad'koi, mais j'espère que tu as bien un tweakui pour xp des fois,
soit la vers 2.10 qui est affichée à la racine de la section
'about'. La 1.33 c'est pour w2k.



C'est bien la 2.10.
Bon, on ne sait pas pourquoi Tweak UI ne marche pas pour ça (il marche
pour d'autres choses) mais en tous cas, pour l'instant ça marche.

Merci :-)

--
siger
siger
Le #14346591
houba a écrit :

Alors là, sort un poulet et une bouteille de rhum blanc agricole,
uniquement du fait main certifié, on va suivre un rite...
Je m'occupe des herbes. ;)



Mmmm, pas longtemps. C'est revenu. C'est comme si le paramètre 15 de la
BdR était pris en compte au tout début, puis que Tweak UI prenne le
dessus avec son paramètre 1, au bout d'une minute, par exemple.

--
siger
siger
Le #14345871
houba a écrit :

Bon, je reprends mes herbes ...



:-)

Alors refais le même test avec la souris connectée en direct sur
le port ps2 et tu t'obligeras à utiliser le clavier du portable au
moins pendant quelques heures.
Si ca ne re-bascule pas en 1, ce serait que ton
adaptateur/dérivateur *est* le pb.



C'est pareil : juste après le démmarage, j'ai 15 ligne par cran. Puis
très vite ça passe à 1, Tweak UI reprend a main (dans dans la BdR c'est
15)

Sinon, tu pourrais toujours essayer mon raisonnement garanti à
20%.

Tu lances regedit
Tu cliques sur hkey_users
Dans le menu de regedit (suis en vers EN) tu déroules
'file/fichier'?



Il n'y a ni l'un ni l'autre ni rien qui ressemble.

et tu vas à 'load hive/charger ruche'?
Dans l'arborescence, tu vas sur documents&settings>Default user et
tu cliques sur 'ntuser.dat'.



'documents&settings' n'est pas dans la BdR.
Je n'ai trouvé 'ntuser.dat' que dans la valeur de quelques clés.

--
siger
Publicité
Poster une réponse
Anonyme