Ubuntu 11.04 et locale ISO-8859-15 semble altérer le système

Le
denis.paris
Bonjour,

Pour des raisons personnelles je souhaite configurer une machine Ubuntu
11.04 pour travailler uniquement en ISO-8859-15 au lieu de UTF-8 (accès
concurrents sur un NAS de machines Windows et de Linux)

C'est une question qui revient régulièrement sur le WEB, avec des
"bidouilles" plus ou moins propres. Voici ce que j'ai fait:

1° dans /var/lib/locales/supported.d/local
uniquement la ligne
fr_FR ISO-8859-15, puis

dpkg-reconfigure locales


2° dans /etc/defaut/locale
LANG=fr_FR.ISO-8859-15

Cela semble fonctionner, mais il n'est plus possible d'administrer les
utilisateurs et les groupes: quand je tente d'ajouter un utilisateur
(avec l'interface graphique) j'ai le message suivante:

"Vous n'êtes pas autorisé à modifier
la configuration du système
une erreur est survenue lors de la vérification des
autorisations"

Alors que normalement c'est la fenêtre de demande d'authentification.

Pour pouvoir gérer les comptes, je re-modifie le fichier
/etc/defaut/locale et je remets la ligne:

LANG="fr_FR.UTF-8"

Je me reconnecte en resél-ectionnant la bonne langue le cas échéant et
ça remarche!

Je pense que le système bute alors sur un fichier qui n'est pas au bon
format et ne va pas plus loin.

Il y a-t-il une manière "propre" de gérer ce problème?

Merci pour vos réponses éventuelles.
Publicité
Vidéos High-Tech et Jeu Vidéo
Téléchargements
  • Ubuntu Sudio est une distribution Linux orientée multimédia.
  • Ubuntu est une distribution Linux libre et gratuite basée sur Debian.
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier V
Le #23962291
denis.paris wrote:

Bonjour,

Pour des raisons personnelles je souhaite configurer une machine Ubuntu
11.04 pour travailler uniquement en ISO-8859-15 au lieu de UTF-8 (accès
concurrents sur un NAS de machines Windows et de Linux)



En ce qui me concerne, j'utilise kile avec la commande :
LC_ALL= kile "$@"

Ainsi kile travaille dans cet encodage.

À adapter peut-être ?

Olivier V
denis.paris
Le #23964721
Le 13/11/2011 18:53, Olivier V a écrit :
denis.paris wrote:

Bonjour,

Pour des raisons personnelles je souhaite configurer une machine Ubuntu
11.04 pour travailler uniquement en ISO-8859-15 au lieu de UTF-8 (accès
concurrents sur un NAS de machines Windows et de Linux)



En ce qui me concerne, j'utilise kile avec la commande :
LC_ALL= kile "$@"

Ainsi kile travaille dans cet encodage.

À adapter peut-être ?

Olivier V



OK, mais Kile est un éditeur de texte, donc une application

Je pense que chaque application doit pouvoir gérer des codages
différents, comme Thunderbird que j'utilise par exemple pour rédiger ce
message.

Mon problème est un peu différent, puisque je veux utiliser ISO-8859
directement au niveau de toutes les commandes OS, comme la création d'un
fichier quelconque sur un NAS distant auquel est relié également des
machines Windows.

Si je créé un fichier binaire nommé "Vidéo.avi" sur mon NAS, les
machines Windows verront quelque chose comme "Vid?e.avi", et
réciproquement, alors que le contenu binaire du fichier est le même. Et
les fichiers créés par les machines Windows seront vues avec
"xxxx?Codage invalide.avi".

En clair je voudrais travailler nativement en ISO au lieu de UTF-8, mais
je ne sais pas si c'est possible.
YBM
Le #23965581
Le 14.11.2011 13:16, denis.paris a écrit :
Le 13/11/2011 18:53, Olivier V a écrit :
denis.paris wrote:

Bonjour,

Pour des raisons personnelles je souhaite configurer une machine Ubuntu
11.04 pour travailler uniquement en ISO-8859-15 au lieu de UTF-8 (accès
concurrents sur un NAS de machines Windows et de Linux)



En ce qui me concerne, j'utilise kile avec la commande :
LC_ALL= kile "$@"

Ainsi kile travaille dans cet encodage.

À adapter peut-être ?

Olivier V



OK, mais Kile est un éditeur de texte, donc une application

Je pense que chaque application doit pouvoir gérer des codages
différents, comme Thunderbird que j'utilise par exemple pour rédiger ce
message.

Mon problème est un peu différent, puisque je veux utiliser ISO-8859
directement au niveau de toutes les commandes OS, comme la création d'un
fichier quelconque sur un NAS distant auquel est relié également des
machines Windows.

Si je créé un fichier binaire nommé "Vidéo.avi" sur mon NAS, les
machines Windows verront quelque chose comme "Vid?e.avi", et
réciproquement, alors que le contenu binaire du fichier est le même. Et
les fichiers créés par les machines Windows seront vues avec
"xxxx?Codage invalide.avi".

En clair je voudrais travailler nativement en ISO au lieu de UTF-8, mais
je ne sais pas si c'est possible.



AMHA il vaut mieux régler ça au niveau soit du NAS soit du montage sur
le client.
Arnaud Gomes-do-Vale
Le #23966491
"denis.paris"
Si je créé un fichier binaire nommé "Vidéo.avi" sur mon NAS, les
machines Windows verront quelque chose comme "Vid?e.avi", et
réciproquement, alors que le contenu binaire du fichier est le
même. Et les fichiers créés par les machines Windows seront vues avec
"xxxx?Codage invalide.avi".



Si je peux me permettre, utiliser autre chose que de l'ASCII (et encore,
un petit sous-ensemble, essentiellement les lettres, les chiffres , -, _
et .) pour les noms de fichiers, c'est de toute façon
casse-gueule. Après, chacun fait comme il veut. ;-)

--
Arnaud
http://blogs.glou.org/arnaud/
denis.paris
Le #23967641
Le 14/11/2011 21:20, Arnaud Gomes-do-Vale a écrit :
"denis.paris"
Si je créé un fichier binaire nommé "Vidéo.avi" sur mon NAS, les
machines Windows verront quelque chose comme "Vid?e.avi", et
réciproquement, alors que le contenu binaire du fichier est le
même. Et les fichiers créés par les machines Windows seront vues avec
"xxxx?Codage invalide.avi".



Si je peux me permettre, utiliser autre chose que de l'ASCII (et encore,
un petit sous-ensemble, essentiellement les lettres, les chiffres , -, _
et .) pour les noms de fichiers, c'est de toute façon
casse-gueule. Après, chacun fait comme il veut. ;-)




Je suis d'accord, c'est le point de vue d'un administrateur système,
mais malheureusement il y a des utilisateurs Windows qui ont la fâcheuse
habitude de nommer leurs fichiers n'importe comment (les utilisateurs de
Mac c'est pareil).

Et même si les utilisateurs étaient "raisonnables", Le contrôleur de
domaine n'est pas un Windows mais un Linux avec Samba, il sert aussi de
serveur de profiles, avec les noms par défaut des répertoires système
comme "Modèles", "Mes vidéos", etc..

Bref, les mondes Windows et Linux ne sont pas encore prêts à cohabiter
simplement.
denis.paris
Le #23967751
Le 14/11/2011 16:53, YBM a écrit :
Le 14.11.2011 13:16, denis.paris a écrit :
Le 13/11/2011 18:53, Olivier V a écrit :
denis.paris wrote:

Bonjour,

Pour des raisons personnelles je souhaite configurer une machine Ubuntu
11.04 pour travailler uniquement en ISO-8859-15 au lieu de UTF-8 (accès
concurrents sur un NAS de machines Windows et de Linux)



En ce qui me concerne, j'utilise kile avec la commande :
LC_ALL= kile "$@"

Ainsi kile travaille dans cet encodage.

À adapter peut-être ?

Olivier V



OK, mais Kile est un éditeur de texte, donc une application

Je pense que chaque application doit pouvoir gérer des codages
différents, comme Thunderbird que j'utilise par exemple pour rédiger ce
message.

Mon problème est un peu différent, puisque je veux utiliser ISO-8859
directement au niveau de toutes les commandes OS, comme la création d'un
fichier quelconque sur un NAS distant auquel est relié également des
machines Windows.

Si je créé un fichier binaire nommé "Vidéo.avi" sur mon NAS, les
machines Windows verront quelque chose comme "Vid?e.avi", et
réciproquement, alors que le contenu binaire du fichier est le même. Et
les fichiers créés par les machines Windows seront vues avec
"xxxx?Codage invalide.avi".

En clair je voudrais travailler nativement en ISO au lieu de UTF-8, mais
je ne sais pas si c'est possible.



AMHA il vaut mieux régler ça au niveau soit du NAS soit du montage sur
le client.







Je n'ai pas tout dit mais il y a aussi un serveur de profiles sous
Samba, un contrôleur de domaine, etc.. On ne peut pas tout changer sur
tous les clients, dont certains occasionnels...

Et puis c'est précisément que je cherche à faire, régler le problème au
niveau de mon client Linux. La manip que je décris a fonctionné avec un
version Ubuntu 9.04, sans effet de bord contrairement à la v.11.04 qui à
de gros effet secondaires:

- le gestionnaire des utilisateurs ne fonctionne plus (mode graphique)

- GNOME fonctionne mal: une fois sur deux le bureau est totalement vide,
il faut le lancer en mode sans échec pour avoir les menus, puis en le
relançant ça passe parfois.
Sergio
Le #23968591
Le 15/11/2011 10:30, denis.paris a écrit :

Si je peux me permettre, utiliser autre chose que de l'ASCII (et encore,
un petit sous-ensemble, essentiellement les lettres, les chiffres , -, _
et .) pour les noms de fichiers, c'est de toute façon
casse-gueule. Après, chacun fait comme il veut. ;-)



Je suis d'accord, c'est le point de vue d'un administrateur système, mais malheureusement il y a des utilisateurs Windows qui ont la
fâcheuse habitude de nommer leurs fichiers n'importe comment (les utilisateurs de Mac c'est pareil).



Ben non. À moins d'être le BOFH, il n'y a aucune raison de ne pas permettre les caractères spéciaux dans les noms de fichiers.

Et même si les utilisateurs étaient "raisonnables", Le contrôleur de domaine n'est pas un Windows mais un Linux avec Samba, il sert
aussi de serveur de profiles, avec les noms par défaut des répertoires système comme "Modèles", "Mes vidéos", etc..

Bref, les mondes Windows et Linux ne sont pas encore prêts à cohabiter simplement.



Normalement, on doit y arriver... (me rappelle plus comment...).

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Fabien LE LEZ
Le #23970131
On Tue, 15 Nov 2011 10:30:59 +0100, "denis.paris" :

Bref, les mondes Windows et Linux ne sont pas encore prêts à cohabiter
simplement.



Honnêtement, je n'ai jamais rencontré de problèmes du côté des noms de
fichiers. Windows (2000, XP, Vista, 7) cause en UTF-16 ; Linux stocke
les noms de fichiers en UTF-8 ; et Samba se charge de faire les
conversions nécessaires.
Évidemment, si le serveur Linux est configuré pour travailler en autre
chose qu'UTF-8, tu es dans la merde.
erwan
Le #23970171
Fabien LE LEZ
On Tue, 15 Nov 2011 10:30:59 +0100, "denis.paris" :

Bref, les mondes Windows et Linux ne sont pas encore prêts à cohabiter
simplement.



Honnêtement, je n'ai jamais rencontré de problèmes du côté des noms de
fichiers. Windows (2000, XP, Vista, 7) cause en UTF-16 ; Linux stocke
les noms de fichiers en UTF-8 ; et Samba se charge de faire les
conversions nécessaires.
Évidemment, si le serveur Linux est configuré pour travailler en autre
chose qu'UTF-8, tu es dans la merde.



Linux est en UTF-8 Forme Normale Composée. Un mac est en UTF-8 Forme
Normale décomposée.

Ça peut amaner des trucs étranges...


--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
cLx
Le #23970201
On 15/11/2011 20:17, Fabien LE LEZ wrote:
On Tue, 15 Nov 2011 10:30:59 +0100, "denis.paris" :

Bref, les mondes Windows et Linux ne sont pas encore prêts à cohabiter
simplement.



Honnêtement, je n'ai jamais rencontré de problèmes du côté des noms de
fichiers. Windows (2000, XP, Vista, 7) cause en UTF-16 ; Linux stocke
les noms de fichiers en UTF-8 ; et Samba se charge de faire les
conversions nécessaires.
Évidemment, si le serveur Linux est configuré pour travailler en autre
chose qu'UTF-8, tu es dans la merde.



Comment on fait pour vérifier quel charset est utilisé pour le système de
fichiers d'ailleurs ?
Publicité
Suivre les réponses
Poster une réponse
Anonyme