Udev, carte son et webcam...

Le
David BERCOT
--Sig_/3Msu=kqKHbV.lNDISvOy8=s
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Je viens de réinstaller mon système et je retrouve un "vieux" pro=
blème
qui était réglé depuis longtemps
Si, au démarrage de mon portable, la webcam n'est pas branchée, t=
out
roule : j'ai du son correctement
En revanche, si la webcam est là, ça ne marche plus

Pour résoudre ce problème, j'avais fait un /etc/modprobe.d/sound =
avec :
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
Mais là, ça ne fonctionne plus

D'autre part, si je lance alsaconf, il me dit que je ferais mieux
d'utiliser udev (que je ne connais pas du tout)

Pour info, si je fais maintenant un cat /proc/asound/cards, j'ai
seulement :
0 [U0x46d0x8ad ]: USB-Audio - USB Device 0x46d:0x8ad
USB Device 0x46d:0x8ad at usb-0000:00:1d.0-2,
full speed

Avant l'alsaconf, j'avais aussi 2 autres lignes (l'une sur la carte son
et l'autre sur le modem).

Bref, auriez-vous une piste pour moi ? Des liens ? Des exemples ?

Merci d'avance.

David.

--Sig_/3Msu=kqKHbV.lNDISvOy8=s
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

--BEGIN PGP SIGNATURE--
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHYXWcvSnthbGI8ygRArqgAKCTEHRLmP3ODwCMpxGulrahcCxjDwCfRaXG
CoLlWqf4XlVsswykoZ690ok=
=z6B9
--END PGP SIGNATURE--

--Sig_/3Msu=kqKHbV.lNDISvOy8=s--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Le Gall
Le #9636961
On 13-12-2007, David BERCOT
--Sig_/3Msu=kqKHbV.lNDISvOy8=s
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Je viens de réinstaller mon système et je retrouve un "vieux" pro > blème
qui était réglé depuis longtemps...
Si, au démarrage de mon portable, la webcam n'est pas branchée, t > out
roule : j'ai du son correctement...
En revanche, si la webcam est là, ça ne marche plus...

Pour résoudre ce problème, j'avais fait un /etc/modprobe.d/sound > avec :
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
Mais là, ça ne fonctionne plus...

D'autre part, si je lance alsaconf, il me dit que je ferais mieux
d'utiliser udev (que je ne connais pas du tout)...

Pour info, si je fais maintenant un cat /proc/asound/cards, j'ai
seulement :
0 [U0x46d0x8ad ]: USB-Audio - USB Device 0x46d:0x8ad
USB Device 0x46d:0x8ad at usb-0000:00:1d.0-2,
full speed

Avant l'alsaconf, j'avais aussi 2 autres lignes (l'une sur la carte son
et l'autre sur le modem).

Bref, auriez-vous une piste pour moi ? Des liens ? Des exemples ?




Je m'avance un peu, parceque j'utilise la même astuce que toi, mais je
pense que tu devrais prendre exemple sur les fichiers suivants, que tu
dois pouvoir trouver sur ton systeme:
/etc/udev/rules.d/z25_persistent-net.rules
/etc/udev/rules.d/z25_persistent-cd.rules

Ces régles sont générées de telle façon à ce que ton système réattribue
systématiquement les mêmes devices au même matériel (entre les cartes
réseaux et les lecteurs CD).

Peut être que tu peux t'en inspirer pour écrire des règles qui matchent
tes périphériques et leurs assignent les mêmes devices (ALSA).

Cdlt,
Sylvain Le Gall


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David BERCOT
Le #9636931
--Sig_/_1CIpV4LvOl9YUAWJcxhbJ5
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Re-bonjour,

Je progresse ;-)
Donc, suite à tout ça, j'ai créé 2 règles udev qui me permettent
d'avoir maintenant /dev/webcam et /dev/carte_son.
Mais la nouvelle question est : comment utiliser ça ???

Mais ça avance ;-)

Merci.

David.

Le Thu, 13 Dec 2007 19:16:11 +0000 (UTC),
Sylvain Le Gall
On 13-12-2007, David BERCOT > --Sig_/3Msu=kqKHbV.lNDISvOy8=s
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: quoted-printable
>
> Bonjour,
>
> Je viens de réinstaller mon système et je retrouve un
> "vieux" pro= blème
> qui était réglé depuis longtemps...
> Si, au démarrage de mon portable, la webcam n'est pas
> branchée, t= out
> roule : j'ai du son correctement...
> En revanche, si la webcam est là, ça ne marche plus...
>
> Pour résoudre ce problème, j'avais fait
> un /etc/modprobe.d/sound = avec :
> alias snd-card-0 snd-intel8x0
> options snd-intel8x0 index=0
> Mais là, ça ne fonctionne plus...
>
> D'autre part, si je lance alsaconf, il me dit que je ferais mieux
> d'utiliser udev (que je ne connais pas du tout)...
>
> Pour info, si je fais maintenant un cat /proc/asound/cards, j'ai
> seulement :
> 0 [U0x46d0x8ad ]: USB-Audio - USB Device 0x46d:0x8ad
> USB Device 0x46d:0x8ad at usb-0000:00:1d.0-2,
> full speed
>
> Avant l'alsaconf, j'avais aussi 2 autres lignes (l'une sur la carte
> son et l'autre sur le modem).
>
> Bref, auriez-vous une piste pour moi ? Des liens ? Des exemples ?
>

Je m'avance un peu, parceque j'utilise la même astuce que toi, mais je
pense que tu devrais prendre exemple sur les fichiers suivants, que tu
dois pouvoir trouver sur ton systeme:
/etc/udev/rules.d/z25_persistent-net.rules
/etc/udev/rules.d/z25_persistent-cd.rules

Ces régles sont générées de telle façon à c e que ton système
réattribue systématiquement les mêmes devices au même matériel (entre
les cartes réseaux et les lecteurs CD).

Peut être que tu peux t'en inspirer pour écrire des règles qui
matchent tes périphériques et leurs assignent les mêmes de vices
(ALSA).

Cdlt,
Sylvain Le Gall





--Sig_/_1CIpV4LvOl9YUAWJcxhbJ5
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHYZstvSnthbGI8ygRAvvRAJ0RHPsoKSBYUArMOn4W2JBvlUBErQCfQBgx
Crqw2TpVE3lw6+8HrwpCBuY =tlwo
-----END PGP SIGNATURE-----

--Sig_/_1CIpV4LvOl9YUAWJcxhbJ5--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Le Gall
Le #9636771
Bonjour,

On 13-12-2007, David BERCOT
--Sig_/_1CIpV4LvOl9YUAWJcxhbJ5
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Re-bonjour,

Je progresse ;-)
Donc, suite à tout ça, j'ai créé 2 règles udev qui > me permettent
d'avoir maintenant /dev/webcam et /dev/carte_son.
Mais la nouvelle question est : comment utiliser ça ???




Je pense qu'une petite page web vous permettra de résoudre tout ca (pour
udev + ALSA en tout cas):
http://alsa.opensrc.org/index.php/Udev

Cdlt,
Sylvain Le Gall


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David BERCOT
Le #9636751
--Sig_/j++JRF2nsLE0xtc/KitDleP
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Apparemment, le simple fait de rajouter mes règles fait que tout
fonctionne... Mais je vais vérifier encore ;-)

Maintenant, concernant udev, j'ai encore quelques questions. Ainsi, je
fais :
SUBSYSTEM=="sound", ATTRS{dev}=="116:0", SYMLINK="carte_son"
SUBSYSTEM=="sound", ATTRS{dev}=="116:32", SYMLINK="modem"
Ce qui fonctionne très bien...
Mais je me disais que j'aurais pu forcer le nom (en
l'occurence /dev/sound/controlC0 et C1).
Si je modifie mes lignes comme ça :
SUBSYSTEM=="sound", ATTRS{dev}=="116:0",
NAME="controlC1", SYMLINK="carte_son"
SUBSYSTEM=="sound", ATTRS{dev}=="116:32",
NAME="controlC0", SYMLINK="modem"
ça ne marche pas (bien sûr, dans la réalité, je mets C0 pour la carte
son et C1 pour le modem, mais c'est juste pour les tests).

Est-ce que ça vient de ma syntaxe ou bien est-ce que ce n'est pas
possible ?

Merci.

David.

P.S. : tant qu'à utiliser tout ça, autant en profiter pour appren dre ;-)

Le Fri, 14 Dec 2007 14:41:06 +0000 (UTC),
Sylvain Le Gall
Bonjour,

On 13-12-2007, David BERCOT > --Sig_/_1CIpV4LvOl9YUAWJcxhbJ5
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: quoted-printable
>
> Re-bonjour,
>
> Je progresse ;-)
> Donc, suite à tout ça, j'ai créé 2 règles
> udev qui= me permettent
> d'avoir maintenant /dev/webcam et /dev/carte_son.
> Mais la nouvelle question est : comment utiliser ça ???
>

Je pense qu'une petite page web vous permettra de résoudre tout ca
(pour udev + ALSA en tout cas):
http://alsa.opensrc.org/index.php/Udev

Cdlt,
Sylvain Le Gall





--Sig_/j++JRF2nsLE0xtc/KitDleP
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHYq1CvSnthbGI8ygRAjrfAJ4y9yUj064hkvynadms/+sneulrRgCgrV+W
APmmzWQgXHDd5B//6iYorMI ÏPu
-----END PGP SIGNATURE-----

--Sig_/j++JRF2nsLE0xtc/KitDleP--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Frédéric BOITEUX
Le #9636731
Le ven 14 déc 2007 17:20:12 CET, David BERCOT a écrit :


Si je modifie mes lignes comme ça :
SUBSYSTEM=="sound", ATTRS{dev}=="116:0",
NAME="controlC1", SYMLINK="carte_son"
SUBSYSTEM=="sound", ATTRS{dev}=="116:32",
NAME="controlC0", SYMLINK="modem"
ça ne marche pas (bien sûr, dans la réalité, je mets C0 pour la c arte
son et C1 pour le modem, mais c'est juste pour les tests).



Ce ne serait pas :
SUBSYSTEM=="sound", ATTRS{dev}=="116:0", NAME="sound/controlC1", SYMLINK="carte_son"

Fred.
David BERCOT
Le #9636021
--Sig_/hEMI/EGXPqGMRP7wSTmPbkO
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Je réponds un peu en retard...

> Si je modifie mes lignes comme ça :
> SUBSYSTEM=="sound", ATTRS{dev}=="116:0",
> NAME="controlC1", SYMLINK="carte_son"
> SUBSYSTEM=="sound", ATTRS{dev}=="116:32",
> NAME="controlC0", SYMLINK="modem"
> ça ne marche pas (bien sûr, dans la réalité, je met s C0 pour la
> carte son et C1 pour le modem, mais c'est juste pour les tests).

Ce ne serait pas :
SUBSYSTEM=="sound", ATTRS{dev}=="116:0", NAME="sound/controlC1",
SYMLINK="carte_son"



En effet, ça paraît plus logique ;-)
Mais j'ai essayé et... pas mieux :-(

David.

--Sig_/hEMI/EGXPqGMRP7wSTmPbkO
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHaPM9vSnthbGI8ygRAhstAJsFT5tIBOkfld+6Zj5tpBLmgpddJwCeNPPv
UstaPBwFQsVLJjly2fzoYLY =S4ew
-----END PGP SIGNATURE-----

--Sig_/hEMI/EGXPqGMRP7wSTmPbkO--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Frédéric BOITEUX
Le #9636011
Le mer 19 déc 2007 11:32:13 CET, David BERCOT écrit :

Bonjour,

Je réponds un peu en retard...


...
> Ce ne serait pas :
> SUBSYSTEM=="sound", ATTRS{dev}=="116:0", NAME="sound/controlC 1",
> SYMLINK="carte_son"

En effet, ça paraît plus logique ;-)
Mais j'ai essayé et... pas mieux :-(



Attention, dans ta ligne : il faut des signes « égal » en double ! Do nc
« NAME=="sound/controlC1" » et non « NAME="sound/controlC1" »
De plus, je mettrais « SYMLINK+="carte_son" » pour que d'autres règ les
éventuelles puissent s'appliquer...

Ensuite, pour recharger les règles, il y a 2 commandes à faire ...
udevtrigger je crois, et un /etc/init.d/udev reload (de mémoire, à
vérifier)...

Fred.
David BERCOT
Le #9635941
--Sig_/3YTO5X3lLPz6YrlYLR+EtHB
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Re-bonjour,

> > Ce ne serait pas :
> > SUBSYSTEM=="sound", ATTRS{dev}=="116:0", NAME="sound/contro lC1",
> > SYMLINK="carte_son"
>
> En effet, ça paraît plus logique ;-)
> Mais j'ai essayé et... pas mieux :-(

Attention, dans ta ligne : il faut des signes « égal » en double !
Donc « NAME=="sound/controlC1" » et non « NAME="soun d/controlC1" »
De plus, je mettrais « SYMLINK+="carte_son" » pour que d'autr es règles
éventuelles puissent s'appliquer...

Ensuite, pour recharger les règles, il y a 2 commandes à faire ...
udevtrigger je crois, et un /etc/init.d/udev reload (de mémoire, à  
vérifier)...



Concernant les double "=", j'ai essayé avec et sans, sans que ç a change
quoi que ce soit...
Suite à udevtrigger et udev reload, j'ai bien mon symlink si l'option
"name" n'est pas là, et sinon, je n'ai rien !!!

J'en profite pour poser 2 ou 3 questions de plus sur udev ;-)
1. Parfois, je vois des simple "=" et parfois des doubles. Quelle est
la différence (dans ce cas-là) ? Est-ce lié à une attri bution ou une
comparaison (comme en programmation) ?
2. Que fait le += ?
3. Pour une autre périphérique (téléphone portable bran ché en USB), je
lance un script via udev. Ca marche bien au branchement, mais par au
retrait... Y'a-t-il des choses particulières à faire ?

Merci d'avance (même pour une seule réponse ;-))).

David.

--Sig_/3YTO5X3lLPz6YrlYLR+EtHB
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHaSWjvSnthbGI8ygRAshmAKCK6W9A0WXk7z++leSR6szGrMeqRwCfT37o
Lb5eBrMQOXbNX5sjlQ+v3TI =wvvz
-----END PGP SIGNATURE-----

--Sig_/3YTO5X3lLPz6YrlYLR+EtHB--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Frédéric BOITEUX
Le #9635891
Le mer 19 déc 2007 15:07:31 CET, David BERCOT écrit :

Concernant les double "=", j'ai essayé avec et sans, sans que ça ch ange
quoi que ce soit...
Suite à udevtrigger et udev reload, j'ai bien mon symlink si l'option
"name" n'est pas là, et sinon, je n'ai rien !!!


bizarre, mais bon, cela dépend aussi ... de la version d'udev (et du
noyau)...

J'en profite pour poser 2 ou 3 questions de plus sur udev ;-)



1. Parfois, je vois des simple "=" et parfois des doubles. Quelle est
la différence (dans ce cas-là) ? Est-ce lié à une attribution ou une
comparaison (comme en programmation) ?


La syntaxe a changée au cours du dév.t d'udev, je ne connais pas les
détails... mais tu en sauras sûrement plus là :
http://www.reactivated.net/writing_udev_rules.html

2. Que fait le += ?


je crois qu'il sert à indiquer à udev de continuer à lire ses autres
règles même lorsque la tienne correspondait.

3. Pour une autre périphérique (téléphone portable branché en U SB), je
lance un script via udev. Ca marche bien au branchement, mais par au
retrait... Y'a-t-il des choses particulières à faire ?


là, je sèche...


Fred.
David BERCOT
Le #9635711
--Sig_/gU+iCI9SK3_1xYNt1Ltg=lD
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Et bien grâce à toi, j'ai beaucoup avancé ;-)

Le Wed, 19 Dec 2007 16:22:25 +0100,
Frédéric BOITEUX
Le mer 19 déc 2007 15:07:31 CET, David BERCOT écrit :
> Concernant les double "=", j'ai essayé avec et sans, sans que ça
> change quoi que ce soit...
> Suite à udevtrigger et udev reload, j'ai bien mon symlink si
> l'option "name" n'est pas là, et sinon, je n'ai rien !!!
bizarre, mais bon, cela dépend aussi ... de la version d'udev (et du
noyau)...



Alors en fait, j'avais un S de trop à la fin de ATTR. Dans le lien que
tu donnes plus bas, il est bien expliqué qu'on utilise '==' pour la
consultation et '=' pour l'attribution, donc, pour name par exemple...

> J'en profite pour poser 2 ou 3 questions de plus sur udev ;-)
> 1. Parfois, je vois des simple "=" et parfois des doubles. Quelle
> est la différence (dans ce cas-là) ? Est-ce lié à u ne attribution
> ou une comparaison (comme en programmation) ?
La syntaxe a changée au cours du dév.t d'udev, je ne connais pa s les
détails... mais tu en sauras sûrement plus là :
http://www.reactivated.net/writing_udev_rules.html



Page très claire !!! Merci.

> 2. Que fait le += ?
je crois qu'il sert à indiquer à udev de continuer à lire ses autres
règles même lorsque la tienne correspondait.
> 3. Pour une autre périphérique (téléphone portable branché en USB),
> je lance un script via udev. Ca marche bien au branchement, mais
> par au retrait... Y'a-t-il des choses particulières à faire ?
là, je sèche...



Maintenant, j'ai juste des problèmes de nommage des points de montage
(disques externes & carte MMC). J'ai fait pas mal de recherches sur
Google, sans succès (on parle bien d'udev pour le nommage dans /dev,
mais ça, c'est ok). Il semblerait que ce soit plutôt hal qui gà ¨re ça
(je suis sous Gnome), mais je ne trouve rien hormis l'attribution d'un
label au dit périphérique (ce qui ne me convient guère) car gnome
utilise ce label pour le nommage.

Bref, quelqu'un aurait-il quelques tuyaux pour la spécification des
noms dans /media ?

Merci d'avance.

David.

--Sig_/gU+iCI9SK3_1xYNt1Ltg=lD
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHakM0vSnthbGI8ygRAg+TAKChHEi6uLRANZ/VL6znVpj9TB746QCghty2
rqB+QSPKyALNSbLoOQbJVSM Ëym
-----END PGP SIGNATURE-----

--Sig_/gU+iCI9SK3_1xYNt1Ltg=lD--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme