unable to connect to X server

Le
hervest
Bonjour,
En faisant la maintenance de mon freebsd avec pkgdb -F, je crois avoir supprimé une dépendance et après avoir redémarrer je n'arrive plus à faire démarrer mon système (startx). j'ai cette erreur

"unable to connect to X server"

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick Lamaizière
Le #20519191
hervest :

En faisant la maintenance de mon freebsd avec pkgdb -F, je crois avoir supprimé
une dépendance et après avoir redémarrer je n'arrive plus à faire démarrer mon
système (startx). j'ai cette erreur

"unable to connect to X server"



Y'a quelque chose dans /var/log/Xorg.0.log ?
hervest
Le #20521571
hervest a écrit le 09/11/2009 à 09h03 :
Bonjour,
En faisant la maintenance de mon freebsd avec pkgdb -F, je crois avoir
supprimé une dépendance et après avoir redémarrer
je n'arrive plus à faire démarrer mon système (startx).
j'ai cette erreur

"unable to connect to X server"

Merci


X.Org X Server 1.6.1
Release Date: 2009-4-14
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 7.2-RELEASE-p2 i386
Current Operating System: FreeBSD hm.seno.com 7.2-RELEASE-p2 FreeBSD 7.2-RELEASE-p2 #0: Wed Jun 24 00:57:44 UTC 2009 :/usr/obj/usr/src/sys/GENERIC i386
Build Date: 09 November 2009 03:02:06AM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 9 14:08:00 2009
(II) Loader magic: 0x6a0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on freebsd
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9

(--) PCI:*(:0:0) ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] rev 0, Mem @ 0xd0000000/134217728, 0xffcf0000/65536, I/O @ 0x0000b000/256, BIOS @ 0x????????/65536
(==) Using default built-in configuration (30 lines)
(==) --- Start of built-in configuration ---
Section "Device"
Identifier "Builtin Default ati Device 0"
Driver "ati"
EndSection
Section "Screen"
Identifier "Builtin Default ati Screen 0"
Device "Builtin Default ati Device 0"
EndSection
Section "Device"
Identifier "Builtin Default vesa Device 0"
Driver "vesa"
EndSection
Section "Screen"
Identifier "Builtin Default vesa Screen 0"
Device "Builtin Default vesa Device 0"
EndSection
Section "Device"
Identifier "Builtin Default fbdev Device 0"
Driver "fbdev"
EndSection
Section "Screen"
Identifier "Builtin Default fbdev Screen 0"
Device "Builtin Default fbdev Device 0"
EndSection
Section "ServerLayout"
Identifier "Builtin Default Layout"
Screen "Builtin Default ati Screen 0"
Screen "Builtin Default vesa Screen 0"
Screen "Builtin Default fbdev Screen 0"
EndSection
(==) --- End of built-in configuration ---
(==) ServerLayout "Builtin Default Layout"
(**) |-->Screen "Builtin Default ati Screen 0" (0)
(**) | |-->Monitor "<default monitor>"
(**) | |-->Device "Builtin Default ati Device 0"
(==) No monitor specified for screen "Builtin Default ati Screen 0".
Using a default monitor configuration.
(**) |-->Screen "Builtin Default vesa Screen 0" (1)
(**) | |-->Monitor "<default monitor>"
(**) | |-->Device "Builtin Default vesa Device 0"
(==) No monitor specified for screen "Builtin Default vesa Screen 0".
Using a default monitor configuration.
(**) |-->Screen "Builtin Default fbdev Screen 0" (2)
(**) | |-->Monitor "<default monitor>"
(**) | |-->Device "Builtin Default fbdev Device 0"
(==) No monitor specified for screen "Builtin Default fbdev Screen 0".
Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
/usr/local/lib/X11/fonts/misc/,
/usr/local/lib/X11/fonts/TTF/,
/usr/local/lib/X11/fonts/OTF,
/usr/local/lib/X11/fonts/Type1/,
/usr/local/lib/X11/fonts/100dpi/,
/usr/local/lib/X11/fonts/75dpi/,
built-ins
(==) ModulePath set to "/usr/local/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) System resource ranges:
[0] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[1] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[2] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[3] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[4] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) LoadModule: "extmod"
(II) Loading /usr/local/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/local/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX disabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/local/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "ati"
(II) Loading /usr/local/lib/xorg/modules/drivers//ati_drv.so
(II) Module ati: vendor="X.Org Foundation"
compiled for 1.4.0, module version = 6.7.195
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 2.0
(EE) module ABI major version (2) doesn't match the server's version (5)
(II) UnloadModule: "ati"
(II) Unloading /usr/local/lib/xorg/modules/drivers//ati_drv.so
(EE) Failed to load module "ati" (module requirement mismatch, 0)
(II) LoadModule: "vesa"
(II) Loading /usr/local/lib/xorg/modules/drivers//vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
compiled for 1.4.0, module version = 1.3.0
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 2.0
(EE) module ABI major version (2) doesn't match the server's version (5)
(II) UnloadModule: "vesa"
(II) Unloading /usr/local/lib/xorg/modules/drivers//vesa_drv.so
(EE) Failed to load module "vesa" (module requirement mismatch, 0)
(II) LoadModule: "fbdev"
(WW) Warning, couldn't open module fbdev
(II) UnloadModule: "fbdev"
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
Patrick Lamaizière
Le #20527631
hervest :

Bonjour,
En faisant la maintenance de mon freebsd avec pkgdb -F, je crois avoir
supprimé une dépendance et après avoir redémarrer





Tu n'aurais pas plutôt fait une mise à jour de X ?

(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.



Il faut que hald tourne (ou le désactiver)
http://www.diablotins.org/index.php/X11:_interface_graphique#HAL.2C_non_merci


(EE) module ABI major version (2) doesn't match the server's version (5)



Tu as des drivers X qui n'ont pas la même version que le serveur X.
Soit X est plus récent, soit il est plus vieux. Tu devrais reconstruire
tout X pour être sûr.
Publicité
Poster une réponse
Anonyme