unmet dependencies:libgcc1:i386 libc6:i386

Le
admini
bonjour la liste:

j'ai un problème très ennuyeux avec les dépendances multiarche

je suis sous wheezy@3.2.0-4-amd64.

il y a qqs temps, j'ai du installer des choses en i386 pour faire des
tests. un récent upgrade ma sorti les erreurs suivantes:

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6 : Breaks: libc6:i386 (!= 2.13-38) but 2.13-37 is installed
libc6:i386 : Depends: libc-bin:i386 (= 2.13-37)
Recommends: libc6-i686:i386 but it is not installed
Breaks: libc6 (!= 2.13-37) but 2.13-38 is installed
E: Unmet dependencies. Try using -f
--
-et apt-get install -f donne
-
The following extra packages will be installed:
libc6:i386
Suggested packages:
glibc-doc:i386 locales:i386
Recommended packages:
libc6-i686:i386
The following packages will be upgraded:
libc6:i386
1 upgraded, 0 newly installed, 0 to remove and 46 not upgraded.
2 not fully installed or removed.
Need to get 0 B/3939 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]?
Preconfiguring packages
(Reading database 51121 files and directories currently installed.)
Preparing to replace libc6:i386 2.13-37 (using
/libc6_2.13-38_i386.deb)

LD_LIBRARY_PATH contains the traditional /lib directory,
but not the multiarch directory /lib/i386-linux-gnu.
It is not safe to upgrade the C library in this situation;
please remove the /lib/directory from LD_LIBRARY_PATH and
try again.

dpkg: error processing /var/cache/apt/archives/libc6_2.13-38_i386.deb
(--unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.13-38_i386.deb
--

export
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnu

n'améliore pas les choses,

j'ai viré, /etc/ld.so.conf.d/x86_64-linux-gnu.conf et faire un ldconfig
-f /etc/ld.so.conf, rien ne change.

j'ai voulu virer

libc6:i386


dpkg -r 'libc6:i386'
dpkg: dependency problems prevent removal of libc6:i386:
libgcc1:i386 depends on libc6 (>= 2.2.4).


puis


dpkg -r libgcc1:i386
dpkg: dependency problems prevent removal of libgcc1:i386:
libc6:i386 depends on libgcc1; however:
Package libgcc1:i386 is to be removed



c'est le chien qui se mord la queue. avant que je procède une
réinstallation, ce qui est très bête sous linux, quelles sont vos
suggestions?

une commande magique?
attendre la prochaine upgrade magique?

d'avance merci

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/512DD1D7.6030000@freeatome.com
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain L. Sauvage
Le #25250992
Le mercredi 27 février 2013 à 10:28:55, admini a écrit :
bonjour la liste:



’jour,

[…]
please remove the /lib/directory from LD_LIBRARY_PATH and
try again.
[…]
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib/x86_64-linux-gnu:/usr/l
ib/x86_64-linux-gnu

n'améliore pas les choses,



Euh… ils disent de virer /lib du LD_LIBRARY_PATH, pas
d’ajouter /lib/x86_64…

(Note que je ne sais pas si le LD_LIBRAIRY_PATH dont il est
question est celui de ton environnement ou s’il s’agit d⠀™une
valeur utilisée par un des outils Debian au passage…)

[…]
dpkg -r libc6:i386
[…]
libgcc1:i386 depends on libc6 (>= 2.2.4).
[…]
dpkg -r libgcc1:i386
[…]
libc6:i386 depends on libgcc1; however:
[…]
c'est le chien qui se mord la queue. avant que je procède une
réinstallation, ce qui est très bête sous linux, quelles s ont
vos suggestions? […]



Euh, essayer de virer tout le monde en même temps ?
dpkg --purge libc6:i386 libgcc1:i386

ou essayer avec des outils plus malins qui savent mieux gérer
les dépendances (apt-get ou aptitude) ?

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
admini
Le #25263372
Le 27/02/2013 16:04, Sylvain L. Sauvage a écrit :
Le mercredi 27 février 2013 à 10:28:55, admini a écrit :
bonjour la liste:


’jour,

[…]
please remove the /lib/directory from LD_LIBRARY_PATH and
try again.
[…]
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib/x86_64-linux-gnu:/usr/l
ib/x86_64-linux-gnu

n'améliore pas les choses,


Euh… ils disent de virer /lib du LD_LIBRARY_PATH, pas
d’ajouter /lib/x86_64…

(Note que je ne sais pas si le LD_LIBRAIRY_PATH dont il est
question est celui de ton environnement ou s’il s’agit d’une
valeur utilisée par un des outils Debian au passage…)

[…]
dpkg -r libc6:i386
[…]
libgcc1:i386 depends on libc6 (>= 2.2.4).
[…]
dpkg -r libgcc1:i386
[…]
libc6:i386 depends on libgcc1; however:
[…]
c'est le chien qui se mord la queue. avant que je procède une
réinstallation, ce qui est très bête sous linux, quelles sont
vos suggestions? […]


Euh, essayer de virer tout le monde en même temps ?
dpkg --purge libc6:i386 libgcc1:i386



apt-get remove libc6:i386 libgcc1:i386

permet de résoudre le problème en effet. merci encore


ou essayer avec des outils plus malins qui savent mieux gérer
les dépendances (apt-get ou aptitude) ?




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme