Upgrade Jessie : problème avec SMB et NFS

Le
Nicolas FRANCOIS
Salut.

Après passage à Jessie, j'ai quelques problèmes de rése=
au :
- j'ai déjà parlé de aMule qui se trouve en lowID, mais Ã=
§a n'est pas
très grave
- mes montages NFS et SMB ne sont plus montés. J'ai un message du
genre :

$ sudo mount /mnt/nfssave
mount.nfs: access denied by server while mounting
$ sudo mount /mnt/smbshare/
mount: mauvais type de système de fichiers, option erronée, sup=
erbloc
erroné sur //192.168.10.84/partage, page de code ou programme
auxiliaire manquant, ou autre erreur (pour plusieurs système de
fichiers (NFS ou CIFS par exemple), un programme /sbin/mount.<type>
auxiliaire pourrait être nécessaire)

Dans certains cas des renseignements utiles sont dans le journal
système — essayez « dmesg | tail » ou qu=
elque chose du genre.

Le dmesg en question m'indique :
[287114.777098] CIFS VFS: No username specified
ce qui m'inquiète doublement : premièrement, le nom d'utilisate=
ur est
spécifié dans le /etc/fstab, mais en plus le mot de passe aussi=
, en
clair :-(

Pouvez-vous m'aider sur ce point ?

D'avance merci.

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/20150430002322.6195aa2f@gaston.baronie.vez
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébastien NOBILI
Le #26350738
Bonjour,

Le jeudi 30 avril 2015 à 0:23, Nicolas FRANCOIS a écrit :
- mes montages NFS et SMB ne sont plus montés. J'ai un message du
genre :

$ sudo mount /mnt/nfssave
mount.nfs: access denied by server while mounting



Sur Samba je laisse la main, mais pour NFS :

- Est-ce que tu as mis à jour le serveur ou bien uniquement le client ?

- Que trouves-tu au moment de la tentative de montage dans les logs (syslog
ou daemon.log) du serveur ?

Sébastien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
yamo'
Le #26351048
Salut,

Nicolas FRANCOIS a écrit le 30/04/2015 00:30 :
- mes montages NFS et SMB ne sont plus montés.




Il y a ce bug qui peut peut-être t'intéresser :

Trouvé sur :


--
Stéphane

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/mi21tk$u05$
Nicolas FRANCOIS
Le #26352484
Le Thu, 30 Apr 2015 09:19:39 +0200,
Sébastien NOBILI
Bonjour,

Le jeudi 30 avril 2015 à 0:23, Nicolas FRANCOIS a écrit :
> - mes montages NFS et SMB ne sont plus montés. J'ai un message du
> genre :
>
> $ sudo mount /mnt/nfssave
> mount.nfs: access denied by server while mounting

Sur Samba je laisse la main, mais pour NFS :

- Est-ce que tu as mis à jour le serveur ou bien uniquement le
client ?

- Que trouves-tu au moment de la tentative de montage dans les
logs (syslog ou daemon.log) du serveur ?

Sébastien




Pour info, j'ai trouvé le problème : la mise à jour a crà ©Ã© une nouvelle
interface réseau (eth2, avec une seule carte réseau !), qu'elle a
configuré en DHCP parce qu'elle a détecté un serveur sur mon réseau (en
fait, une de mes boîtes wifi). Du coup, j'étais en 192.168.10.101 au
lieu de mon IP fixe habituelle 192.168.10.8. Comme les redirections de
mon firewall et les autorisations de mon NAS étaient configurés s ur la
seconde, je n'obtenais plus rien.

Voili, voilà, si jamais quelqu'un d'autre a le même soucis... Il saura
qu'il n'a pas été seul ;-)

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Sylvain L. Sauvage
Le #26352539
Le mardi 12 mai 2015, 23:43:46 Sylvain L. Sauvage a écrit :
[…]
Je ne sais plus s’il y a un avertissement dans les release
notes mais il y a eu un bogue approchant qui a été rég lé juste
avant la sortie de Jessie :
https://bugs.debian.org/cgi-bin/bugreport.cgi?bugv5577



Oups, pas réglé le bogue : réouvert et sera réglà © pour la 8.1.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Sylvain L. Sauvage
Le #26352540
Le mardi 12 mai 2015, 16:55:00 Nicolas FRANCOIS a écrit :
[…]
Pour info, j'ai trouvé le problème : la mise à jour a créé une
nouvelle interface réseau (eth2, avec une seule carte résea u
!), […]



Si tu regardes (si tu as encore…) les différents pé riphériques
dans /etc/udev/rules.d/70-persistent-net.rules, tu verras que
(les) trois entrées correspondent toutes à ta carte mais avec
une légère différence à chaque fois (ou pas, voir l e rapport de
bogue plus bas).

Le mot « persistent » est la clef.
Quand udev voit un nouveau périphérique, il lui donne un no m
qui va persister, pour que, sur les machines avec plusieurs
périphériques (qu’ils soient permanents ou temporaire s), chacun
puisse être configuré individuellement, par son nom, quel que
soit l’ordre d’initialisation ou de branchement (ordre qui peut
être différent même avec des périphériques fix es).

Le truc, c’est que quand on change de version de module
pilote, de noyau ou d’udev, les infos pour les règles d⠀™udev
peuvent changer. Donc udev croit que le périphérique est
nouveau, donc une nouvelle règle udev est créée et le
périphérique a un nouveau nom.

Vu que tu as trois entrées, ça a dû t’arriver deux fois.

Tu peux effacer les règles obsolètes et modifier la dernià ¨re
pour que le nom soit eth0.
Tu peux aussi carrément effacer le fichier, il sera recréà © au
prochain démarrage.

Je ne sais plus s’il y a un avertissement dans les release
notes mais il y a eu un bogue approchant qui a été réglà © juste
avant la sortie de Jessie :
https://bugs.debian.org/cgi-bin/bugreport.cgi?bugv5577

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme