upgrade libsane-extra debian testing

Le
debianpmd
j'ai un problème en upgradant libsane-extra ce jour sur debian testing.

"Dépaquetage de libsane-extras (à partir
de /libsane-extras_1.0.18.16_i386.deb)
dpkg : erreur de traitement
de /var/cache/apt/archives/libsane-extras_1.0.18.16_i386.deb (--unpack) :
tentative de remplacement de « /usr/share/man/man5/sane-epkowa.5.gz =
», qui
appartient aussi au paquet iscan
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libsane-extras_1.0.18.16_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"

Avez vous le même problème ?

pmd
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
David Prévot
Le #9644111
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

debianpmd a écrit :
j'ai un problème en upgradant libsane-extra ce jour sur debian testing.


[...]
tentative de remplacement de « /usr/share/man/man5/sane-epkowa.5.gz », qui
appartient aussi au paquet iscan


[...]
Avez vous le même problème ?



iscan n'etant pas pas un paquet debian officiel, il doit entrer en
conflit avec libsane-extra, ne reste plus qu'à le patcher...

D'un autre côté, si tu as installé iscan pour bénéficier du pilote
epokwa qui semble maintenant inclus dans libsane-extra, tu peux
peut-être simplement virer iscan.

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHkgf718/WetbTC/oRAmrOAJ9iVgarYsHVBcgLBf+bkWtsUxvsWwCbB3c1
kdt3AwHRHYtEe1wtaRkVGPE =9SXH
-----END PGP SIGNATURE-----


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Philippe Merlin
Le #9644101
Bonjour,
J'ai exactement le même problème. J'ai fait comme tu l'as suggéré u n
apt-get -f remove iscan.
Mais alors on me dit de faire un apt-get -f install préalablement ,qui es saye
d'installer libsane-extra et qui échoue évidemment.
Je ne vois pas comment m'en sortir, je pense que c'est très simple.
Pourriez vous me donner une idée.
A l'avance merci.
Philippe MERLIN




Le samedi 19 janvier 2008, David Prévot a écrit :
debianpmd a écrit :
> j'ai un problème en upgradant libsane-extra ce jour sur debian testin g.

[...]

> tentative de remplacement de « /usr/share/man/man5/sane-epkowa.5.gz »,
> qui appartient aussi au paquet iscan

[...]

> Avez vous le même problème ?

iscan n'etant pas pas un paquet debian officiel, il doit entrer en
conflit avec libsane-extra, ne reste plus qu'à le patcher...

D'un autre côté, si tu as installé iscan pour bénéficier du pil ote
epokwa qui semble maintenant inclus dans libsane-extra, tu peux
peut-être simplement virer iscan.

Amicalement

David


Txo
Le #9644091
En ce samedi 19 janvier 2008 à 15:50:33 Philippe Merlin nous
susurrait :

Bonjour,



Bonjour

J'ai exactement le même problème. J'ai fait comme tu l'as suggéré un
apt-get -f remove iscan.
Mais alors on me dit de faire un apt-get -f install préalablement ,qui essaye
d'installer libsane-extra et qui échoue évidemment.



J'ai téléchargé le paquet à partir de cette page pour sid
http://packages.debian.org/sid/i386/libsane-extras/download

ou de celle là si testing
http://packages.debian.org/lenny/i386/libsane-extras/download

et installé le paquet avec la commande
dpkg -i --force-depends libsane-extras_1.0.18.15_i386.deb

et j'ai ainsi gardé iscan et Xsane.


--
-+- Dominique Marin http://txodom.free.fr -+-

«Les hommes qui pensent en rond, ont les idées courbes ...
La pensée mise en commun est une pensée commune»
-+- Léo Ferré Préface -+-


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
debianpmd
Le #9644071
Le Saturday 19 January 2008 15:23:56 David Prévot, vous avez écrit :
debianpmd a écrit :
> j'ai un problème en upgradant libsane-extra ce jour sur debian testin g.

[...]

> tentative de remplacement de « /usr/share/man/man5/sane-epkowa.5.gz »,
> qui appartient aussi au paquet iscan

[...]

> Avez vous le même problème ?

iscan n'etant pas pas un paquet debian officiel, il doit entrer en
conflit avec libsane-extra, ne reste plus qu'à le patcher...

D'un autre côté, si tu as installé iscan pour bénéficier du pil ote
epokwa qui semble maintenant inclus dans libsane-extra, tu peux
peut-être simplement virer iscan.

Amicalement

David


exact
dpkg --purge iscan
et ça marche.
J'aurais bien modifié le paquet deb car ce qui cloche c'est le remplaceme nt de
la page man mais je ne sais pas faire.

Merci à tous
Amitiés
pmd
Publicité
Poster une réponse
Anonyme