URGENT !! Récupérer un disque après install Ubuntu

Le
PPbal
Bonjour à tous,

Ma config lors de l'installation :
Un disque IDE sur tiroir pour installer Ubuntu.
Un disque SATA NTFS uniquement de stockage donc sans système.

J'ai installé Ubuntu sur le disque IDE pour le tester.
Ensuite j'ai changé le tiroir pour remettre mon disque dur de travail
sous WXP et c'est là que j'ai rencontré un problème : disque non système
au démarrage. Deux solutions pour démarrer le PC :

- F8 au démarrage et sélectionner le disque windows
- Débrancher le disque NTFS

Apparement, Ubuntu a modifié mon disque SATA et mon PC tente de booter
dessus.

Ce que j'ai fait sur le disque SATA :
Suppression des partitions et recréation + formatage.
Aucun résultat.
Exécution de FIXBOOT
Aucun résultat.
Exécution de FIXMBR
Aucun résultat.
Création de nouvelles partitions
Aucun résultat.

Que faut-il faire pour que mon PC redémarre correctement en présence du
disque SATA ??

Faut quand même pas aller jursqu'au format bas niveau tout de même.


Merci d'avance pour vos réponses.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Th.A.C
Le #6427651


Ce que j'ai fait sur le disque SATA :
Suppression des partitions et recréation + formatage.
Aucun résultat.
Exécution de FIXBOOT
Aucun résultat.
Exécution de FIXMBR
Aucun résultat.
Création de nouvelles partitions
Aucun résultat.

Que faut-il faire pour que mon PC redémarre correctement en présence du
disque SATA ??


il faut supprimer le boot installé par Ubuntu (lilo ou grub en général).

En général, un simple fdisk /mbr depuis un cd ou une disquette de W98
devrait suffire.

Faut quand même pas aller jursqu'au format bas niveau tout de même.


si si ;-)

Gump
Le #6427641
| il faut supprimer le boot installé par Ubuntu (lilo ou grub en général).
|
| En général, un simple fdisk /mbr depuis un cd ou une disquette de W98
| devrait suffire.


Mais pourquoi Ubuntu aurait-il installé son chargeur grub sur le disque
S-ATA, alors que PPbal dit bien qu'il a installé son Ubuntu sur un IDE
à tiroir ?

Gump
Nicolas George
Le #6427901
"Gump" wrote in message
Mais pourquoi Ubuntu aurait-il installé son chargeur grub sur le disque
S-ATA, alors que PPbal dit bien qu'il a installé son Ubuntu sur un IDE
à tiroir ?


Probablement parce qu'il s'est trompé quelque part.

PPbal
Le #6428341
"Gump" wrote in message
Mais pourquoi Ubuntu aurait-il installé son chargeur grub sur le disque
S-ATA, alors que PPbal dit bien qu'il a installé son Ubuntu sur un IDE
à tiroir ?


Probablement parce qu'il s'est trompé quelque part.


Je ne comprends pas où je me serais trompé puisque Ubuntu était installé
sur le bon disque. A l'install de Ubuntu, il ne me semble pas avoir vu
des paramétrage pour le boot mais peut-être que j'ai mal regardé.


William Marie
Le #6429801
"PPbal" news: 48163d0b$0$856$
Bonjour à tous,

Ma config lors de l'installation :
Un disque IDE sur tiroir pour installer Ubuntu.
Un disque SATA NTFS uniquement de stockage donc sans système.

J'ai installé Ubuntu sur le disque IDE pour le tester.
Ensuite j'ai changé le tiroir pour remettre mon disque dur de travail
sous WXP et c'est là que j'ai rencontré un problème : disque non
système au démarrage. Deux solutions pour démarrer le PC :

- F8 au démarrage et sélectionner le disque windows
- Débrancher le disque NTFS

Apparement, Ubuntu a modifié mon disque SATA et mon PC tente de booter
dessus.

Ce que j'ai fait sur le disque SATA :
Suppression des partitions et recréation + formatage.
Aucun résultat.
Exécution de FIXBOOT
Aucun résultat.
Exécution de FIXMBR
Aucun résultat.
Création de nouvelles partitions
Aucun résultat.

Que faut-il faire pour que mon PC redémarre correctement en présence
du disque SATA ??

Question bête : tu as bien vérifié que le disque démarrable dans le BIOS

était bien l'IDE ?

Attention à un célèbre gag : dans l'archaïsme du lettrage Microsoft issu du
MS-DOS, les partitions principales sont lettrées en premier, avant, donc,
les unités logiques. Si la nature des partitions change ça peut mettre un
caca noir.

Exemple :

1er disque :
/dev/hda1 : C: partition principale
/dev/hda5 : D: première unité logique

2e disque :
/dev/fdb5 : E: première unité logique

Changement ! On a alors

1er disque :
/dev/hda1 : C: partition principale
/dev/hda5 : E: première unité logique

2e disque :
/dev/hdb1 : D: partition principale
et éventuellement
/dev/hdb5 : F: première unité logique

Donc si Windows (système) s'attend à démarrer en D: il y aura de l'injure
box à la clé.

Donc vérifier (avec Acronis Partition suite sur CD boutable) comment ça se
goupille pour remettre tout en ordre. Il n'y a rien de perdu et rien à
formater.
--
=================================== William Marie
Attention antiSpam remplacer trapellun.invalid
par free.fr
Web : http://wmarie.free.fr
http://www.pandemonium.dnsalias.org (site expérimental)
====================================

William Marie
Le #6429791
"William Marie" news: 4816edaf$0$21149$
Question bête : tu as bien vérifié que le disque démarrable dans le
BIOS était bien l'IDE ?

Attention à un célèbre gag : dans l'archaïsme du lettrage Microsoft
issu du MS-DOS, les partitions principales sont lettrées en premier,
avant, donc, les unités logiques. Si la nature des partitions change
ça peut mettre un caca noir.

Exemple :

1er disque :
/dev/hda1 : C: partition principale
/dev/hda5 : D: première unité logique

2e disque :
/dev/fdb5 : E: première unité logique
^^^^ oups ! gourance ! il faut lire hdb5

--
=================================== William Marie
Attention antiSpam remplacer trapellun.invalid
par free.fr
Web : http://wmarie.free.fr
http://www.pandemonium.dnsalias.org (site expérimental)
====================================

PPbal
Le #6433581
"PPbal" news: 48163d0b$0$856$
Bonjour à tous,

Ma config lors de l'installation :
Un disque IDE sur tiroir pour installer Ubuntu.
Un disque SATA NTFS uniquement de stockage donc sans système.

J'ai installé Ubuntu sur le disque IDE pour le tester.
Ensuite j'ai changé le tiroir pour remettre mon disque dur de travail
sous WXP et c'est là que j'ai rencontré un problème : disque non
système au démarrage. Deux solutions pour démarrer le PC :

- F8 au démarrage et sélectionner le disque windows
- Débrancher le disque NTFS

Apparement, Ubuntu a modifié mon disque SATA et mon PC tente de booter
dessus.

Ce que j'ai fait sur le disque SATA :
Suppression des partitions et recréation + formatage.
Aucun résultat.
Exécution de FIXBOOT
Aucun résultat.
Exécution de FIXMBR
Aucun résultat.
Création de nouvelles partitions
Aucun résultat.

Que faut-il faire pour que mon PC redémarre correctement en présence
du disque SATA ??

Question bête : tu as bien vérifié que le disque démarrable dans le BIOS

était bien l'IDE ?

Effectivement je n'avais pas vérifié le disque démarrable dans le BIOS

mais je pensais que l'IDE avait une priorité sur le SATA.
Le problème vient peut-être de là.

En tout cas, la prochaine fois que j'installe Linux, je débranche tous
les disques dur et ne laisse que celui qui doit l'accueillir.


Publicité
Poster une réponse
Anonyme