[UTILISATEURS IKOULA] Urgent! Téléchargement des exe

Le
Patrick Philippot
Bonjour,

S'il y a un utilisateur d'hébergement Ikoula Windows parmi vous, je
souhaiterais savoir comment autoriser le téléchargement des .exe depuis mon
site nouvellement installé. Tous les autres fichiers sont téléchargeables
sauf les .exe. Ils sont signalés comme "non trouvés". Cela me met dans une
situation *très* difficile

Je ne trouve pas dans Plesk où configurer ça. Et le support n'a pas encore
répondu.

--
Patrick Philippot
MainSoft Consulting Services
www.mainsoft.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick Philippot
Le #134637
Patrick Philippot wrote:
S'il y a un utilisateur d'hébergement Ikoula Windows parmi vous, je
souhaiterais savoir comment autoriser le téléchargement des .exe
depuis mon site nouvellement installé. Tous les autres fichiers sont
téléchargeables sauf les .exe. Ils sont signalés comme "non
trouvés". Cela me met dans une situation *très* difficile...


Problème résolu.

--
Patrick Philippot
MainSoft Consulting Services
www.mainsoft.fr

Barnabé Gudul
Le #137290
Patrick Philippot wrote:
Patrick Philippot wrote:
S'il y a un utilisateur d'hébergement Ikoula Windows parmi vous, je
souhaiterais savoir comment autoriser le téléchargement des .exe
depuis mon site nouvellement installé. Tous les autres fichiers sont
téléchargeables sauf les .exe. Ils sont signalés comme "non
trouvés". Cela me met dans une situation *très* difficile...


Problème résolu.


Ne communique surtout pas la solution, ca pourrait aider des gens dans le
meme cas.

Au fait tu la trouves comment l'offre MSDN d'Ikoula ? (j'imagine que tu as
ca) :o


Patrick Philippot
Le #137159
Barnabé Gudul wrote:
Problème résolu.


Ne communique surtout pas la solution, ca pourrait aider des gens
dans le meme cas.


Désolé, on m'a déjà fait cette remarque ailleurs mais je n'ai pas eu le
temps d'écrire un message complet sur les problèmes que j'ai eus lors de
cette migration. Voilà 3 jours que je galère afin de faire tourner mon
application ASP .Net et je n'ai pas eu beaucoup de temps pour bavarder.

Au fait tu la trouves comment l'offre MSDN d'Ikoula ? (j'imagine que
tu as ca) :o


Voilà le message que j'ai déjà posté dans un autre groupe privé:

1. A prix égal, il n'y a aucune offre équivalente et aussi diversifiée. Je
ne connais pas d'autre hébergeur qui me donne en mode mutualisé la
possibilité de faire en même temps du CGI, de l'ASP.Net, du PHP, du MySQL,
du SQL Server, etc. Voir leur tableau comparatif.

2. J'ai pris un abonnement Deluxe. Cela couvre largement tous mes besoins.

3. L'interface de gestion est basée sur Plesk. C'est très riche, très beau,
très lent et un peu trop touffu au démarrage. Il manque un document de
synthèse pour démarrer. Mais c'est la même chose chez tous les hébergeurs.
Tiens, voilà le paquet, débrouille toi.

4. La FAQ est nulle et très maigre.

5. Il y a de nombreuses applications prêtes à installer d'un clic de souris.

6. J'ai quitté hebergement.com parce que ça commence à sentir le sapin. Ils
ne répondent même plus aux demandes de support et il faut appeler à Monaco
et hurler très fort dans le combiné pour que quelqu'un consente à lever son
derrière de son fauteuil. Le support d'Ikoula fait preuve d'une bonne
volonté et d'une réactivité au-dessus de la moyenne. Même si pour les 2
problèmes qui m'ont plombé le week-end, c'est moi qui ai trouvé la solution.
Par 2 fois je me suis retrouvé à échanger des emails vers minuit - 1 heure
du mat' avec un type du support. C'est quand même assez rare.

7. De toute évidence, les performances chez Ikoula sont de loin meilleures
que chez hebergement.com.

Mes 2pbs:

1. Je me suis retrouvé dans l'impossibilité de télécharger des fichiers .exe
depuis mon site. Cela se produit si je règle IIS de manière à ce qu'il
autorise scripts et exécutables sur les répertoires en question. C'est
bizarre, je n'avais pas remarqué ça auparavant. Cela semble toutefois être
une initiative Ikoula et pas IIS [à la réflexion non, a priori c'est du
standard IIS]. Pb mineur réglé assez rapidement en passant en "scripts
only".

2. Plus grave. Mon appli ASP .Net qui fonctionnait chez moi sans souci (3
sites de test en local) et chez hebergement.com *avec la même base de
données installée sur Ikoula* a obstinément refusé de démarrer chez Ikoula.
J'y suis depuis vendredi, nuit comprises. Je vous passe les détails mais au
final, il y avait 2 problèmes:

2.1 Plesk a un bug. Quand on donne le niveau Full Trust à une appli, il
modifie automatiquement le fichier web.config. Sauf qu'ils n'avaient pas
anticipé le cas des fichiers web.config un peu complexes et ils inséraient
la directive adéquate au mauvais endroit dans le fichier. Je croyais donc
être en Full Trust mais ce n'était pas le cas. Ce qui a causé beaucoup de
difficultés pour faire un diagnostic.

2.2 Les réglages sécurité d'Ikoula sont beaucoup plus serrés qu'ailleurs. Ce
qui était accepté chez hebergement.com ne l'est pas chez Ikoula. En
particulier, un assembly .Net ayant un nom fort et ne se trouvant pas dans
le GAC, doit obligatoirement avoir l'attribut
[assembly:AllowPartiallyTrustedCallers] sinon cela génère une exception de
configuration. J'ai mis pas mal de temps à comprendre ça. Et, problème
habituel, comme on ne peut pas déboguer chez l'hébergeur, ça dure...

Voilà.

--
Patrick Philippot - Microsoft MVP
MainSoft Consulting Services
www.mainsoft.fr


Patrick Philippot
Le #137042
Barnabé Gudul wrote:
Au fait tu la trouves comment l'offre MSDN d'Ikoula ? (j'imagine que
tu as ca) :o


Dans mon mémo précédent, j'ai oublié de préciser que j'étais en Deluxe, pas
MSDN.

--
Patrick Philippot - Microsoft MVP
MainSoft Consulting Services
www.mainsoft.fr

Barnabé Gudul
Le #136916
Patrick Philippot wrote:
Barnabé Gudul wrote:
Problème résolu.


Ne communique surtout pas la solution, ca pourrait aider des gens
dans le meme cas.


Désolé, on m'a déjà fait cette remarque ailleurs mais je n'ai pas eu
le temps d'écrire un message complet sur les problèmes que j'ai eus
lors de cette migration. Voilà 3 jours que je galère afin de faire
tourner mon application ASP .Net et je n'ai pas eu beaucoup de temps
pour bavarder.
Au fait tu la trouves comment l'offre MSDN d'Ikoula ? (j'imagine que
tu as ca) :o


Voilà le message que j'ai déjà posté dans un autre groupe privé:

1. A prix égal, il n'y a aucune offre équivalente et aussi
diversifiée. Je ne connais pas d'autre hébergeur qui me donne en mode
mutualisé la possibilité de faire en même temps du CGI, de l'ASP.Net,
du PHP, du MySQL, du SQL Server, etc. Voir leur tableau comparatif.

2. J'ai pris un abonnement Deluxe. Cela couvre largement tous mes
besoins.
3. L'interface de gestion est basée sur Plesk. C'est très riche, très
beau, très lent et un peu trop touffu au démarrage. Il manque un
document de synthèse pour démarrer. Mais c'est la même chose chez
tous les hébergeurs. Tiens, voilà le paquet, débrouille toi.

4. La FAQ est nulle et très maigre.

5. Il y a de nombreuses applications prêtes à installer d'un clic de
souris.
6. J'ai quitté hebergement.com parce que ça commence à sentir le
sapin. Ils ne répondent même plus aux demandes de support et il faut
appeler à Monaco et hurler très fort dans le combiné pour que
quelqu'un consente à lever son derrière de son fauteuil. Le support
d'Ikoula fait preuve d'une bonne volonté et d'une réactivité
au-dessus de la moyenne. Même si pour les 2 problèmes qui m'ont
plombé le week-end, c'est moi qui ai trouvé la solution. Par 2 fois
je me suis retrouvé à échanger des emails vers minuit - 1 heure du
mat' avec un type du support. C'est quand même assez rare.
7. De toute évidence, les performances chez Ikoula sont de loin
meilleures que chez hebergement.com.

Mes 2pbs:

1. Je me suis retrouvé dans l'impossibilité de télécharger des
fichiers .exe depuis mon site. Cela se produit si je règle IIS de
manière à ce qu'il autorise scripts et exécutables sur les
répertoires en question. C'est bizarre, je n'avais pas remarqué ça
auparavant. Cela semble toutefois être une initiative Ikoula et pas
IIS [à la réflexion non, a priori c'est du standard IIS]. Pb mineur
réglé assez rapidement en passant en "scripts only".

2. Plus grave. Mon appli ASP .Net qui fonctionnait chez moi sans
souci (3 sites de test en local) et chez hebergement.com *avec la
même base de données installée sur Ikoula* a obstinément refusé de
démarrer chez Ikoula. J'y suis depuis vendredi, nuit comprises. Je
vous passe les détails mais au final, il y avait 2 problèmes:

2.1 Plesk a un bug. Quand on donne le niveau Full Trust à une appli,
il modifie automatiquement le fichier web.config. Sauf qu'ils
n'avaient pas anticipé le cas des fichiers web.config un peu
complexes et ils inséraient la directive adéquate au mauvais endroit
dans le fichier. Je croyais donc être en Full Trust mais ce n'était
pas le cas. Ce qui a causé beaucoup de difficultés pour faire un
diagnostic.
2.2 Les réglages sécurité d'Ikoula sont beaucoup plus serrés
qu'ailleurs. Ce qui était accepté chez hebergement.com ne l'est pas
chez Ikoula. En particulier, un assembly .Net ayant un nom fort et ne
se trouvant pas dans le GAC, doit obligatoirement avoir l'attribut
[assembly:AllowPartiallyTrustedCallers] sinon cela génère une
exception de configuration. J'ai mis pas mal de temps à comprendre
ça. Et, problème habituel, comme on ne peut pas déboguer chez
l'hébergeur, ça dure...
Voilà.


Merci bcp pour ces précieuses infos.



marinship
Le #21260371
Patrick Philippot a écrit le 23/03/2007 à 21h23 :
Bonjour,

S'il y a un utilisateur d'hébergement Ikoula Windows parmi vous, je
souhaiterais savoir comment autoriser le téléchargement des .exe
depuis mon
site nouvellement installé. Tous les autres fichiers sont
téléchargeables
sauf les .exe. Ils sont signalés comme "non trouvés".
Cela me met dans une
situation *très* difficile...

Je ne trouve pas dans Plesk où configurer ça. Et le support n'a
pas encore
répondu.

--
Patrick Philippot
MainSoft Consulting Services
www.mainsoft.fr


Bonjour,

Je sais que le sujet est vieux mais je suis aussi chez Ikoula et j'ai rencontré le même problème que vous. Je me permets donc d'apporter les précisions suivantes.

En fait, tous mes fichiers.exe sont redevenus téléchargeables depuis que
j'ai modiié 1 paramètre dans Plesk / répertoires web / généralités / Préférences :
- dans Paramètres de l'application (listBox), j'ai modifie en 'Scripts uniquement'
alors que auparavant j'étais en 'Script et exécutable'.

RM
Sayoma
www.saveyourmails.com
Publicité
Poster une réponse
Anonyme