Utilisation drivers ATI

Le
cyrille maiche
=_Part_122866_8563075.1175545424650
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour

J'ai un portable Totoshiba A100-241 avec une carte ATI

Voici un extrait d'un lspci
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpres=
s
200M]

J'ai donc installé les drivers ATI, l'installe fonctionne bien, j'ai un l=
ien
vers "ATI Control" mais lors de la création du fichier xorg.conf
mon serveur X ne fonctionne pas !!!

Y a t-il des utilisateur de ces drivers sur la liste ?

Je souhaite utiliser ce driver pour avoir la deuxième sortie vidéo pour=
un
vidéo projecteur

Merci pour votre aide

Cyrille

Debian 2.6.18 Etch

=_Part_122866_8563075.1175545424650
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour<br><br>J&#39;ai un portable Totoshiba A100-241 avec une carte ATI<b=
r><br>Voici un extrait d&#39;un lspci<br>00:14.3 ISA bridge: ATI Technologi=
es Inc IXP SB400 PCI-ISA Bridge (rev 80)<br>00:14.4 PCI bridge: ATI Technol=
ogies Inc IXP SB400 PCI-PCI Bridge (rev 80)
<br>01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon X=
press 200M]<br><br>J&#39;ai donc installé les drivers ATI, l&#39;installe=
fonctionne bien, j&#39;ai un lien vers &quot;ATI Control&quot; mais lors d=
e la création du fichier
xorg.conf<br>mon serveur X ne fonctionne pas !!!<br><br>Y a t-il des utilis=
ateur de ces drivers sur la liste ?<br><br>Je souhaite utiliser ce driver p=
our avoir la deuxième sortie vidéo pour un vidéo projecteur<br><br>Me=
rci pour votre aide
<br><br>Cyrille<br><br>Debian 2.6.18 Etch<br>

=_Part_122866_8563075.1175545424650--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
mx
Le #9536391
cyrille maiche a écrit :
Bonjour

J'ai un portable Totoshiba A100-241 avec une carte ATI


J'ai un autre modéle de toshiba A100 avec un ATI X1400
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility
X1400

Je peux te donner les ressources en ligne que j'ai utilisées pour
paramétrer mon xorg.conf :

Unofficial Wiki for the ATI Linux Driver
http://wiki.cchtml.com/index.php/Main_Page

http://www.thinkwiki.org/wiki/Fglrx

http://doc.fedora-fr.org/Carte_ATI_:_installation_des_pilotes
J'ai donc installé les drivers ATI, l'installe fonctionne bien, j'ai
un lien
vers "ATI Control" mais lors de la création du fichier xorg.conf
mon serveur X ne fonctionne pas !!!


As tu installé la version paqueté Debian ou les sources du ATI ?

Je souhaite utiliser ce driver pour avoir la deuxième sortie vidéo
pour un
vidéo projecteur


J'ai réussi à faire fonctionner l'écran de mon Desktop ; cf. mon
xorg.conf ci après.
Voila j'ai rien de mieux.

mx

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
BusID "PCI:1:0:0"
#Option pour la sortie second écran :
#Bureau élargi sur le second écran
#Option "DesktopSetup" "horizontal"
Option "HSync2" "30-70"
Option "VRefresh2" "50-160"
Option "Mode2" "1280x1024"
#divers / miscellanous
Option "ForceMonitors" "lvds,crl1,tv"
Option "CenterMode" "off"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "OverlayOnCRTC2" "0"
Option "PseudoColorVisuals" "off"
Option "UseFastTLS" "0"
Option "mtrr" "no"
Option "no_accel" "no"
Option "no_dri" "no"
#
# Choose the TV format. Available values are:
# NTSC-JPN, NTSC-M, NTSC-N, PAL-B, PAL-CN, PAL-D,
# PAL-G, PAL-H, PAL-I, PAL-K, PAL-K1, PAL-L, PAL-N,
# PAL-M, PAL-SCART
#Option "TVFormat" "NTSC-M"
# Choose the TV standard. Available values are: VIDEO, SCART, YUF
#Option "TVStandard" "SCART"
EndSection




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Hugues LARRIVE
Le #9536381
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig4355EFACD5098CE94D9294C5
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

cyrille maiche a écrit :
Bonjour

J'ai un portable Totoshiba A100-241 avec une carte ATI

Voici un extrait d'un lspci
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev
80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon
Xpress 200M]

J'ai donc installé les drivers ATI, l'installe fonctionne bien, j' ai
un lien vers "ATI Control" mais lors de la création du fichier xor g.conf
mon serveur X ne fonctionne pas !!!

Y a t-il des utilisateur de ces drivers sur la liste ?


Moi j'ai une ati dual head et je ne me suis pas embêté avec le driver
fglrx qui n'a pas grand chose de plus que le driver libre si ce n'est
une accélération 3d plus performante mais moins complète ( compatibilité
AIGLX/Composite). C'est pas comme pour nvidia, le driver libre est trè s
évolué et le driver proprio est plutôt "naze" !

J'ai ça dans mon xorg.conf :

Section "Device"
Identifier "ATI"
Driver "radeon"
BusID "PCI:1:0:0"
#ChipID 0x5159
VideoRAM 32768
Screen 0
Option "DPMS" "true"
Option "BusType" "AGP"
Option "AGPMode" "4"
Option "DDCMode" "true"
Option "EnablePageFlip" "true"
Option "RenderAccel" "true"
Option "DynamicClocks" "true"
# Dual head config
Option "MonitorLayout" "CRT, CRT2"
Option "MergedFB" "true"
Option "CRT2Position" "RightOf"
Option "MergedXineramaCRT2IsScreen0" "False"
Option "MetaModes" "1024x768-1024x768"
EndSection

Les différentes options sont bien documentées dans la page de m anuel
(man radeon) dont voici un extrait qui pourrait t'être utile :

Option "MonitorLayout" "string"
This option is used to overwrite the detected monitor
types. This is only required when driver makes a false detection. The p os‐
sible monitor types are:
NONE -- Not connected
CRT -- Analog CRT monitor
TMDS -- Desktop flat panel
LVDS -- Laptop flat panel
This option can be used in following format:
Option "MonitorLayout" "[type on primary], [type on
secondary]"
For example, Option "MonitorLayout" "CRT, TMDS"

Primary/Secondary head for dual-head cards:
(when only one port is used, it will be treated as the
primary regardless)
Primary head:
DVI port on DVI+VGA cards
LCD output on laptops
Internal TMDS port on DVI+DVI cards
Secondary head:
VGA port on DVI+VGA cards
VGA port on laptops
External TMDS port on DVI+DVI cards

The default value is undefined.


Je souhaite utiliser ce driver pour avoir la deuxième sortie vidà ©o
pour un vidéo projecteur

Merci pour votre aide

Cyrille

Debian 2.6.18 Etch



Bon courage !

@+


--------------enig4355EFACD5098CE94D9294C5
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGEbe7NdTZuHWpgVIRAgXPAJ9kTd9GzIOswet2aFHnEVkVb0E80ACeIN+D
+1mHGZI75RIMHG4WNtnNthc =AoZd
-----END PGP SIGNATURE-----

--------------enig4355EFACD5098CE94D9294C5--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
cyrille maiche
Le #9536191
------=_Part_15800_23086751.1175629667142
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 03/04/07, mx

cyrille maiche a écrit :
> Bonjour
>
> J'ai un portable Totoshiba A100-241 avec une carte ATI
J'ai un autre modéle de toshiba A100 avec un ATI X1400
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility
X1400

Je peux te donner les ressources en ligne que j'ai utilisées pour
paramétrer mon xorg.conf :

Unofficial Wiki for the ATI Linux Driver
http://wiki.cchtml.com/index.php/Main_Page

http://www.thinkwiki.org/wiki/Fglrx

http://doc.fedora-fr.org/Carte_ATI_:_installation_des_pilotes
> J'ai donc installé les drivers ATI, l'installe fonctionne bien, j'ai
> un lien
> vers "ATI Control" mais lors de la création du fichier xorg.conf
> mon serveur X ne fonctionne pas !!!
As tu installé la version paqueté Debian ou les sources du ATI ?




J'ai installé les sources du driver ATI

voici mon xorg.conf

Lorsque je remplace ati par flgrx, le serveur X ne démarre pas !!

++++++++++++++++++++++++++++++++++++++++++++++++++++++

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Monitor"
Identifier "Écran générique"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "ATI Technologies Inc RC410 [Radeon Xpress 200M]"
Driver "fglrx"
BusID "PCI:1:5:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "ati"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc RC410 [Radeon Xpress 200M]"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Je souhaite utiliser ce driver pour avoir la deuxième sortie vidéo
> pour un
> vidéo projecteur
J'ai réussi à faire fonctionner l'écran de mon Desktop ; cf. mon
xorg.conf ci après.
Voila j'ai rien de mieux.

mx

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
BusID "PCI:1:0:0"
#Option pour la sortie second écran :
#Bureau élargi sur le second écran
#Option "DesktopSetup" "horizontal"
Option "HSync2" "30-70"
Option "VRefresh2" "50-160"
Option "Mode2" "1280x1024"
#divers / miscellanous
Option "ForceMonitors" "lvds,crl1,tv"
Option "CenterMode" "off"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "OverlayOnCRTC2" "0"
Option "PseudoColorVisuals" "off"
Option "UseFastTLS" "0"
Option "mtrr" "no"
Option "no_accel" "no"
Option "no_dri" "no"
#
# Choose the TV format. Available values are:
# NTSC-JPN, NTSC-M, NTSC-N, PAL-B, PAL-CN, PAL-D,
# PAL-G, PAL-H, PAL-I, PAL-K, PAL-K1, PAL-L, PAL-N,
# PAL-M, PAL-SCART
#Option "TVFormat" "NTSC-M"
# Choose the TV standard. Available values are: VIDEO, SCART, YUF
#Option "TVStandard" "SCART"
EndSection




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact






------=_Part_15800_23086751.1175629667142
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

cyrille maiche a écrit :<br>&gt; Bonjour<br>&gt;<br>&gt; J&#39;ai un port able Totoshiba A100-241 avec une carte ATI<br>J&#39;ai un autre modéle de toshiba A100 avec un ATI X1400<br>01:00.0 VGA compatible controller: ATI T echnologies Inc Radeon Mobility
http://wiki.cchtml.com/index.php/Main_Page <br><br>++++++++++++++++++++++++++++++++++++++++++++++++++++++<br><br>Secti on &quot;ServerLayout&quot;<br>&nbsp;&nbsp;&nbsp; Identifier&nbsp;&nbsp;&nb sp;&nbsp; &quot;Default Layout&quot;<br>&nbsp;&nbsp;&nbsp; Screen&nbsp;&nbs p;&nbsp;&nbsp;&nbsp; 0&nbsp; &quot;aticonfig-Screen[0]&quot; 0 0<br>&nbsp;& nbsp;&nbsp; InputDevice&nbsp;&nbsp;&nbsp; &quot;Generic Keyboard&quot;
<br>&nbsp;&nbsp;&nbsp; InputDevice&nbsp;&nbsp;&nbsp; &quot;Configured Mouse &quot;<br>&nbsp;&nbsp;&nbsp; InputDevice&nbsp;&nbsp;&nbsp; &quot;Synaptics Touchpad&quot;<br>EndSection<br><br>Section &quot;Files&quot;<br><br>&nbsp; &nbsp;&nbsp; # path to defoma fonts<br>&nbsp;&nbsp;&nbsp; FontPath&nbsp;&nb sp;&nbsp;&nbsp; &quot;/usr/share/fonts/X11/misc&quot;
<br>&nbsp;&nbsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nbsp; &quot;/usr/X11R6/li b/X11/fonts/misc&quot;<br>&nbsp;&nbsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nbs p; &quot;/usr/share/fonts/X11/cyrillic&quot;<br>&nbsp;&nbsp;&nbsp; FontPath &nbsp;&nbsp;&nbsp;&nbsp; &quot;/usr/X11R6/lib/X11/fonts/cyrillic&quot;<br>& nbsp;&nbsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nbsp; &quot;/usr/share/fonts/X 11/100dpi/:unscaled&quot;
<br>&nbsp;&nbsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nbsp; &quot;/usr/X11R6/li b/X11/fonts/100dpi/:unscaled&quot;<br>&nbsp;&nbsp;&nbsp; FontPath&nbsp;&nbs p;&nbsp;&nbsp; &quot;/usr/share/fonts/X11/75dpi/:unscaled&quot;<br>&nbsp;&n bsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nbsp; &quot;/usr/X11R6/lib/X11/fonts/ 75dpi/:unscaled&quot;<br>&nbsp;&nbsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nbsp ; &quot;/usr/share/fonts/X11/Type1&quot;
<br>&nbsp;&nbsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nbsp; &quot;/usr/X11R6/li b/X11/fonts/Type1&quot;<br>&nbsp;&nbsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nb sp; &quot;/usr/share/fonts/X11/100dpi&quot;<br>&nbsp;&nbsp;&nbsp; FontPath& nbsp;&nbsp;&nbsp;&nbsp; &quot;/usr/X11R6/lib/X11/fonts/100dpi&quot;<br>&nbs p;&nbsp;&nbsp; FontPath&nbsp;&nbsp;&nbsp;&nbsp; &quot;/usr/share/fonts/X11/ 75dpi&quot;
<br>&nbsp;&nbsp;&nbsp; Load&nbsp; &quot;ddc&quot;<br>&nbsp;&nbsp;&nbsp; Loa d&nbsp; &quot;dri&quot;<br>&nbsp;&nbsp;&nbsp; Load&nbsp; &quot;extmod&quot; <br>&nbsp;&nbsp;&nbsp; Load&nbsp; &quot;freetype&quot;<br>&nbsp;&nbsp;&nbsp ; Load&nbsp; &quot;glx&quot;<br>&nbsp;&nbsp;&nbsp; Load&nbsp; &quot;int10&q uot;<br>&nbsp;&nbsp;&nbsp; Load&nbsp; &quot;vbe&quot;<br>EndSection
<br><br>Section &quot;InputDevice&quot;<br>&nbsp;&nbsp;&nbsp; Identifier&nb sp; &quot;Generic Keyboard&quot;<br>&nbsp;&nbsp;&nbsp; Driver&nbsp;&nbsp;&n bsp;&nbsp;&nbsp; &quot;kbd&quot;<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&n bsp; &nbsp;&nbsp;&nbsp; &quot;CoreKeyboard&quot;<br>&nbsp;&nbsp;&nbsp; Opti on&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;XkbRules&quot; &quot;xorg&quo t;
<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;Xk bModel&quot; &quot;pc105&quot;<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbs p; &nbsp;&nbsp;&nbsp; &quot;XkbLayout&quot; &quot;fr&quot;<br>&nbsp;&nbsp;& nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;XkbVariant&quot; &q uot;latin9&quot;<br>EndSection<br><br>Section &quot;InputDevice&quot;
<br>&nbsp;&nbsp;&nbsp; Identifier&nbsp; &quot;Configured Mouse&quot;<br>&nb sp;&nbsp;&nbsp; Driver&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;mouse&quot;<br>& nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;CorePoi nter&quot;<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp ; &quot;Device&quot; &quot;/dev/input/mice&quot;<br>&nbsp;&nbsp;&nbsp; Opti on&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;Protocol&quot; &quot;ImPS/2&q uot;
<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;Em ulate3Buttons&quot; &quot;true&quot;<br>EndSection<br><br>Section &quot;Inp utDevice&quot;<br>&nbsp;&nbsp;&nbsp; Identifier&nbsp; &quot;Synaptics Touch pad&quot;<br>&nbsp;&nbsp;&nbsp; Driver&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot; synaptics&quot;<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; &nbsp; &quot;SendCoreEvents&quot; &quot;true&quot;
<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;De vice&quot; &quot;/dev/psaux&quot;<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;& nbsp; &nbsp;&nbsp;&nbsp; &quot;Protocol&quot; &quot;auto-dev&quot;<br>&nbsp ;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;HorizScroll Delta&quot; &quot;0&quot;<br>EndSection<br><br>Section &quot;Monitor&quot;
<br>&nbsp;&nbsp;&nbsp; Identifier&nbsp;&nbsp; &quot;Écran générique&q uot;<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quo t;DPMS&quot;<br>EndSection<br><br>Section &quot;Monitor&quot;<br>&nbsp;&nbs p;&nbsp; Identifier&nbsp;&nbsp; &quot;aticonfig-Monitor[0]&quot;<br>&nbsp;& nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;VendorName&qu ot; &quot;ATI Proprietary Driver&quot;
<br>&nbsp;&nbsp;&nbsp; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;Mo delName&quot; &quot;Generic Autodetecting Monitor&quot;<br>&nbsp;&nbsp;&nbs p; Option&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &quot;DPMS&quot; &quot;true& quot;<br>EndSection<br><br>Section &quot;Device&quot;<br>&nbsp;&nbsp;&nbsp; Identifier&nbsp; &quot;ATI Technologies Inc RC410 [Radeon Xpress 200M]&quo t;
<br>&nbsp;&nbsp;&nbsp; Driver&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;fglrx&quo t;<br>&nbsp;&nbsp;&nbsp; BusID&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;PC I:1:5:0&quot;<br>EndSection<br><br>Section &quot;Device&quot;<br>&nbsp;&nbs p;&nbsp; Identifier&nbsp; &quot;aticonfig-Device[0]&quot;<br>&nbsp;&nbsp;&n bsp; Driver&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;ati&quot;<br>EndSection
<br><br>Section &quot;Screen&quot;<br>&nbsp;&nbsp;&nbsp; Identifier &quot;D efault Screen&quot;<br>&nbsp;&nbsp;&nbsp; Device&nbsp;&nbsp;&nbsp;&nbsp; &q uot;ATI Technologies Inc RC410 [Radeon Xpress 200M]&quot;<br>&nbsp;&nbsp;&n bsp; Monitor&nbsp;&nbsp;&nbsp; &quot;Écran générique&quot;<br>&nbsp;& nbsp;&nbsp; DefaultDepth&nbsp;&nbsp;&nbsp;&nbsp; 24
<br>&nbsp;&nbsp;&nbsp; SubSection &quot;Display&quot;<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Depth&nbsp;&nbsp;&nbsp;&nbsp; 1<br>&nbsp;&nbsp;&nbsp; & nbsp;&nbsp;&nbsp; Modes&nbsp;&nbsp;&nbsp; &quot;1280x800&quot;<br>&nbsp;&nb sp;&nbsp; EndSubSection<br>&nbsp;&nbsp;&nbsp; SubSection &quot;Display&quot ;<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Depth&nbsp;&nbsp;&nbsp;&nbsp; 4< br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Modes&nbsp;&nbsp;&nbsp; &quot;1280 x800&quot;
<br>&nbsp;&nbsp;&nbsp; EndSubSection<br>&nbsp;&nbsp;&nbsp; SubSection &quot ;Display&quot;<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Depth&nbsp;&nbsp;&n bsp;&nbsp; 8<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Modes&nbsp;&nbsp;&nbs p; &quot;1280x800&quot;<br>&nbsp;&nbsp;&nbsp; EndSubSection<br>&nbsp;&nbsp; &nbsp; SubSection &quot;Display&quot;<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nb sp; Depth&nbsp;&nbsp;&nbsp;&nbsp; 15<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbs p; Modes&nbsp;&nbsp;&nbsp; &quot;1280x800&quot;
<br>&nbsp;&nbsp;&nbsp; EndSubSection<br>&nbsp;&nbsp;&nbsp; SubSection &quot ;Display&quot;<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Depth&nbsp;&nbsp;&n bsp;&nbsp; 16<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Modes&nbsp;&nbsp;&nb sp; &quot;1280x800&quot;<br>&nbsp;&nbsp;&nbsp; EndSubSection<br>&nbsp;&nbsp ;&nbsp; SubSection &quot;Display&quot;<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&n bsp; Depth&nbsp;&nbsp;&nbsp;&nbsp; 24<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nb sp; Modes&nbsp;&nbsp;&nbsp; &quot;1280x800&quot;
<br>&nbsp;&nbsp;&nbsp; EndSubSection<br>EndSection<br><br>Section &quot;Scr een&quot;<br>&nbsp;&nbsp;&nbsp; Identifier &quot;aticonfig-Screen[0]&quot;< br>&nbsp;&nbsp;&nbsp; Device&nbsp;&nbsp;&nbsp;&nbsp; &quot;aticonfig-Device [0]&quot;<br>&nbsp;&nbsp;&nbsp; Monitor&nbsp;&nbsp;&nbsp; &quot;aticonfig-M onitor[0]&quot;<br>
&nbsp;&nbsp;&nbsp; DefaultDepth&nbsp;&nbsp;&nbsp;&nbsp; 24<br>&nbsp;&nbsp;& nbsp; SubSection &quot;Display&quot;<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbs p; Viewport&nbsp;&nbsp; 0 0<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Depth& nbsp;&nbsp;&nbsp;&nbsp; 24<br>&nbsp;&nbsp;&nbsp; EndSubSection<br>EndSectio n<br><br>Section &quot;DRI&quot;<br>&nbsp;&nbsp;&nbsp; Mode&nbsp;&nbsp;&nbs p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 0666<br>EndSection<br><br>
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ &nbsp;&nbsp;&nbsp;&nbsp;Identifier&nbsp;&nbsp;&quot;aticonfig-Device[0]&quo t;<br>&nbsp;&nbsp;&nbsp;&nbsp;Driver&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&qu ot;fglrx&quot;<br>&nbsp;&nbsp;&nbsp;&nbsp;BusID&nbsp;&nbsp;&nbsp;&nbsp;&nbs p;&nbsp;&nbsp;&nbsp;&quot;PCI:1:0:0&quot;<br>&nbsp;&nbsp;&nbsp;&nbsp;#Optio n pour la sortie second écran :<br>&nbsp;&nbsp;&nbsp;&nbsp;#Bureau élar gi sur le second écran<br>&nbsp;&nbsp;&nbsp;&nbsp;#Option &quot;DesktopSe tup&quot; &quot;horizontal&quot;
<br>&nbsp;&nbsp;&nbsp;&nbsp;Option &quot;HSync2&quot; &quot;30-70&quot;<br> &nbsp;&nbsp;&nbsp;&nbsp;Option &quot;VRefresh2&quot; &quot;50-160&quot;<br> &nbsp;&nbsp;&nbsp;&nbsp;Option &quot;Mode2&quot; &quot;1280x1024&quot;<br>& nbsp;&nbsp;&nbsp;&nbsp;#divers / miscellanous<br>&nbsp;&nbsp;&nbsp;&nbsp;Op tion &quot;ForceMonitors&quot; &quot;lvds,crl1,tv&quot;
<br>&nbsp;&nbsp;&nbsp;&nbsp;Option &quot;CenterMode&quot; &quot;off&quot;<b r>&nbsp;&nbsp;&nbsp;&nbsp;Option &quot;VideoOverlay&quot; &quot;on&quot;<br >&nbsp;&nbsp;&nbsp;&nbsp;Option &quot;OpenGLOverlay&quot; &quot;off&quot;<b r>&nbsp;&nbsp;&nbsp;&nbsp;Option &quot;OverlayOnCRTC2&quot; &quot;0&quot;<b r>
&nbsp;&nbsp;&nbsp;&nbsp;Option &quot;PseudoColorVisuals&quot; &quot;off&quo t;<br>&nbsp;&nbsp;&nbsp;&nbsp;Option &quot;UseFastTLS&quot; &quot;0&quot;<b r>&nbsp;&nbsp;&nbsp;&nbsp;Option &quot;mtrr&quot; &quot;no&quot;<br>&nbsp;& nbsp;&nbsp;&nbsp;Option &quot;no_accel&quot; &quot;no&quot;<br>&nbsp;&nbsp; &nbsp;&nbsp;Option &quot;no_dri&quot; &quot;no&quot;
</a><br><br></blockquote></div><br>

------=_Part_15800_23086751.1175629667142--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
mx
Le #9535471
cyrille maiche a écrit :
J'ai installé les sources du driver ATI

voici mon xorg.conf

Lorsque je remplace ati par flgrx, le serveur X ne démarre pas !!


Pourquoi ?

Regarde le journal : /var/log/Xorg.0.log
et particulièrement les entrées commençant avec (WW) et (EE),
respectivement Warning et Error.
avec une commande du genre :
grep "(WW)" /var/log/Xorg.0.log

mx


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
cyrille maiche
Le #9535001
------=_Part_52701_21832403.1175793063526
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

voici mon message d'erreur suite au grep

(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

(EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so
(EE) Failed to load module "fglrx" (loader failed, 7)


Le 05/04/07, mx

cyrille maiche a écrit :
> J'ai installé les sources du driver ATI
>
> voici mon xorg.conf
>
> Lorsque je remplace ati par flgrx, le serveur X ne démarre pas !!
Pourquoi ?

Regarde le journal : /var/log/Xorg.0.log
et particulièrement les entrées commençant avec (WW) et (EE),
respectivement Warning et Error.
avec une commande du genre :
grep "(WW)" /var/log/Xorg.0.log

mx





------=_Part_52701_21832403.1175793063526
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

voici mon message d&#39;erreur suite au grep cyrille maiche a écrit :
------=_Part_52701_21832403.1175793063526--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
mx
Le #9534821
cyrille maiche a écrit :
voici mon message d'erreur suite au grep

(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

(EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so
(EE) Failed to load module "fglrx" (loader failed, 7)


Là je ne peux pas trop t'aider.

La compilation du module a t'elle eu des ratées ?

Tu as dit avoir utilisé les sources ATI.
Pourquoi ne pas utiliser le paquet fglrx-kernel-src [0] ?
|Tu compiles toi même les sources fournit par Debian avec module-assistant.
|Tu construis ainsi un paquet debian mieux intégré à ton système.

Le sources debian du modules ne gère pas la sortie vidéo ?

J'ai une ATI x1400 sur mon portable et cela fonctionne très bien avec ce
paquet debian et module-assistant. Même mes sorties vidéo fonctionnent.

[0] http://packages.debian.org/fglrx-kernel-src

Geoff


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
cyrille maiche
Le #9534621
------=_Part_4785_3916798.1175877674468
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Après un redémarrage brutal !!! cela fonctionne

Y a t-il des changement à faire dans le fichier xorg.conf pour la deuxi ème
sortie vidéo ???

Merci de ton aide, c'est vraiment cool de trouver des gens compétents et
patients à la fois.

@+

Cyrille

------=_Part_4785_3916798.1175877674468
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Après un redémarrage brutal !!! cela fonctionne <br><br>@+<br><br>Cyrille<br><br><div><span class="gmail_quote"></span><b r></div><br>

------=_Part_4785_3916798.1175877674468--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
mx
Le #9534611
cyrille maiche a écrit :
Après un redémarrage brutal !!! cela fonctionne


Il devait te manquer un "#depmod" ou tout simplement un "#modprob fglrx"
pour prendre en compte le module fraîchement compilé.
Y a t-il des changement à faire dans le fichier xorg.conf pour la
deuxième
sortie vidéo ???


Tu peux regarder la page de manuel de fglrx qui documente complètement
les options de xorg.conf : %man fglrx. La page de manuel est fourni par
le paquet fglrx-driver (le module fglrx pour la 2D).
Je pense qu'il faut que tu précise les caractéristiques du second écran :
le type de moniteur, résolution, fréquence etc...

Merci de ton aide, c'est vraiment cool de trouver des gens compétents et
patients à la fois.


De rien.
J'ai moi même passé beaucoup de temps là dessus. Et c'est grâce à la
communauté que j'ai progressé et appris.

mx


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme