Utilisation de nb.si

Le
JLuc
Salut à tous,
comment trouver le nombre de valeurs differentes dans une plage dont la
longueur est inconnus ?
Par exemple en colonne A :
5
6
3
8
9
10
5
7
6

Resultat : 7
JLuc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #4855161
Si tu définis une plage de cellules au nom de ColA avec la formule Decaler ....

La formule te donne le nombre de valeur unique.
=SOMMEPROD((ColA<>"")/(NB.SI(ColA;ColA)+(ColA="")))

et si tu as des cellules vides, ChristV avait trouvé cette formule
=SOMME(SI(ESTVIDE(ColA);"";1/NB.SI(ColA;ColA)))



"JLuc" 46fe4c9d$0$18266$
Salut à tous,
comment trouver le nombre de valeurs differentes dans une plage dont la
longueur est inconnus ?
Par exemple en colonne A :
5
6
3
8
9
10
5
7
6
...
Resultat : 7
JLuc
JB
Le #4855121
Bonjour,

-S'il n'y a pas de cellules vides:
Créer un nom de champ dynamique: xxx ÞCALER(Feuil1!$A
$1;;;NBVAL(Feuil1!$A:$A))
=SOMMEPROD(1/NB.SI(xxx;xxx))

-S'il y a des cellules vides:

=SOMME(SI(NB.SI(A1:A100;A1:A1000)<>0;1/NB.SI(A1:A100;A1:A100);""))

JB


On 29 sep, 14:58, JLuc
Salut à tous,
comment trouver le nombre de valeurs differentes dans une plage dont la
longueur est inconnus ?
Par exemple en colonne A :
5
6
3
8
9
10
5
7
6
...
Resultat : 7
JLuc


Misange
Le #4854961
ChristV avait trouvé cette formule


Quel panthéon ! Il y a donc plusieurs demi-dieux d'excel ?


Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

MichDenis
Le #4854841
ChristV avait trouvé cette formule


| Quel panthéon ! Il y a donc plusieurs demi-dieux d'excel ?


ça fait déjà un bon moment, qu'il ne sait pas commis dans une formule !

Je suppose qu'il a rencontré une dame qui ne savait pas repassée et que
cela lui prend tout son temps libre !!!
;-)))

JLuc
Le #4854461
Merci à tous pour vos réponses de qualité :)
JLuc
Misange
Le #4854331
;-)
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

ChristV avait trouvé cette formule


| Quel panthéon ! Il y a donc plusieurs demi-dieux d'excel ?


ça fait déjà un bon moment, qu'il ne sait pas commis dans une formule !

Je suppose qu'il a rencontré une dame qui ne savait pas repassée et que
cela lui prend tout son temps libre !!!
;-)))





jps
Le #4854281
ayant commencé par lire la phrase traitant du repassage, du coup j'avais lu
ensuite "quel pantalon!"
jps

"MichDenis"

ChristV avait trouvé cette formule


| Quel panthéon ! Il y a donc plusieurs demi-dieux d'excel ?


ça fait déjà un bon moment, qu'il ne s'est pas commis dans une formule !

Je suppose qu'il a rencontré une dame qui ne savait pas repasser et que
cela lui prend tout son temps libre !!!
;-)))





Misange
Le #4854251
:-)

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

ayant commencé par lire la phrase traitant du repassage, du coup j'avais lu
ensuite "quel pantalon!"
jps

"MichDenis"
ChristV avait trouvé cette formule
| Quel panthéon ! Il y a donc plusieurs demi-dieux d'excel ?



ça fait déjà un bon moment, qu'il ne s'est pas commis dans une formule !

Je suppose qu'il a rencontré une dame qui ne savait pas repasser et que
cela lui prend tout son temps libre !!!
;-)))









LSteph
Le #4854191
Bien le bonjour,

Le demi-dieu, pour le repassage compte sur sa moitié, c'est bien connu!

--
lSteph

ayant commencé par lire la phrase traitant du repassage, du coup j'avais lu
ensuite "quel pantalon!"
jps

"MichDenis"
ChristV avait trouvé cette formule
| Quel panthéon ! Il y a donc plusieurs demi-dieux d'excel ?



ça fait déjà un bon moment, qu'il ne s'est pas commis dans une formule !

Je suppose qu'il a rencontré une dame qui ne savait pas repasser et que
cela lui prend tout son temps libre !!!
;-)))









Publicité
Poster une réponse
Anonyme