UUID et label

Le
Michel
Bonjour,

J'ai mis à jour mon serveur ce WE (de Squeeze à Wheezy) et j'ai un =
soucis avec
la partition /dev/sda1. Elle n'est reconnus que par son UUID ce qui me =
pose
soucis avec cacti notamment Pas de problème pour les 3 autres (/de=
v/sdb1 et
/dev/sdc1).

[root@canoe]:~ # ls -l /dev/disk/by-uuid
total 0
lrwxrwxrwx 1 root root 10 avril 7 15:38 02a1386f-f861-4245-8787-d7960c=
ebce38
-> ../../sda1
lrwxrwxrwx 1 root root 10 avril 7 15:38 432a611f-7830-4196-bb87-318da4=
501ede
-> ../../sdb1
lrwxrwxrwx 1 root root 10 avril 7 15:38 828c1c42-30fd-4d6a-b5cf-efb2c6=
dc563c
-> ../../sda5
lrwxrwxrwx 1 root root 10 avril 7 15:38 f17189ee-e901-45cb-be02-f3be01=
29b956
-> ../../sdc1

[root@canoe]:~ # mount
/dev/disk/by-uuid/02a1386f-f861-4245-8787-d7960cebce38 on / type ext4 =

(rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=orde=
red)
/dev/sdb1 on /srv type ext4
(rw,relatime,user_xattr,acl,barrier=1,data=ordered)
/dev/sdc1 on /var/archives type ext4
(rw,relatime,user_xattr,acl,barrier=1,data=ordered)


Mon fstab :
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=02a1386f-f861-4245-8787-d7960cebce38 / ext4
errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=828c1c42-30fd-4d6a-b5cf-efb2c6dc563c none swap sw =

0 0
#/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto 0 0

# Le disque de 2To
UUID=432a611f-7830-4196-bb87-318da4501ede /srv ext4 defau=
lts
0 1

# Le disque de 1To
UUID=f17189ee-e901-45cb-be02-f3be0129b956 /var/archives ext4 =

defaults 0 1


Une idée ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/2013396.TdcVqkhtRX@basket
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
S
Le #26075332
Bonjour,

Le lundi 07 avril 2014 à 15:58, Michel a écrit :
J'ai mis à jour mon serveur ce WE (de Squeeze à Wheezy) et j'ai un soucis avec
la partition /dev/sda1. Elle n'est reconnus que par son UUID ce qui me pose
soucis avec cacti notamment... Pas de problème pour les 3 autres (/dev/sdb1 et
/dev/sdc1).



[...]

[]:~ # ls -l /dev/disk/by-uuid



[...]

[]:~ # mount



[...]

Mon fstab :



[...]

Tout ça me paraît correct…

Quel est le problème exactement ?

Comment se manifeste-t-il ?

Que donne la commande suivante ?
ls -l /dev/disk/by-label

Et celle-la ?
dumpe2fs /dev/sda1 | grep "Filesystem volume name:"

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Michel
Le #26075412
Le lundi 7 avril 2014, 16:18:42 Sébastien NOBILI a écrit :

Que donne la commande suivante ?
ls -l /dev/disk/by-label



Je n'ai pas ce répertoire... J'ai by-path, by-id, by-uuid.
Ce qui est bizarre, c'est que sdb1 et sdc1 fonctionnent bien. Un problè me avec
grub ?

/dev/disk/by-path:
total 0
lrwxrwxrwx 1 root root 9 avril 7 15:38 pci-0000:00:11.0-scsi-0:0:0:0 ->
../../sda
lrwxrwxrwx 1 root root 10 avril 7 15:38 pci-0000:00:11.0-scsi-0:0:0:0- part1 -
../../sda1


lrwxrwxrwx 1 root root 10 avril 7 15:38 pci-0000:00:11.0-scsi-0:0:0:0- part2 -
../../sda2


lrwxrwxrwx 1 root root 10 avril 7 15:38 pci-0000:00:11.0-scsi-0:0:0:0- part5 -
../../sda5


lrwxrwxrwx 1 root root 9 avril 7 15:38 pci-0000:00:11.0-scsi-1:0:0:0 ->
../../sdb
lrwxrwxrwx 1 root root 10 avril 7 15:38 pci-0000:00:11.0-scsi-1:0:0:0- part1 -
../../sdb1


lrwxrwxrwx 1 root root 9 avril 7 15:38 pci-0000:00:11.0-scsi-2:0:0:0 ->
../../sdc
lrwxrwxrwx 1 root root 10 avril 7 15:38 pci-0000:00:11.0-scsi-2:0:0:0- part1 -
../../sdc1



/dev/disk/by-uuid:
total 0
lrwxrwxrwx 1 root root 10 avril 7 15:38 02a1386f-f861-4245-8787-d7960c ebce38
-> ../../sda1
lrwxrwxrwx 1 root root 10 avril 7 15:38 432a611f-7830-4196-bb87-318da4 501ede
-> ../../sdb1
lrwxrwxrwx 1 root root 10 avril 7 15:38 828c1c42-30fd-4d6a-b5cf-efb2c6 dc563c
-> ../../sda5
lrwxrwxrwx 1 root root 10 avril 7 15:38 f17189ee-e901-45cb-be02-f3be01 29b956
-> ../../sdc1


Et celle-la ?
dumpe2fs /dev/sda1 | grep "Filesystem volume name:"



[]:~ # dumpe2fs /dev/sda1 | grep "Filesystem volume name: "
dumpe2fs 1.42.5 (29-Jul-2012)
Filesystem volume name: <none>

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
steve
Le #26075442
Le 07-04-2014, à 15:58:32 +0200, Michel a écrit :

Bonjour,

J'ai mis à jour mon serveur ce WE (de Squeeze à Wheezy) et j'ai un soucis avec
la partition /dev/sda1. Elle n'est reconnus que par son UUID ce qui me pose
soucis avec cacti notamment... Pas de problème pour les 3 autres (/dev/sdb1 et
/dev/sdc1).



Quel type de souci ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Michel
Le #26075512
Le lundi 7 avril 2014, 17:06:51 steve a écrit :
Le 07-04-2014, à 15:58:32 +0200, Michel a écrit :
> Bonjour,
>
> J'ai mis à jour mon serveur ce WE (de Squeeze à Wheezy) et j'ai un soucis
> avec la partition /dev/sda1. Elle n'est reconnus que par son UUID c e qui
> me pose soucis avec cacti notamment... Pas de problème pour les 3 autres
> (/dev/sdb1 et /dev/sdc1).



Cacti ne me reporte plus l'espace disque dispo... Comme il cherche /dev /sda et
que celle-ci a "disparu", ca ne marche pas.

Idem mout la commande mount ou df, je ne vois que l'uuid...
[]:~ # df -h
Sys. fich. Taille Util. Dis po Uti%
Monté sur
rootfs 146G 46G 9 3G 34%
/
udev 10M 0 1 0M 0%
/dev
tmpfs 88M 628K 8 7M 1%
/run
/dev/disk/by-uuid/02a1386f-f861-4245-8787-d7960cebce38 146G 46G 9 3G 34%
/
tmpfs 5,0M 0 5, 0M 0%
/run/lock
tmpfs 517M 0 51 7M 0%
/run/shm
/dev/sdb1 1,8T 558G 1, 3T 31%
/srv
/dev/sdc1 917G 290G 61 9G 32%
/var/archives

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
steve
Le #26075502
Le 07-04-2014, à 17:11:22 +0200, Michel a écrit :

Le lundi 7 avril 2014, 17:06:51 steve a écrit :
> Le 07-04-2014, à 15:58:32 +0200, Michel a écrit :
> > Bonjour,
> >
> > J'ai mis à jour mon serveur ce WE (de Squeeze à Wheezy) et j'ai un soucis
> > avec la partition /dev/sda1. Elle n'est reconnus que par son UUID ce qui
> > me pose soucis avec cacti notamment... Pas de problème pour les 3 autres
> > (/dev/sdb1 et /dev/sdc1).

Cacti ne me reporte plus l'espace disque dispo... Comme il cherche /dev/sda et
que celle-ci a "disparu", ca ne marche pas.



Peux pas t'aider pour cacti (je n'utilise pas), mais

Idem mout la commande mount ou df, je ne vois que l'uuid...
[]:~ # df -h
Sys. fich. Taille Util. Dispo Uti%
Monté sur
rootfs 146G 46G 93G 34%
/
udev 10M 0 10M 0%
/dev
tmpfs 88M 628K 87M 1%
/run
/dev/disk/by-uuid/02a1386f-f861-4245-8787-d7960cebce38 146G 46G 93G 34%



ça c'est le bug #653073, bien pénible sur un petit terminal. Perso,
j'ai créé un alias pour df -h (dans ~/.bashrc):

alias df='df -h | sed "/dev/disk.*/d"'

Faudra juste s'en souvenir lorsque ce bug sera corrigé....:)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Michel
Le #26075992
Le lundi 7 avril 2014, 17:23:17 steve a écrit :
> Idem mout la commande mount ou df, je ne vois que l'uuid...
> []:~ # df -h
> Sys. fich. Taille Util. Dispo
> Uti% Monté sur
> rootfs 146G 46G 93G
> 34% /
> udev 10M 0 10M
> 0% /dev
> tmpfs 88M 628K 87M
> 1% /run
> /dev/disk/by-uuid/02a1386f-f861-4245-8787-d7960cebce38 146G 46G 93G
> 34%
ça c'est le bug #653073, bien pénible sur un petit terminal. Pe rso,
j'ai créé un alias pour df -h (dans ~/.bashrc):

alias df='df -h | sed "/dev/disk.*/d"'

Faudra juste s'en souvenir lorsque ce bug sera corrigé....:)



En fait le bug #653073 est fermé mais chez moi j'ai encore ce comport ement et
sur d'autres outils que df.
mount, et sans doute d'autres sont affectés.

Faut-il le ré-ouvrir ?
Avez-vous ce comportement chez vous ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
steve
Le #26076022
Le 07-04-2014, à 21:57:27 +0200, Michel a écrit :

> > /dev/disk/by-uuid/02a1386f-f861-4245-8787-d7960cebce38 146G 46G 93G
> > 34%
> ça c'est le bug #653073, bien pénible sur un petit terminal. Perso,
> j'ai créé un alias pour df -h (dans ~/.bashrc):
>
> alias df='df -h | sed "/dev/disk.*/d"'
>
> Faudra juste s'en souvenir lorsque ce bug sera corrigé....:)

En fait le bug #653073 est fermé mais chez moi j'ai encore ce comportement et



Enfin, il a été fermé le 13 novembre 2012, mais quelques temps plus
tard des gens se sont manifestés pour dire qu'il affectait encore
wheezy. Donc c'est une fermeture malheureuse..

sur d'autres outils que df.
mount, et sans doute d'autres sont affectés.



Pareil mount chez moi.

Faut-il le ré-ouvrir ?



Pourquoi pas ?

Avez-vous ce comportement chez vous ?



Oui.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Michel
Le #26077062
Le lundi 7 avril 2014, 22:21:55 steve a écrit :
> En fait le bug #653073 est fermé mais chez moi j'ai encore ce com portement
> et

Enfin, il a été fermé le 13 novembre 2012, mais quelques temp s plus
tard des gens se sont manifestés pour dire qu'il affectait encore
wheezy. Donc c'est une fermeture malheureuse..



Ce bug a été fermé avec la version 8.20-1 de coreutils.
Or wheezy en est à la version 8.13-3.5.

Donc normal que ce bug affecte encore wheezy...
Je vais tâcher d'installer une version plus récente de coreutils.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Michel
Le #26077342
Le mardi 8 avril 2014, 13:31:03 Michel a écrit :
Le lundi 7 avril 2014, 22:21:55 steve a écrit :
> > En fait le bug #653073 est fermé mais chez moi j'ai encore ce
> > comportement
> > et
> >
> Enfin, il a été fermé le 13 novembre 2012, mais quelques te mps plus
> tard des gens se sont manifestés pour dire qu'il affectait enco re
> wheezy. Donc c'est une fermeture malheureuse..

Ce bug a été fermé avec la version 8.20-1 de coreutils.
Or wheezy en est à la version 8.13-3.5.

Donc normal que ce bug affecte encore wheezy...
Je vais tâcher d'installer une version plus récente de coreutils.



Aie aie aie...
En forçant un peu la main à dpkg, j'ai cassé mon installation...

[]:~ # apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus
nécessaires :
bittornado fonts-lyx fping fwbuilder-common fwbuilder-doc libaio1
libarchive-zip-perl libbsd-resource-perl libdbi1 libdevel-symdump-perl
libdigest-hmac-perl libfile-rsyncp-perl libglu1-mesa libhtml-template -perl
libio-dirent-perl libjs-jquery libkonq5-templates libmcrypt4
libnet-snmp-perl libnetfilter-queue1 libnussl1 libodbc1 libonig2 libp q5
libpython2.7 libqdbm14 libradiusclient-ng2 libtime-modules-perl
libupsclient1 libwxbase2.8-0 mysql-server-core-5.5 nagios-images nut- client
python-crypto python-dateutil python-gobject python-ipy
python-matplotlib-data python-mysqldb python-nevow python-openssl pyt hon-pam
python-pkg-resources python-pyparsing python-serial
python-twisted-bin python-twisted-core python-twisted-web python-
zope.interface qstat snmp tcl8.5 tdb-tools unixodbc xaw3dg
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
emacs23-nox libgd2-noxpm lynx-cur makedev tcl8.4 tk8.4
Paquets suggérés :
emacs23-common-non-dfsg libgd-tools tcl-tclreadline
Les paquets suivants seront ENLEVÉS :
apache2 apache2-mpm-prefork apache2.2-common apt-listchanges backup-m anager
backuppc blt cacti cifs-utils colord console-setup
console-setup-linux coreutils cryptsetup-bin cups cups-driver-gutenpr int
cups-filters cups-pdf dbconfig-common dmsetup dwww e2fsprogs
eject emacs emacs23 fontconfig fontconfig-config foo2zjs foomatic-db- engine
foomatic-filters fwbuilder gconf-service gconf2
gconf2-common ghostscript ghostscript-cups gitweb gnuplot gnuplot-nox grub-
common grub-pc grub-pc-bin grub2-common gsmartcontrol hplip
hplip-cups ifupdown imagemagick info2www initramfs-tools initscripts
k4dirstat katepart kde-runtime kdebase-runtime kdelibs-bin
kdelibs5-plugins kdirstat kdoctools keyboard-configuration libapache2 -mod-
perl2 libapache2-mod-php5 libapache2-mod-python
libapache2-reload-perl libass4 libcairo-gobject2 libcairo2 libcairomm -1.0-1
libcanberra-gtk3-0 libcanberra-gtk3-module libcryptsetup4
libdbusmenu-qt2 libdevmapper-event1.02.1 libdevmapper1.02.1 libfontco nfig1
libgconf-2-4 libgd2-xpm libglade2-0 libgphoto2-2 libgs9
libgtk-3-0 libgtk-3-bin libgtk2.0-0 libgtk2.0-bin libgtkmm-2.4-1c2a
libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5
libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5
libkidletime4 libkio5 libkjsembed4 libkmediaplayer4
libknewstuff3-4 libknotifyconfig4 libkonq-common libkonq5abi1 libkpar ts4
libkrosscore4 libktexteditor4 liblvm2app2.2 libm17n-0
libmagickcore5 libmagickcore5-extra libmagickwand5 libnepomuk4
libnepomukquery4a libnepomukutils4 libnss-winbind libpam-winbind
libpango1.0-0 libpangomm-1.4-1 libpaper-utils libpaper1 libparted0deb ian1
libphonon4 libphp-adodb libplasma3 libpolkit-qt-1-1
libpoppler19 libqt4-declarative libqt4-designer libqt4-opengl libqt4-
qt3support libqt4-svg libqtgui4 libqtwebkit4 librrd4 librsvg2-2
librsvg2-common libsane libsolid4 libsvm-tools libxft2 linux-base lin ux-
image-2.6-amd64 linux-image-2.6.32-5-amd64
linux-image-3.2.0-4-amd64 linux-image-amd64 mysql-server mysql-server -5.5
nagios-plugins nagios-plugins-basic nagios-plugins-common
nagios-plugins-standard nagios3 nagios3-cgi nagios3-common nagios3-co re nfs-
common nfs-kernel-server notification-daemon nufw nulog nut
nut-cgi nut-server nut-snmp openssh-server phonon phonon-backend-vlc php5
php5-cli php5-common php5-gd php5-ldap php5-mcrypt php5-mysql
php5-snmp php5-xsl phpldapadmin phpmyadmin phpsysinfo plasma-scripten gine-
javascript poppler-utils printer-driver-c2050
printer-driver-foo2zjs printer-driver-gutenprint printer-driver-hpcup s
printer-driver-m2300w printer-driver-pnm2ppa
printer-driver-postscript-hp printer-driver-ptouch printer-driver-pxl jr
printer-driver-sag-gdi printer-driver-splix procps psutils
python-cairo python-glade2 python-gtk2 python-matplotlib python-tk qt 4-
qtconfig resolvconf rpcbind rrdtool rsyslog samba samba-common
samba-common-bin slapd smbclient swat sysvinit tk8.5 torrentflux ucf udev
udisks upower util-linux vlc vlc-nox vlc-plugin-notify
vlc-plugin-pulse winbind x11-utils xterm
Les NOUVEAUX paquets suivants seront installés :
emacs23-nox libgd2-noxpm lynx-cur makedev tcl8.4 tk8.4
ATTENTION : Les paquets essentiels suivants vont être enlevés.
Vous NE devez PAS faire ceci, à moins de savoir exactement ce
que vous êtes en train de faire.
coreutils e2fsprogs util-linux (en raison de e2fsprogs) sysvinit init scripts
(en raison de sysvinit)
0 mis à jour, 6 nouvellement installés, 225 à enlever et 2 non mi s à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 7 874 ko dans les archives.
Après cette opération, 744 Mo d'espace disque seront libérés.
Vous êtes sur le point de faire quelque chose de potentiellement dang ereux
Pour continuer, tapez la phrase « Oui, faites ce que je vous dis ! »
?]


[]:~ # dpkg -i --force-all libc6_2.13-38+deb7u1_amd64.deb
rm: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (re quired
by rm)

J'ai à chaque fois cette erreur avec GLIBC... Comment puis-je revenir à l'état
antérieur du système ??



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Sébastien NOBILI
Le #26077372
Bonjour,

Le mardi 08 avril 2014 à 14:50, Michel a écrit :
[]:~ # dpkg -i --force-all libc6_2.13-38+deb7u1_amd64.deb
rm: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required
by rm)



Ne jamais forcer les opérations qui touchent à la libc ! Je l'ai appris à mes
dépens en faisant à peu près la même chose que toi il y a bien longtemps.

Vois le bon coté des choses, c'est une erreur que tu ne referas plus !

J'ai à chaque fois cette erreur avec GLIBC... Comment puis-je revenirà l'état
antérieur du système ??



La libc de ton système étant cassée, il n'est plus utilisable. Ta seule solution
est de démarrer sur un LiveCD et d'écraser la libc.

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme