VALEUR D'UNE COLONNE

Le
FA
bonsoir,

comment faire si je veux qu'une cellule raméne une valeur si dans une
colonne il y a une valeur..

exemple si dans la colonne (a1;a100) il y a la valeur 45 dans une des
cellules de la colonnes alors dans la cellule c1 il y a la valeur qui est à
coté de la cellule 45 de la colonne b1;b100


Merci
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tatanka
Le #5137331
Salut FA,

Quelque chose du genre :
Tu mets ta valeur à rechercher en A1:A100 dans une certaine cellule.
Dans mon exemple, je l'ai mise en D1.
Tu utilises alors cette formule :
=INDEX($B$1:$B$100;EQUIV($D$1;$A$1:$A$100;0);1)
Tu pourrais aussi metttre directement la valeur cherchée en A:A100
dans la formule :
=INDEX($B$1:$B$100;EQUIV(45;$A$1:$A$100;0);1)

Serge


"FA"
bonsoir,

comment faire si je veux qu'une cellule raméne une valeur si dans une colonne il y a une valeur..

exemple si dans la colonne (a1;a100) il y a la valeur 45 dans une des cellules de la colonnes alors dans la cellule c1 il y a la
valeur qui est à coté de la cellule 45 de la colonne b1;b100


Merci


delta7253
Le #5137311
Bonsoir

=RECHERCHEV(A1:B100;45;2)

le "2", c'est pour dire qu'on cherche dans la deuxième colonne du tableau

à la place de la valeur recherchée, on peut mettre une cellule dans laquelle
on saisit la valeur que l'on cherche


"FA"
bonsoir,

comment faire si je veux qu'une cellule raméne une valeur si dans une
colonne il y a une valeur..

exemple si dans la colonne (a1;a100) il y a la valeur 45 dans une des
cellules de la colonnes alors dans la cellule c1 il y a la valeur qui est
à coté de la cellule 45 de la colonne b1;b100


Merci


Michel Samoey
Le #5137281
Bonjour,
des questions pour comprendre le pb
a) dans la colonne A il n'y a au mieux qu'un seul nombre ? (ce nombre est
dans la cellule Ax)
b) la valeur recherchée se situe dans la colonne B situé à coté de la
cellule Ax ?


Cordialement
Michel
FA
Le #5288521
oui dans la cellule B ou H ou autre mais dans le principe c'est ça il faut
qu'il cherche la valeur sur la meme ligne que le nombre dans la colonne A

Merci

"Michel Samoey" news:4798f05f$0$883$
Bonjour,
des questions pour comprendre le pb
a) dans la colonne A il n'y a au mieux qu'un seul nombre ? (ce nombre est
dans la cellule Ax)
b) la valeur recherchée se situe dans la colonne B situé à coté de la
cellule Ax ?


Cordialement
Michel



FA
Le #5288511
ça ne fonctionne ça m'ecrit #VALEUR

"delta7253" news:
Bonsoir

=RECHERCHEV(A1:B100;45;2)

le "2", c'est pour dire qu'on cherche dans la deuxième colonne du tableau

à la place de la valeur recherchée, on peut mettre une cellule dans
laquelle
on saisit la valeur que l'on cherche


"FA"
bonsoir,

comment faire si je veux qu'une cellule raméne une valeur si dans une
colonne il y a une valeur..

exemple si dans la colonne (a1;a100) il y a la valeur 45 dans une des
cellules de la colonnes alors dans la cellule c1 il y a la valeur qui est
à coté de la cellule 45 de la colonne b1;b100


Merci






Michel Samoey
Le #5143751
Bonjour,
un truc comme ça peut être si dans la colonne A il n'y a qu'un seul nombre
=INDEX(B1:B100;EQUIV(SOMME(A1:A100);A1:A100;0))

Cordialement
Michel
"FA"
oui dans la cellule B ou H ou autre mais dans le principe c'est ça il faut
qu'il cherche la valeur sur la meme ligne que le nombre dans la colonne A

Merci



FA
Le #5143551
Ok ça marche très bien, mais maintenant je voudrais que si dans la colonne A
il n'y a pas de valeur ne pas avoir en retour le #N/A mais avoir une cellule
vide
j'ai essayer ça
=SI((feuille1!$A$3:$A$70)="";"";INDEX((feuille1!$B$3:$B$70);EQUIV(4;(feuille1!$A$3:$A$70);0);1))
mais ça ne marche pas

Merci

"Tatanka" news:
Salut FA,

Quelque chose du genre :
Tu mets ta valeur à rechercher en A1:A100 dans une certaine cellule.
Dans mon exemple, je l'ai mise en D1.
Tu utilises alors cette formule :
=INDEX($B$1:$B$100;EQUIV($D$1;$A$1:$A$100;0);1)
Tu pourrais aussi metttre directement la valeur cherchée en A:A100
dans la formule :
=INDEX($B$1:$B$100;EQUIV(45;$A$1:$A$100;0);1)

Serge


"FA"
bonsoir,

comment faire si je veux qu'une cellule raméne une valeur si dans une
colonne il y a une valeur..

exemple si dans la colonne (a1;a100) il y a la valeur 45 dans une des
cellules de la colonnes alors dans la cellule c1 il y a la valeur qui est
à coté de la cellule 45 de la colonne b1;b100


Merci






Brunos
Le #5143421
"FA" a écrit
Ok ça marche très bien, mais maintenant je voudrais que si dans la
colonne A il n'y a pas de valeur ne pas avoir en retour le #N/A mais
avoir une cellule vide
j'ai essayer ça
=SI((feuille1!$A$3:$A$70)="";"";INDEX((feuille1!$B$3:$B$70);EQUIV(4;(feuille1!$A$3:$A$70);0);1))
mais ça ne marche pas


essaie plutôt ça:
=SI(ESTERREUR(ta_formule);"";ta_formule)
Brunos

Michel Samoey
Le #5143411
Bonjour,
avec
SI(SOMME(feuille1!$B$3:$B$70)=0;"";INDEX((feuille1!$B$3:$B$70);EQUIV(4;(feuille1!$A$3:$A$70);0);1))

mais un truc m'intrigue d'où vient le 4 dans EQUIV ?
Cordialement
Michel

"FA"
Ok ça marche très bien, mais maintenant je voudrais que si dans la colonne
A il n'y a pas de valeur ne pas avoir en retour le #N/A mais avoir une
cellule vide
j'ai essayer ça
=SI((feuille1!$A$3:$A$70)="";"";INDEX((feuille1!$B$3:$B$70);EQUIV(4;(feuille1!$A$3:$A$70);0);1))
mais ça ne marche pas

Merci

"Tatanka" news:
Salut FA,

Quelque chose du genre :
Tu mets ta valeur à rechercher en A1:A100 dans une certaine cellule.
Dans mon exemple, je l'ai mise en D1.
Tu utilises alors cette formule :
=INDEX($B$1:$B$100;EQUIV($D$1;$A$1:$A$100;0);1)
Tu pourrais aussi metttre directement la valeur cherchée en A:A100
dans la formule :
=INDEX($B$1:$B$100;EQUIV(45;$A$1:$A$100;0);1)

Serge


"FA"
bonsoir,

comment faire si je veux qu'une cellule raméne une valeur si dans une
colonne il y a une valeur..

exemple si dans la colonne (a1;a100) il y a la valeur 45 dans une des
cellules de la colonnes alors dans la cellule c1 il y a la valeur qui
est à coté de la cellule 45 de la colonne b1;b100


Merci









Publicité
Poster une réponse
Anonyme