#valeur

Le
globule
bonsoir,

comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
=($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs en
pourcentage et je veux faire la moyenne ou la somme mais ces cellules me pose
probleme car le resultats ne se fait pas et m'indique #valeur.
j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
calcul);"";(plage de calcul)) mais cela ne marche pas.
l'exemple est donc le suivant:

sur la ligne 1 par exemple:

en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la meme
plage.
le calcul est une somme ou moyenne de pourcentage.
merci de votre aide

globule
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #20596511
Bonjour,

Il serait sage d'intervenir pour faire disparaître ces #Valeur.

Ceci était dit, tu peux utiliser une formule de ce type pour
ne pas avoir à tenir compte des cellules comportant des #Valeur

Tu adaptes la plage de cellules selon ton applicationl.

La validation de cette formule matricielle se fait par Maj+Ctrl + Enter
=MOYENNE(SI(NON(ESTERREUR(A1:A5));A1:A5))



"globule" discussion :
bonsoir,

comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
=($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs en
pourcentage et je veux faire la moyenne ou la somme mais ces cellules me pose
probleme car le resultats ne se fait pas et m'indique #valeur.
j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
calcul);"";(plage de calcul)) mais cela ne marche pas.
l'exemple est donc le suivant:

sur la ligne 1 par exemple:

en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la meme
plage.
le calcul est une somme ou moyenne de pourcentage.
merci de votre aide

globule
Daniel.C
Le #20596501
Bonjour.
Une moyenne sur la plage A4:G4 contenant des valeurs d'erreur (formule
matricielle à valider avec Ctrl+Maj+Entrée) :
=SOMME(SI(ESTERR(A4:G4);0;A4:G4)/NB(A4:G4))
Daniel

bonsoir,

comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
=($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs en
pourcentage et je veux faire la moyenne ou la somme mais ces cellules me pose
probleme car le resultats ne se fait pas et m'indique #valeur.
j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
calcul);"";(plage de calcul)) mais cela ne marche pas.
l'exemple est donc le suivant:

sur la ligne 1 par exemple:

en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la meme
plage.
le calcul est une somme ou moyenne de pourcentage.
merci de votre aide

globule


jero
Le #20596561
Salut,
En 1)
=SI(ESTERREUR($AF$1/AH12/$AH$9/1000/$L$3);"";$AF$1/AH12/$AH$9/1000/$L$3)
Ensuite, tu pouras faire la somme ou la moyenne sans pb.
Rem : Pourquoi autant de parenthèses ? Je ne les ai pas remises, vérifie....
A+
jpg
"globule" news:
bonsoir,

comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
=($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs
en
pourcentage et je veux faire la moyenne ou la somme mais ces cellules me
pose
probleme car le resultats ne se fait pas et m'indique #valeur.
j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
calcul);"";(plage de calcul)) mais cela ne marche pas.
l'exemple est donc le suivant:

sur la ligne 1 par exemple:

en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la
meme
plage.
le calcul est une somme ou moyenne de pourcentage.
merci de votre aide

globule


globule
Le #20596851
Merci michdenis pour ta reponse.
mais malheureusement le resultats n'est pas ce que voudrai voir sniff sniff
hihi. j'ai comme resultat 0 alors que sur la ligne il y a un 115,8% (a seule
valeur sur cette ligne car le reste est avec ce fameux #VALEUR) donc le
resultats devrait etre 115,8%.....

oui tu as raison de dire qu'il serait bien de faire disparaitre ces #Valeur
mais malheureusement je ne peux pas ou ne sais pas car les cellules qui ont
comme resultats ce maudit #Valeur font reference a d'autres cellules pour un
calcul de pourcentage

j'ai essaye de le faire en utilisant
=(si(esterreur(($AF$1/(AG11/($AG$9/1000)))/$L$3;"";)
donc je traduit ce que je voulais faire car je ne maitrise pas tout,
c'est faire le calcul suivant la petite formule qui me determine un
pourcentage et si la cellule est vide ne rien mettre ( la cellule vide est la
cellule AG11) comme ça je n'aurais plus mais fameux #VALEUR et je pourrai
faire un simple calcul

voila voila


"michdenis" a écrit :

Bonjour,

Il serait sage d'intervenir pour faire disparaître ces #Valeur.

Ceci était dit, tu peux utiliser une formule de ce type pour
ne pas avoir à tenir compte des cellules comportant des #Valeur

Tu adaptes la plage de cellules selon ton applicationl.

La validation de cette formule matricielle se fait par Maj+Ctrl + Enter
=MOYENNE(SI(NON(ESTERREUR(A1:A5));A1:A5))



"globule" discussion :
bonsoir,

comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
=($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs en
pourcentage et je veux faire la moyenne ou la somme mais ces cellules me pose
probleme car le resultats ne se fait pas et m'indique #valeur.
j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
calcul);"";(plage de calcul)) mais cela ne marche pas.
l'exemple est donc le suivant:

sur la ligne 1 par exemple:

en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la meme
plage.
le calcul est une somme ou moyenne de pourcentage.
merci de votre aide

globule



globule
Le #20596841
Merci daniel,

idem que pour michdenis a la difference c'est que le resultat est Vrai bon
ok c'est juste mais je ne voudrai bien voir mon resultats 115,8% mais merci
pour ton aide je vais continuer a chercher avec vos infos


"Daniel.C" a écrit :

Bonjour.
Une moyenne sur la plage A4:G4 contenant des valeurs d'erreur (formule
matricielle à valider avec Ctrl+Maj+Entrée) :
=SOMME(SI(ESTERR(A4:G4);0;A4:G4)/NB(A4:G4))
Daniel

> bonsoir,
>
> comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
> celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
> =($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs en
> pourcentage et je veux faire la moyenne ou la somme mais ces cellules me pose
> probleme car le resultats ne se fait pas et m'indique #valeur.
> j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
> calcul);"";(plage de calcul)) mais cela ne marche pas.
> l'exemple est donc le suivant:
>
> sur la ligne 1 par exemple:
>
> en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la meme
> plage.
> le calcul est une somme ou moyenne de pourcentage.
> merci de votre aide
>
> globule


.



michdenis
Le #20596831
Regarde là un exemple :

http://cjoint.com/?lut533WC7P



"globule" discussion :
Merci michdenis pour ta reponse.
mais malheureusement le resultats n'est pas ce que voudrai voir sniff sniff
hihi. j'ai comme resultat 0 alors que sur la ligne il y a un 115,8% (a seule
valeur sur cette ligne car le reste est avec ce fameux #VALEUR) donc le
resultats devrait etre 115,8%.....

oui tu as raison de dire qu'il serait bien de faire disparaitre ces #Valeur
mais malheureusement je ne peux pas ou ne sais pas car les cellules qui ont
comme resultats ce maudit #Valeur font reference a d'autres cellules pour un
calcul de pourcentage

j'ai essaye de le faire en utilisant
=(si(esterreur(($AF$1/(AG11/($AG$9/1000)))/$L$3;"";)
donc je traduit ce que je voulais faire car je ne maitrise pas tout,
c'est faire le calcul suivant la petite formule qui me determine un
pourcentage et si la cellule est vide ne rien mettre ( la cellule vide est la
cellule AG11) comme ça je n'aurais plus mais fameux #VALEUR et je pourrai
faire un simple calcul

voila voila


"michdenis" a écrit :

Bonjour,

Il serait sage d'intervenir pour faire disparaître ces #Valeur.

Ceci était dit, tu peux utiliser une formule de ce type pour
ne pas avoir à tenir compte des cellules comportant des #Valeur

Tu adaptes la plage de cellules selon ton applicationl.

La validation de cette formule matricielle se fait par Maj+Ctrl + Enter
=MOYENNE(SI(NON(ESTERREUR(A1:A5));A1:A5))



"globule" discussion :
bonsoir,

comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
=($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs en
pourcentage et je veux faire la moyenne ou la somme mais ces cellules me pose
probleme car le resultats ne se fait pas et m'indique #valeur.
j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
calcul);"";(plage de calcul)) mais cela ne marche pas.
l'exemple est donc le suivant:

sur la ligne 1 par exemple:

en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la meme
plage.
le calcul est une somme ou moyenne de pourcentage.
merci de votre aide

globule



globule
Le #20597031
Merci Jero

j'ai donc effectivement fait ce que tu as fait sur chaque cellule ce qui me
permet d'eliminer tous les #Valeur ouff et comme tu le dis je n'ai plus cas
j'avec appliquer cette formule mais a moitie donc cela ne pouvait pas
fonctionner et donc merci a toi

"jero" a écrit :

Salut,
En 1)
=SI(ESTERREUR($AF$1/AH12/$AH$9/1000/$L$3);"";$AF$1/AH12/$AH$9/1000/$L$3)
Ensuite, tu pouras faire la somme ou la moyenne sans pb.
Rem : Pourquoi autant de parenthèses ? Je ne les ai pas remises, vérifie....
A+
jpg
"globule" news:
> bonsoir,
>
> comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
> celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
> =($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs
> en
> pourcentage et je veux faire la moyenne ou la somme mais ces cellules me
> pose
> probleme car le resultats ne se fait pas et m'indique #valeur.
> j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
> calcul);"";(plage de calcul)) mais cela ne marche pas.
> l'exemple est donc le suivant:
>
> sur la ligne 1 par exemple:
>
> en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la
> meme
> plage.
> le calcul est une somme ou moyenne de pourcentage.
> merci de votre aide
>
> globule


.



globule
Le #20597021
merci vraiment merci c'est cool cela marche super bien

et bonne soirée

globule

"michdenis" a écrit :

Regarde là un exemple :

http://cjoint.com/?lut533WC7P



"globule" discussion :
Merci michdenis pour ta reponse.
mais malheureusement le resultats n'est pas ce que voudrai voir sniff sniff
hihi. j'ai comme resultat 0 alors que sur la ligne il y a un 115,8% (a seule
valeur sur cette ligne car le reste est avec ce fameux #VALEUR) donc le
resultats devrait etre 115,8%.....

oui tu as raison de dire qu'il serait bien de faire disparaitre ces #Valeur
mais malheureusement je ne peux pas ou ne sais pas car les cellules qui ont
comme resultats ce maudit #Valeur font reference a d'autres cellules pour un
calcul de pourcentage

j'ai essaye de le faire en utilisant
=(si(esterreur(($AF$1/(AG11/($AG$9/1000)))/$L$3;"";)
donc je traduit ce que je voulais faire car je ne maitrise pas tout,
c'est faire le calcul suivant la petite formule qui me determine un
pourcentage et si la cellule est vide ne rien mettre ( la cellule vide est la
cellule AG11) comme ça je n'aurais plus mais fameux #VALEUR et je pourrai
faire un simple calcul

voila voila


"michdenis" a écrit :

> Bonjour,
>
> Il serait sage d'intervenir pour faire disparaître ces #Valeur.
>
> Ceci était dit, tu peux utiliser une formule de ce type pour
> ne pas avoir à tenir compte des cellules comportant des #Valeur
>
> Tu adaptes la plage de cellules selon ton applicationl.
>
> La validation de cette formule matricielle se fait par Maj+Ctrl + Enter
> =MOYENNE(SI(NON(ESTERREUR(A1:A5));A1:A5))
>
>
>
> "globule" > discussion :
> bonsoir,
>
> comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
> celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
> =($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs en
> pourcentage et je veux faire la moyenne ou la somme mais ces cellules me pose
> probleme car le resultats ne se fait pas et m'indique #valeur.
> j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
> calcul);"";(plage de calcul)) mais cela ne marche pas.
> l'exemple est donc le suivant:
>
> sur la ligne 1 par exemple:
>
> en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la meme
> plage.
> le calcul est une somme ou moyenne de pourcentage.
> merci de votre aide
>
> globule
>


globule
Le #20597201
petite question pour finir lorsque l'on fait un calcul simple (moyenne) et
q'aucune cellule ne possede de valeur le resultats est #DIV/0! comment faire
pour que la cellule soit vide car j'ai essaye =moyenne(si(esterreur(la
page);"";0) mais cela ne marche pas la cellule indique #Valeur.

merci

"jero" a écrit :

Salut,
En 1)
=SI(ESTERREUR($AF$1/AH12/$AH$9/1000/$L$3);"";$AF$1/AH12/$AH$9/1000/$L$3)
Ensuite, tu pouras faire la somme ou la moyenne sans pb.
Rem : Pourquoi autant de parenthèses ? Je ne les ai pas remises, vérifie....
A+
jpg
"globule" news:
> bonsoir,
>
> comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
> celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
> =($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs
> en
> pourcentage et je veux faire la moyenne ou la somme mais ces cellules me
> pose
> probleme car le resultats ne se fait pas et m'indique #valeur.
> j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
> calcul);"";(plage de calcul)) mais cela ne marche pas.
> l'exemple est donc le suivant:
>
> sur la ligne 1 par exemple:
>
> en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la
> meme
> plage.
> le calcul est une somme ou moyenne de pourcentage.
> merci de votre aide
>
> globule


.



isabelle
Le #20597291
bonjour globule,

c'est :

=SI(ESTERREUR(la formule);"";la formule)

=SI(ESTERREUR(moyenne(plage);"";moyenne(plage))


isabelle



globule a écrit :
petite question pour finir lorsque l'on fait un calcul simple (moyenne) et
q'aucune cellule ne possede de valeur le resultats est #DIV/0! comment faire
pour que la cellule soit vide car j'ai essaye =moyenne(si(esterreur(la
page);"";0) mais cela ne marche pas la cellule indique #Valeur.

merci

"jero" a écrit :


Salut,
En 1)
=SI(ESTERREUR($AF$1/AH12/$AH$9/1000/$L$3);"";$AF$1/AH12/$AH$9/1000/$L$3)
Ensuite, tu pouras faire la somme ou la moyenne sans pb.
Rem : Pourquoi autant de parenthèses ? Je ne les ai pas remises, vérifie....
A+
jpg
"globule" news:

bonsoir,

comment faire un calcul (somme ou moyenne) d'une ligne et dont cetraines
celulles de cette ligne ont comme valeur #valeur (due a un calcul de type
=($AF$1/(AH12/($AH$9/1000)))/$L$3) sur cette ligne je possede des valeurs
en
pourcentage et je veux faire la moyenne ou la somme mais ces cellules me
pose
probleme car le resultats ne se fait pas et m'indique #valeur.
j'ai essayer la fonction ESTERREUR avec =somme(ESTERREUR(la palge de
calcul);"";(plage de calcul)) mais cela ne marche pas.
l'exemple est donc le suivant:

sur la ligne 1 par exemple:

en A1 cellule de la moyenne de la plage C1 à M1 et en B1 la somme de la
meme
plage.
le calcul est une somme ou moyenne de pourcentage.
merci de votre aide

globule



.






Publicité
Poster une réponse
Anonyme