#VALEUR

Le
verdo.v4
Bonjour,
Je suis débutant sur excel et j'ai besoin d'un petit coup de main si cela=
était possible.
Je fais un planning horaires pour la gestion des heures de mon équipe.
7 colonnes de C a I pour les jours de la semaine.
2 lignes, lignes 19 (heures arrivée) ligne 20 (heure départ)
nous travaillons sur une amplitude horaire de 07h20 et 0h20 de déductible=
ce qui ramène a 07h00.
Mon problème par rapport a ma formule, c'est que le, les jours non travai=
llé (weekend) il me déduit quand même les 0h20 par jours.
Et que je mets dans la cellule RP (repos) ou CP ou ABS ou MA ect cela me=
marque #VALEUR
Je suis vraiment pas fort en formule, si quelqu'un pouvait m'aider , je le =
remercie d'avance.
Voici la formule que j'ai essayé de faire :
=SOMME(((C20-C19)-0,0138888888888889)+((D20-D19)-0,0138888888888889)+((E2=
0-E19)-0,0138888888888889)+((F20-F19)-0,0138888888888889)+((G20-G19)-0,0138=
888888888889)+((H20-H19)-0,0138888888888889)+((I20-I19)-0,0138888888888889)=
)

Merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gloops
Le #24352741
a écrit, le 27/03/2012 09:15 :
Bonjour,
Je suis débutant sur excel et j'ai besoin d'un petit coup de main si cela était possible.
Je fais un planning horaires pour la gestion des heures de mon équipe .
7 colonnes de C a I pour les jours de la semaine.
2 lignes, lignes 19 (heures arrivée) ligne 20 (heure départ)
nous travaillons sur une amplitude horaire de 07h20 et 0h20 de déduct ible ce qui ramène a 07h00.
Mon problème par rapport a ma formule, c'est que le, les jours non tr availlé (weekend) il me déduit quand même les 0h20 par jours.
Et que je mets dans la cellule RP (repos) ou CP ou ABS ou MA ect... cel a me marque #VALEUR
Je suis vraiment pas fort en formule, si quelqu'un pouvait m'aider , je le remercie d'avance.
Voici la formule que j'ai essayé de faire :
=SOMME(((C20-C19)-0,0138888888888889)+((D20-D19)-0,0138888888888889)+ ((E20-E19)-0,0138888888888889)+((F20-F19)-0,0138888888888889)+((G20-G19)- 0,0138888888888889)+((H20-H19)-0,0138888888888889)+((I20-I19)-0,013888888 8888889))

Merci d'avance



RP - 0,20, ça fait #VALEUR, c'est normal.

Il faut décider si la cellule contient du numérique ou du texte, et
réagir en conséquence. Si c'est du texte, ce n'est pas la peine d'en
retirer 0.20, à moins de vouloir obtenir le message d'erreur #VALEUR.

Il existe la fonction IsNum pour savoir si une valeur est numérique.

=Iif(IsNum(C20);C20-C19;"sans objet")

(attention je la fais vite fait de mémoire, il faut vérifier la synta xe)
verdo.v4
Le #24353031
Même si je ne soustrait pas ces 20mn, j'ai quand même le message d'erre ur.

J'ai essayé ça : =Iif(IsNum(C20);C20-C19;"sans objet")

J'ai essayé de faire des modif avec mes maigres connaissances, cela ne fo nctionne pas.
Gloops
Le #24353351
a écrit, le 27/03/2012 10:45 :

Même si je ne soustrait pas ces 20mn, j'ai quand même le message d' erreur.

J'ai essayé ça : =Iif(IsNum(C20);C20-C19;"sans objet")

J'ai essayé de faire des modif avec mes maigres connaissances, cela n e fonctionne pas.



Bon, comme j'ai un peu plus de temps je viens de tester. J'ai Excel 2007
francophone, donc la formule devient :

=SI(ESTNUM(C20);C20-20;"sans objet")

J'ai mis la réduction en dur, après on peut la mettre en C19 il ne
semble pas que ce soit le problème.

Si en C20 je mets "A" j'obtiens "sans objet".
Si en C20 je mets 50 j'obtiens 30.

ça correspond à ce qui est demandé, non ?

Le symbole fx, à gauche de la barre de formule, ouvre l'assistant
formule, qui permet de trouver les fonctions intégrées existantes.
Jacquouille
Le #24353921
Bonjour

Denis a eu un prob et ne peut répondre dans ce fil.
Sa réponse date de ce jour à 15:15 Hr et se trouve juste 2 cm plus haut
. -)))

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
a écrit dans le message de groupe de discussion :


Bonjour,
Je suis débutant sur excel et j'ai besoin d'un petit coup de main si cela
était possible.
Je fais un planning horaires pour la gestion des heures de mon équipe.
7 colonnes de C a I pour les jours de la semaine.
2 lignes, lignes 19 (heures arrivée) ligne 20 (heure départ)
nous travaillons sur une amplitude horaire de 07h20 et 0h20 de déductible ce
qui ramène a 07h00.
Mon problème par rapport a ma formule, c'est que le, les jours non travaillé
(weekend) il me déduit quand même les 0h20 par jours.
Et que je mets dans la cellule RP (repos) ou CP ou ABS ou MA ect... cela me
marque #VALEUR
Je suis vraiment pas fort en formule, si quelqu'un pouvait m'aider , je le
remercie d'avance.
Voici la formule que j'ai essayé de faire :
=SOMME(((C20-C19)-0,0138888888888889)+((D20-D19)-0,0138888888888889)+((E20-E19)-0,0138888888888889)+((F20-F19)-0,0138888888888889)+((G20-G19)-0,0138888888888889)+((H20-H19)-0,0138888888888889)+((I20-I19)-0,0138888888888889))

Merci d'avance
MichD
Le #24354141
Merci Jacquouille,

'-----------------------------------------
Bonjour,

Essaie ceci comme formule :

Cette formule requiert une validation matricielle : Ctrl + Maj + Enter
J'ai créé un "NOM" HreD et je lui ai attribué la valeur 0,0138888888888889

=SOMME(((SI(ESTNUM(C20:I20-C19:I19);(C20:I20-C19:I19)-HreD;0))))


P.S. Ce message retour sur son fil ne passe pas, si quelqu'un veut bien prendre la peine de lui transmettre la réponse.

MichD
------------------------------------------
Jacquouille
Le #24354291
Mais, mon cher Denis, c'est un réel plaisir que de te rendre service.
A côté de tous ceux que tu nous donnes, c'est pas grand chose.
Jacques.



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD" a écrit dans le message de groupe de discussion :
jksnh1$1fd$

Merci Jacquouille,

'-----------------------------------------
Bonjour,

Essaie ceci comme formule :

Cette formule requiert une validation matricielle : Ctrl + Maj + Enter
J'ai créé un "NOM" HreD et je lui ai attribué la valeur 0,0138888888888889

=SOMME(((SI(ESTNUM(C20:I20-C19:I19);(C20:I20-C19:I19)-HreD;0))))


P.S. Ce message retour sur son fil ne passe pas, si quelqu'un veut bien
prendre la peine de lui transmettre la réponse.

MichD
------------------------------------------
Publicité
Poster une réponse
Anonyme