VALEUR SI... Nbre d'arguments

Le
Soya
Re-bonjour,

Bon je sais que le sujet a déjà été traité, mais j'ai fait une recherche et
les solutions proposées dans la question de février 2005 ne répondent pas à
mon problème.

Plusieur si, avec ESTNUM, comme la proposé DRE dans ma question précédente
avec la valeur 0. Je vais avoir 13 SI dans ma formule. J'ai lu que sommeprod
pouvait faire l'affaire. Comment ? ou autre solution ?

Si vous voulez des détails, voilà : tableau de A:M

Formule :
si(estnum(a1);=Autretableau!a1;si(estnum(b1);Autretableau!a1+b1;si(estnum(c1);=Autretableau!a1+b1+c1) etc

Ainsi de suite jusqu'à la colonne M.

Avez-vous une solution à cela ? Merciiiiiii !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
AV
Le #4916221
Formule :
si(estnum(a1);=Autretableau!a1;si(estnum(b1);Autretableau!a1+b1;si(estnum(c1);=Autretableau!a1+b1+c1)
etc...


Si je comprends bien tes imbrications de SI;;;;;
Un tableau avec
* un champ (TestsLogiq) comprenant tous les test logiques (=ESTNUM(A1);
=ESTNUM(B1.etc...)
* un champ ("Valeurs") comprenant les correspondances (=AutreTableau!A1;
=SOMME(AutreTableau!A1;B1).etc.)

Une matricielle (valider par ctrl+maj+entrée)
=INDEX(Valeurs;MIN(SI(TestsLogiq=VRAI;LIGNE(TestsLogiq);""))-LIGNE(Valeurs)+1)

Il faut évidemment adapter mais, sur ce principe, ça devrait te faire
affaire

http://cjoint.com/?gnr064XAgg

AV

Soya
Le #4916121
Avé AV,

Voici un lien. Peux-tu s'il te plaît aller voir mon exemple ? Car je ne
comprends pas bien le tien. Tu verras peut-être mieux ce que je veux faire.

Merci !

http://cjoint.com/?gntqXTyrOR


Formule :
si(estnum(a1);=Autretableau!a1;si(estnum(b1);Autretableau!a1+b1;si(estnum(c1);=Autretableau!a1+b1+c1)
etc...


Si je comprends bien tes imbrications de SI;;;;;
Un tableau avec
* un champ (TestsLogiq) comprenant tous les test logiques (=ESTNUM(A1);
=ESTNUM(B1.etc...)
* un champ ("Valeurs") comprenant les correspondances (=AutreTableau!A1;
=SOMME(AutreTableau!A1;B1).etc.)

Une matricielle (valider par ctrl+maj+entrée)
=INDEX(Valeurs;MIN(SI(TestsLogiq=VRAI;LIGNE(TestsLogiq);""))-LIGNE(Valeurs)+1)

Il faut évidemment adapter mais, sur ce principe, ça devrait te faire
affaire

http://cjoint.com/?gnr064XAgg

AV






dre
Le #4915771
Bonjour,

=SOMMEPROD((ESTNUM(A3:D3)*AutreTableau!A3:D3))
renvoie 22 si A3 et B3 contiennent des valeurs numériques

Il faut que les deux plages (A3:D3) soient de même taille.

dré


Avé AV,

Voici un lien. Peux-tu s'il te plaît aller voir mon exemple ? Car je ne
comprends pas bien le tien. Tu verras peut-être mieux ce que je veux faire.

Merci !

http://cjoint.com/?gntqXTyrOR


Formule :
si(estnum(a1);=Autretableau!a1;si(estnum(b1);Autretableau!a1+b1;si(estnum(c1);=Autretableau!a1+b1+c1)
etc...


Si je comprends bien tes imbrications de SI;;;;;
Un tableau avec
* un champ (TestsLogiq) comprenant tous les test logiques (=ESTNUM(A1);
=ESTNUM(B1.etc...)
* un champ ("Valeurs") comprenant les correspondances (=AutreTableau!A1;
=SOMME(AutreTableau!A1;B1).etc.)

Une matricielle (valider par ctrl+maj+entrée)
=INDEX(Valeurs;MIN(SI(TestsLogiq=VRAI;LIGNE(TestsLogiq);""))-LIGNE(Valeurs)+1)

Il faut évidemment adapter mais, sur ce principe, ça devrait te faire
affaire

http://cjoint.com/?gnr064XAgg

AV








Soya
Le #4914861
Merci infiniment dre, c'est exactement ça ! :))))


Bonjour,

=SOMMEPROD((ESTNUM(A3:D3)*AutreTableau!A3:D3))
renvoie 22 si A3 et B3 contiennent des valeurs numériques

Il faut que les deux plages (A3:D3) soient de même taille.

dré


Avé AV,

Voici un lien. Peux-tu s'il te plaît aller voir mon exemple ? Car je ne
comprends pas bien le tien. Tu verras peut-être mieux ce que je veux faire.

Merci !

http://cjoint.com/?gntqXTyrOR


Formule :
si(estnum(a1);=Autretableau!a1;si(estnum(b1);Autretableau!a1+b1;si(estnum(c1);=Autretableau!a1+b1+c1)
etc...


Si je comprends bien tes imbrications de SI;;;;;
Un tableau avec
* un champ (TestsLogiq) comprenant tous les test logiques (=ESTNUM(A1);
=ESTNUM(B1.etc...)
* un champ ("Valeurs") comprenant les correspondances (=AutreTableau!A1;
=SOMME(AutreTableau!A1;B1).etc.)

Une matricielle (valider par ctrl+maj+entrée)
=INDEX(Valeurs;MIN(SI(TestsLogiq=VRAI;LIGNE(TestsLogiq);""))-LIGNE(Valeurs)+1)

Il faut évidemment adapter mais, sur ce principe, ça devrait te faire
affaire

http://cjoint.com/?gnr064XAgg

AV










Publicité
Poster une réponse
Anonyme