Valeurs les plus fréquentes

Le
Céline Dion
Bonsoir,

Je souhaite obtenir -par formule- la valeur ou les valeurs les plus
fréquentes d'une liste de valeurs numériques ne comprenant pas de vides

1° Exemple de données (A2:A7) :
5-10-15-20-5-25
Le résultat attendu est (B2) : 5

2° Exemple de données (A2:A9) :
10-10-20-30-25-25-5-5

Le résultat attendu est (B2:B4) :
10-25-5

Merci de votre attention
Cordialités
Céline D.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4317261
Bonsoir,

=SI(ESTNUM(INDEX(Champ;GRANDE.VALEUR(SI(FREQUENCE(Champ;Champ)=MAX(FREQ UENCE(Champ;Champ));LIGNE(INDIRECT("1:"&LIGNES(Champ)));FAUX);LIGNE(INDIREC T("1:"&LIGNES(Champ))))));
INDEX(Champ;GRANDE.VALEUR(SI(FREQUENCE(Champ;Champ)=MAX(FREQUENCE(Champ;C hamp));LIGNE(INDIRECT("1:"&LIGNES(Champ)));FAUX);LIGNE(INDIRECT("1:"&LIGNES (Champ)))));"")

http://cjoint.com/?dCwoAmiiKS

JB

On 28 mar, 18:33, "Céline Dion"
Bonsoir,

Je souhaite obtenir -par formule- la valeur ou les valeurs les plus
fréquentes d'une liste de valeurs numériques ne comprenant pas de vid es

1° Exemple de données (A2:A7) :
5-10-15-20-5-25
Le résultat attendu est (B2) : 5

2° Exemple de données (A2:A9) :
10-10-20-30-25-25-5-5

Le résultat attendu est (B2:B4) :
10-25-5

Merci de votre attention
Cordialités
Céline D.


AV
Le #4266151
2° Exemple de données (A2:A9) :
10-10-20-30-25-25-5-5
Le résultat attendu est (B2:B4) :
10-25-5


Pour obtenir le résultat que tu indiques (10-25-5) avec les données
fournies
Sélection préalable de B2:B9 > Saisie dans la barre de formule de …..

=SI(ESTNUM(PETITE.VALEUR(SI(FREQUENCE(plage;plage)=MAX(FREQUENCE(plage;plage));LIGNE(INDIRECT("$1:$"&LIGNES(plage))));LIGNE(INDIRECT("$1:$"&LIGNES(plage)))));INDEX(plage;PETITE.VALEUR(SI(FREQUENCE(plage;plage)=MAX(FREQUENCE(plage;plage));LIGNE(INDIRECT("$1:$"&LIGNES(plage))));LIGNE(INDIRECT("$1:$"&LIGNES(plage)))));"")

Validation par ctrl+maj+entrée

AV

Publicité
Poster une réponse
Anonyme