validation

Le
Jean Martin
Bonjour,

Je suis devant un programme de calcul de présences (présences effectives et
représentations par procuration) pour une assemblée générale.
En colonne C (plage "C11:C400") j'introduis un code de 4 chiffres "1xxx"
pour les présences effectives et "5xxx" pour les procurations. (Les codes
procurations sont obtenus en ajoutant 4000 aux codes présences).
Afin d'éviter les risques de doublons, j'ai opté pour le système de
validation des données personnalisé, sur la base de la formule suivante:
=NB.SI(C$11:C$400;C11)=1 avec un message d'alerte. Cela marche parfaitement.
Un risque toutefois. Si j'introduis successivement les deux codes suivants
en colonne C: "1254" et "5254" - il s'agit de la même personne, une fois
comme présente et une fois comme représentée - ces introductions sont
naturellement validées alors qu'elles ne le devraient pas. Je dois donc
trouver une formule de validation qui se base sur les trois derniers
chiffres seulement.
Puis-je encore espérer de l'aide.
Merci

Jean
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #17994661
Bonjour.
=SOMMEPROD(N(MOD(C11:C400;1000)=MOD(C11;1000)))
à recopier vers le bas.
Daniel

Bonjour,

Je suis devant un programme de calcul de présences (présences effectives et
représentations par procuration) pour une assemblée générale.
En colonne C (plage "C11:C400") j'introduis un code de 4 chiffres "1xxx" pour
les présences effectives et "5xxx" pour les procurations. (Les codes
procurations sont obtenus en ajoutant 4000 aux codes présences).
Afin d'éviter les risques de doublons, j'ai opté pour le système de
validation des données personnalisé, sur la base de la formule suivante:
=NB.SI(C$11:C$400;C11)=1 avec un message d'alerte. Cela marche parfaitement.
Un risque toutefois. Si j'introduis successivement les deux codes suivants en
colonne C: "1254" et "5254" - il s'agit de la même personne, une fois comme
présente et une fois comme représentée - ces introductions sont naturellement
validées alors qu'elles ne le devraient pas. Je dois donc trouver une formule
de validation qui se base sur les trois derniers chiffres seulement.
Puis-je encore espérer de l'aide.
Merci

Jean


Fredo P.
Le #17994991
Bonjour
Passez par une cellule intermédiaire par ex: C10 ou vous collerez cette
formule
=SI(C11>0;SOMME((DROITE(C11:C400;3)=DROITE(C11;3))*1);"") 'à valider en
matricielle ctrl+maj+enter
sur C11 créez votre cellule à validation personnalisé: Á0>2

"Jean Martin" news:
Bonjour,

Je suis devant un programme de calcul de présences (présences effectives


et
représentations par procuration) pour une assemblée générale.
En colonne C (plage "C11:C400") j'introduis un code de 4 chiffres "1xxx"
pour les présences effectives et "5xxx" pour les procurations. (Les codes
procurations sont obtenus en ajoutant 4000 aux codes présences).
Afin d'éviter les risques de doublons, j'ai opté pour le système de
validation des données personnalisé, sur la base de la formule suivante:
=NB.SI(C$11:C$400;C11)=1 avec un message d'alerte. Cela marche


parfaitement.
Un risque toutefois. Si j'introduis successivement les deux codes suivants
en colonne C: "1254" et "5254" - il s'agit de la même personne, une fois
comme présente et une fois comme représentée - ces introductions sont
naturellement validées alors qu'elles ne le devraient pas. Je dois donc
trouver une formule de validation qui se base sur les trois derniers
chiffres seulement.
Puis-je encore espérer de l'aide.
Merci

Jean




Jacky
Le #17995241
Bonjour,

Remplacer validation des données personnalisé
=NB.SI(C$11:C$400;C11)=1
par
=(NB.SI(C$11:C$400;C11))+(NB.SI(C$11:C$400;C11+4000))+(NB.SI(C$11:C$400;C11-4000))=1

--
Salutations
JJ


"Jean Martin"
Bonjour,

Je suis devant un programme de calcul de présences (présences effectives
et représentations par procuration) pour une assemblée générale.
En colonne C (plage "C11:C400") j'introduis un code de 4 chiffres "1xxx"
pour les présences effectives et "5xxx" pour les procurations. (Les codes
procurations sont obtenus en ajoutant 4000 aux codes présences).
Afin d'éviter les risques de doublons, j'ai opté pour le système de
validation des données personnalisé, sur la base de la formule suivante:
=NB.SI(C$11:C$400;C11)=1 avec un message d'alerte. Cela marche
parfaitement. Un risque toutefois. Si j'introduis successivement les deux
codes suivants en colonne C: "1254" et "5254" - il s'agit de la même
personne, une fois comme présente et une fois comme représentée - ces
introductions sont naturellement validées alors qu'elles ne le devraient
pas. Je dois donc trouver une formule de validation qui se base sur les
trois derniers chiffres seulement.
Puis-je encore espérer de l'aide.
Merci

Jean



Fredo P.
Le #17998631
Oups!!!sur C11 créez votre cellule à validation personnalisé: Á0<2
et non pas
sur C11 créez votre cellule à validation personnalisé: Á0>2


Jean Martin
Le #18000421
Merci! J'obtiens réellement le srésultats voulus!

Jean
"Jacky"
Bonjour,

Remplacer validation des données personnalisé
=NB.SI(C$11:C$400;C11)=1
par
=(NB.SI(C$11:C$400;C11))+(NB.SI(C$11:C$400;C11+4000))+(NB.SI(C$11:C$400;C11-4000))=1

--
Salutations
JJ


"Jean Martin" news:
Bonjour,

Je suis devant un programme de calcul de présences (présences effectives
et représentations par procuration) pour une assemblée générale.
En colonne C (plage "C11:C400") j'introduis un code de 4 chiffres "1xxx"
pour les présences effectives et "5xxx" pour les procurations. (Les codes
procurations sont obtenus en ajoutant 4000 aux codes présences).
Afin d'éviter les risques de doublons, j'ai opté pour le système de
validation des données personnalisé, sur la base de la formule suivante:
=NB.SI(C$11:C$400;C11)=1 avec un message d'alerte. Cela marche
parfaitement. Un risque toutefois. Si j'introduis successivement les deux
codes suivants en colonne C: "1254" et "5254" - il s'agit de la même
personne, une fois comme présente et une fois comme représentée - ces
introductions sont naturellement validées alors qu'elles ne le devraient
pas. Je dois donc trouver une formule de validation qui se base sur les
trois derniers chiffres seulement.
Puis-je encore espérer de l'aide.
Merci

Jean







Jean Martin
Le #18000511
Merci pour la proposition. Mais je ne la comprends pas! La colonne C doit
être libre pour introcution des codes...
De plus, Jacky m'a donné une réponse qui me convient très bien!

Jean

"Daniel.C"
Bonjour.
=SOMMEPROD(N(MOD(C11:C400;1000)=MOD(C11;1000)))
à recopier vers le bas.
Daniel

Bonjour,

Je suis devant un programme de calcul de présences (présences effectives
et représentations par procuration) pour une assemblée générale.
En colonne C (plage "C11:C400") j'introduis un code de 4 chiffres "1xxx"
pour les présences effectives et "5xxx" pour les procurations. (Les codes
procurations sont obtenus en ajoutant 4000 aux codes présences).
Afin d'éviter les risques de doublons, j'ai opté pour le système de
validation des données personnalisé, sur la base de la formule suivante:
=NB.SI(C$11:C$400;C11)=1 avec un message d'alerte. Cela marche
parfaitement. Un risque toutefois. Si j'introduis successivement les deux
codes suivants en colonne C: "1254" et "5254" - il s'agit de la même
personne, une fois comme présente et une fois comme représentée - ces
introductions sont naturellement validées alors qu'elles ne le devraient
pas. Je dois donc trouver une formule de validation qui se base sur les
trois derniers chiffres seulement.
Puis-je encore espérer de l'aide.
Merci

Jean






Jean Martin
Le #18000681
Merci pour les efforts consécutifs. J'ai essayé, mais quelque chose
m'échappe et de plus Jacky m'a donné une réponse que je comprends
parfaitement et qui répond à ma question.

Merci
Jean


"Fredo P." news:
Oups!!!sur C11 créez votre cellule à validation personnalisé: Á0<2
et non pas
sur C11 créez votre cellule à validation personnalisé: Á0>2






Daniel.C
Le #18001961
Bonjour.
Oublie "recopier vers le bas"; utilise :
=SOMMEPROD(N(MOD(C11:C400;1000)=MOD(C11;1000)))=1
Daniel

Bonjour.
=SOMMEPROD(N(MOD(C11:C400;1000)=MOD(C11;1000)))
à recopier vers le bas.
Daniel

Bonjour,

Je suis devant un programme de calcul de présences (présences effectives et
représentations par procuration) pour une assemblée générale.
En colonne C (plage "C11:C400") j'introduis un code de 4 chiffres "1xxx"
pour les présences effectives et "5xxx" pour les procurations. (Les codes
procurations sont obtenus en ajoutant 4000 aux codes présences).
Afin d'éviter les risques de doublons, j'ai opté pour le système de
validation des données personnalisé, sur la base de la formule suivante:
=NB.SI(C$11:C$400;C11)=1 avec un message d'alerte. Cela marche
parfaitement. Un risque toutefois. Si j'introduis successivement les deux
codes suivants en colonne C: "1254" et "5254" - il s'agit de la même
personne, une fois comme présente et une fois comme représentée - ces
introductions sont naturellement validées alors qu'elles ne le devraient
pas. Je dois donc trouver une formule de validation qui se base sur les
trois derniers chiffres seulement.
Puis-je encore espérer de l'aide.
Merci

Jean




Jean Martin
Le #18005851
Bonjour,

Merci pour la correction! Par acquis de conscience j'ai mis cette formule de
validation à l'essai. J'ai toutefois dû rendre absolue la plage C11:C400
dans le premier MOD!
Et la formule marche, à un détail près: les codes 1000 et 5000 sont
refusés.
Une question: que signifie le N dans la formule?

Jean

"Daniel.C"
Bonjour.
Oublie "recopier vers le bas"; utilise :
=SOMMEPROD(N(MOD(C11:C400;1000)=MOD(C11;1000)))=1


j'ai mis: =SOMMEPROD(N(MOD(C$11:C$400;1000)=MOD(C11;1000)))=1
Daniel.C
Le #18006211
Regarde le classeur à l'adresse :
http://www.cijoint.fr/cjlink.php?file=cj200811/cijLEyZSI8.xls
La cellule contrôlée par validation est : E10.
La fonction N transforme les valeurs booléennes VRAI en 1 et FAUX en 0.
Ce qui permet de les additionner.
Daniel

Bonjour,

Merci pour la correction! Par acquis de conscience j'ai mis cette formule de
validation à l'essai. J'ai toutefois dû rendre absolue la plage C11:C400 dans
le premier MOD!
Et la formule marche, à un détail près: les codes 1000 et 5000 sont refusés.
Une question: que signifie le N dans la formule?

Jean

"Daniel.C"
Bonjour.
Oublie "recopier vers le bas"; utilise :
=SOMMEPROD(N(MOD(C11:C400;1000)=MOD(C11;1000)))=1


j'ai mis: =SOMMEPROD(N(MOD(C$11:C$400;1000)=MOD(C11;1000)))=1


Publicité
Poster une réponse
Anonyme