Validation sur résultat de formule

Le
Lou
Bonjour,

Est-ce possible d'appliquer une validation sur un résultat de formule?
J'aimerais avoir un message qui s'affiche lorsque le résultat d'une formule
est plus grand que 2 par exemple.

Est-ce que quelqu'un aurais une solution à mon problème?

Merci à l'avance pour votre aide!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FdeCourt
Le #20964811
Salut,

Je ne sais pas si tu peux afficher un msgbox directement à partir
d'une formule (je ne crois vraiment pas).

Par contre, avec une petite formule en VBA :

Function msg()
Application.Volatile
MsgBox "DDD"
msg = ""
End Function

Que tu peux appeler ainsi dans Excel :

=SI(C5>3;msg(); "")

Par contre, si la formule est utilisée plusieurs fois, alors il y a
aura autant de msgbox que de fois ou la formule se vérifie.

Cordialement,

F.
Tatanka
Le #20965241
Bonjour Lou,

Peut-être ceci (un exemple) :

1) Je suppose ta formule en F4,
2) Sélectionne toutes les cellules utilisées par ta formule
et donne un nom à la plage sélectionnée (PourFormule),
3) Fais un clic droit sur l'onglet contenant ta formule,
4) Clique sur « Visualiser le code » et colle cette macro dans
la feuille vierge qui devrait apparaître :

Private Sub Worksheet_Change(ByVal Target As Range)
Set inter = Intersect(Target, Range("PourFormule"))
If Not inter Is Nothing And Target.Count = 1 Then
If Range("F4").Value > 2 Then
MsgBox "La formule en F4 donne un résultat supérieur à 2."
End If
End If
End Sub

Serge




"Lou"
Bonjour,

Est-ce possible d'appliquer une validation sur un résultat de formule?
J'aimerais avoir un message qui s'affiche lorsque le résultat d'une
formule
est plus grand que 2 par exemple.

Est-ce que quelqu'un aurais une solution à mon problème?

Merci à l'avance pour votre aide!


Tatanka
Le #20965371
... Alors si tu modifies une valeur d'une cellule utilisée
par ta formule, le message apparaîtra si la formule
donne un résultat plus grand que 2.

Serge

"Tatanka"
Bonjour Lou,

Peut-être ceci (un exemple) :

1) Je suppose ta formule en F4,
2) Sélectionne toutes les cellules utilisées par ta formule
et donne un nom à la plage sélectionnée (PourFormule),
3) Fais un clic droit sur l'onglet contenant ta formule,
4) Clique sur « Visualiser le code » et colle cette macro dans
la feuille vierge qui devrait apparaître :

Private Sub Worksheet_Change(ByVal Target As Range)
Set inter = Intersect(Target, Range("PourFormule"))
If Not inter Is Nothing And Target.Count = 1 Then
If Range("F4").Value > 2 Then
MsgBox "La formule en F4 donne un résultat supérieur à 2."
End If
End If
End Sub

Serge




"Lou"
Bonjour,

Est-ce possible d'appliquer une validation sur un résultat de formule?
J'aimerais avoir un message qui s'affiche lorsque le résultat d'une
formule
est plus grand que 2 par exemple.

Est-ce que quelqu'un aurais une solution à mon problème?

Merci à l'avance pour votre aide!






Tatanka
Le #20965441
Pour utiliser ce truc, il faut que ta formule et les cellules
qu'elle utilise soient sur la même feuille. Est-ce le cas ?

Serge

"Tatanka"
... Alors si tu modifies une valeur d'une cellule utilisée
par ta formule, le message apparaîtra si la formule
donne un résultat plus grand que 2.

Serge

"Tatanka"
Bonjour Lou,

Peut-être ceci (un exemple) :

1) Je suppose ta formule en F4,
2) Sélectionne toutes les cellules utilisées par ta formule
et donne un nom à la plage sélectionnée (PourFormule),
3) Fais un clic droit sur l'onglet contenant ta formule,
4) Clique sur « Visualiser le code » et colle cette macro dans
la feuille vierge qui devrait apparaître :

Private Sub Worksheet_Change(ByVal Target As Range)
Set inter = Intersect(Target, Range("PourFormule"))
If Not inter Is Nothing And Target.Count = 1 Then
If Range("F4").Value > 2 Then
MsgBox "La formule en F4 donne un résultat supérieur à 2."
End If
End If
End Sub

Serge




"Lou"
Bonjour,

Est-ce possible d'appliquer une validation sur un résultat de formule?
J'aimerais avoir un message qui s'affiche lorsque le résultat d'une
formule
est plus grand que 2 par exemple.

Est-ce que quelqu'un aurais une solution à mon problème?

Merci à l'avance pour votre aide!










Lou
Le #20979271
Bonjour,

J'aime beaucoup ton idée mais j'ai essayé et ça n'a pas fonctionné. Je
travail avec Excel 2007 est-ce que ça pourrait être la raison pour laquelle
ça ne fonctionne pas?

Merci

"FdeCourt" a écrit :

Salut,

Je ne sais pas si tu peux afficher un msgbox directement à partir
d'une formule (je ne crois vraiment pas).

Par contre, avec une petite formule en VBA :

Function msg()
Application.Volatile
MsgBox "DDD"
msg = ""
End Function

Que tu peux appeler ainsi dans Excel :

=SI(C5>3;msg(); "")

Par contre, si la formule est utilisée plusieurs fois, alors il y a
aura autant de msgbox que de fois ou la formule se vérifie.

Cordialement,

F.
.



FdeCourt
Le #20979601
Salut,

Essaye avec le classeur ci-joint :
http://cjoint.com/?bpphgqo87T

Que se passe t-il ?

Cordialement,

F.
Publicité
Poster une réponse
Anonyme