VBA créer une formule SOMMEPROD utilisant une variable

Le
Céline Brien
Bonjour à tous,
Une variable x égale au nombre de cellules de la colonne B.
La création d'une formule en D2 utilisant la variable x.
Finalement la copie de la formule de D2 à Dx
J'obtiens un message d'erreur sur la formule : erreur de syntaxe.
La formule en Excel est :
=SI(B2<>B1;SOMMEPROD((B2:B87²)*C2:C87);"")
La formule en VBA voir les codes ci-dessous.
Pouvez-vous m'aider ??
Merci beaucoup,
Céline
-
x = [b65536].End(3).Row
Range("D2").Select
Range("D2").Formula = "=IF(B2<>B1,SUMPROD(("B2:B" & x ²)*"C2:C" & x),"")"
Selection.AutoFill Destination:=Range("D2:D" & x)
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #4313361
Dim V As Long
V = 5
Range("D2").Formula = "=IF(B2<>B1,SUMPROD((B2:B" & V & "²)*(C2:C" & V & ")),"""")"



"Céline Brien"
Bonjour à tous,
Une variable x égale au nombre de cellules de la colonne B.
La création d'une formule en D2 utilisant la variable x.
Finalement la copie de la formule de D2 à Dx
J'obtiens un message d'erreur sur la formule : erreur de syntaxe.
La formule en Excel est :
=SI(B2<>B1;SOMMEPROD((B2:B87²)*C2:C87);"")
La formule en VBA voir les codes ci-dessous.
Pouvez-vous m'aider ??
Merci beaucoup,
Céline
----------------------------------
x = [b65536].End(3).Row
Range("D2").Select
Range("D2").Formula = "=IF(B2<>B1,SUMPROD(("B2:B" & x ²)*"C2:C" & x),"")"
Selection.AutoFill Destination:=Range("D2:D" & x)
Céline Brien
Le #4313241
Bonjour à tous,
Bonjour Mich,
Merci pour ta réponse.
Pourquoi V = 5 ?
Je crois que je vais garder mes codes actuels.
La formule est en D2.
=SI(B2<>B1;SOMMEPROD((B2:$B$500²)*C2:$C$500);"")
J'espère seulement quelle ne sera pas effacée par erreur et qu'il n'y aura
pas plus de 500 lignes.
x = [b65536].End(3).Row
Range("d2").Select
Selection.AutoFill Destination:=Range("d2:d" & x)
Merci encore,
Céline


"MichDenis"
Dim V As Long
V = 5
Range("D2").Formula = "=IF(B2<>B1,SUMPROD((B2:B" & V & "²)*(C2:C" & V &
")),"""")"



"Céline Brien" news:

Bonjour à tous,
Une variable x égale au nombre de cellules de la colonne B.
La création d'une formule en D2 utilisant la variable x.
Finalement la copie de la formule de D2 à Dx
J'obtiens un message d'erreur sur la formule : erreur de syntaxe.
La formule en Excel est :
=SI(B2<>B1;SOMMEPROD((B2:B87²)*C2:C87);"")
La formule en VBA voir les codes ci-dessous.
Pouvez-vous m'aider ??
Merci beaucoup,
Céline
----------------------------------
x = [b65536].End(3).Row
Range("D2").Select
Range("D2").Formula = "=IF(B2<>B1,SUMPROD(("B2:B" & x ²)*"C2:C" &
x),"")"
Selection.AutoFill Destination:=Range("D2:D" & x)





MichDenis
Le #4313231
| Pourquoi V = 5 ?

Je n'avais pas "vu" x = [b65536].End(3).Row

Tu n'as qu'à remplacer V par x



"Céline Brien"
Bonjour à tous,
Bonjour Mich,
Merci pour ta réponse.
Pourquoi V = 5 ?
Je crois que je vais garder mes codes actuels.
La formule est en D2.
=SI(B2<>B1;SOMMEPROD((B2:$B$500²)*C2:$C$500);"")
J'espère seulement quelle ne sera pas effacée par erreur et qu'il n'y aura
pas plus de 500 lignes.
x = [b65536].End(3).Row
Range("d2").Select
Selection.AutoFill Destination:=Range("d2:d" & x)
Merci encore,
Céline


"MichDenis"
Dim V As Long
V = 5
Range("D2").Formula = "=IF(B2<>B1,SUMPROD((B2:B" & V & "²)*(C2:C" & V &
")),"""")"



"Céline Brien" news:

Bonjour à tous,
Une variable x égale au nombre de cellules de la colonne B.
La création d'une formule en D2 utilisant la variable x.
Finalement la copie de la formule de D2 à Dx
J'obtiens un message d'erreur sur la formule : erreur de syntaxe.
La formule en Excel est :
=SI(B2<>B1;SOMMEPROD((B2:B87²)*C2:C87);"")
La formule en VBA voir les codes ci-dessous.
Pouvez-vous m'aider ??
Merci beaucoup,
Céline
----------------------------------
x = [b65536].End(3).Row
Range("D2").Select
Range("D2").Formula = "=IF(B2<>B1,SUMPROD(("B2:B" & x ²)*"C2:C" &
x),"")"
Selection.AutoFill Destination:=Range("D2:D" & x)





Publicité
Poster une réponse
Anonyme