[VBA] Problème avec la préparation d'envoi d'un mail

Le
HD
Bonjour,

J'ai un petit script qui me permettait d'envoyer un mail en cliquant sur un
bouton. Il fonctionnait à merveille sur mon poste XP avec Excel 2007 et
m'ouvrait un mail avec ma messagerie par défaut Outlook Express
seulement, avec Windows 7 et Excel 2010 lorsque je le lance, alors qu'il
devrait ouvrir la messagerie par défaut (windows messenger) il m'ouvrir une
boite de dialogue me demandant de sélectionner un fichier Voici mon
script :

Sub Mail()
Dim MailAd As String
Dim URLto As String
Dim Subject As String
Dim body As String

URLto = "mailto:monadresse@gmail.fr?subject=Contrôle des codes"
ActiveWorkbook.FollowHyperlink Address:=URLto
DoEvents
End Sub

Ce script doit ouvrir un mail avec mon adresse en destinataire (ici
monadresse@gmail.fr) et un sujet (ici "Contrôle des codes").

La fonction FollowHyperlink fonctionne-t-elle différemment dans les nouveaux
environnements ? Comment résoudre ce problème ?

Merci d'avance pour votre aide,

Cordialement,
HD
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #25002142
bonjour HD,

ton code fonctionne très bien sur mon poste (win7 ,office 2010)
peutetre qu'un restart de l'ordi pourrais régler le probleme

--
isabelle


Le 2012-11-28 10:55, HD a écrit :
Bonjour,

J'ai un petit script qui me permettait d'envoyer un mail en cliquant sur un
bouton. Il fonctionnait à merveille sur mon poste XP avec Excel 2007 et
m'ouvrait un mail avec ma messagerie par défaut Outlook Express...
seulement, avec Windows 7 et Excel 2010 lorsque je le lance, alors qu'il
devrait ouvrir la messagerie par défaut (windows messenger) il m'ouvrir une
boite de dialogue me demandant de sélectionner un fichier... Voici mon
script :

Sub Mail()
Dim MailAd As String
Dim URLto As String
Dim Subject As String
Dim body As String

URLto = "mailto:?subject=Contrôle des codes"
ActiveWorkbook.FollowHyperlink Address:=URLto
DoEvents
End Sub

Ce script doit ouvrir un mail avec mon adresse en destinataire (ici
) et un sujet (ici "Contrôle des codes").

La fonction FollowHyperlink fonctionne-t-elle différemment dans les nouveaux
environnements ? Comment résoudre ce problème ?

Merci d'avance pour votre aide,

Cordialement,
HD


HD
Le #25002782
ton code fonctionne très bien sur mon poste (win7 ,office 2010)
peutetre qu'un restart de l'ordi pourrais régler le probleme



Le redémarrage sur le poste n'a rien changé. J'ai testé avec un autre poste
qui est en Windows 7 avec Office 2010 et le problème se pose également...
Peut être y'a-t-il un scénario particulier à ce bug ? Je vais essayé de
creuser... parmi les particularités le classeur est enregistré au format
Excel 97-2003. Je n'ai aucun souci avec Excel 2007 et les versions
antérieures.

@+
HD
MichD
Le #25003082
Bonjour,

Je n'ai aucun problème avec ce code : Office 2010 et Windows 7
J'utilise "Windows Live Mail", et la fenêtre du message s'ouvre
correctement.


MichD
---------------------------------------------------------------
Publicité
Poster une réponse
Anonyme