VBa Tableau matricielles

Le
PST
Bonjour

ces deux formules me donnent 1 si les quatres conditions sont réunies


=SOMME((O11:O17=O18)*(P11:P17=P18)*(Q11:Q17=Q18)*(R11:R17=R18))=


=SOMMEPROD((O11:O17=O18)*(P11:P17=P18)*(Q11:Q17=Q18)*(R11:R17=R=
18))

Comment faire pour que les plages soient remplacées par des tableaux qu=
i
sont mémoire, aucune référence sur la feuille, si la condition est =

remplie alors seulement le résulat est inscrit sur la feuille.

juste besoin de la syntaxe pour remplacer les plages par les tableaux si =

possible

O11:O17 par Myarray_1
p11:p17 par Myarray_2
q11:q17 par Myarray_3
r11:r17 par Myarray_4

merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4802841
Bonjour,

Sub essai()
a = [O11:R17]
For lig = 1 To UBound(a, 1)
If a(lig, 1) = [O18] And a(lig, 2) = [P18] And a(lig, 3) = [Q18]
_
And a(lig, 4) = [R18] Then n = n + 1
Next lig
MsgBox n
End Sub

Sub essai2()
Set a = [O11:O17]
Set b = [p11:p17]
Set c = [q11:q17]
Set d = [r11:r17]
For lig = 1 To 7
If a(lig) = [O18] And b(lig) = [P18] And c(lig) = [Q18] _
And d(lig) = [R18] Then n = n + 1
Next lig
MsgBox n
End Sub

JB


On 20 août, 07:15, PST
Bonjour

ces deux formules me donnent 1 si les quatres conditions sont réunies

=SOMME((O11:O17=O18)*(P11:P17=P18)*(Q11:Q17=Q18)*(R11:R17=R18))

=SOMMEPROD((O11:O17=O18)*(P11:P17=P18)*(Q11:Q17=Q18)*(R11:R17=R 18))

Comment faire pour que les plages soient remplacées par des tableaux qui
sont mémoire, aucune référence sur la feuille, si la condition est
remplie alors seulement le résulat est inscrit sur la feuille.

juste besoin de la syntaxe pour remplacer les plages par les tableaux si
possible

O11:O17 par Myarray_1
p11:p17 par Myarray_2
q11:q17 par Myarray_3
r11:r17 par Myarray_4

merci


Fredo P.
Le #4802831
Si je comprenet-is-clear
Nomme les plages: ex: plg1,plg2,plg3,plg4
Est ce cela, la rep à ta question?
=SOMME((plg1=O18)*(plg2=P18)*(plg3=Q18)*(plg4=R18))
"PST" 46c90553$0$27393$
Bonjour

ces deux formules me donnent 1 si les quatres conditions sont réunies


=SOMME((O11:O17=O18)*(P11:P17=P18)*(Q11:Q17=Q18)*(R11:R17=R18))

=SOMMEPROD((O11:O17=O18)*(P11:P17=P18)*(Q11:Q17=Q18)*(R11:R17=R18))

Comment faire pour que les plages soient remplacées par des tableaux qui
sont mémoire, aucune référence sur la feuille, si la condition est
remplie alors seulement le résulat est inscrit sur la feuille.

juste besoin de la syntaxe pour remplacer les plages par les tableaux si
possible

O11:O17 par Myarray_1
p11:p17 par Myarray_2
q11:q17 par Myarray_3
r11:r17 par Myarray_4

merci
PST
Le #4802631
je ce je voulais savoir c'est si c'était possible de faire passer une
matricielle sur un tableau avec formula.array ou quelque chose de ce
genre, juste la syntaxe.

=SOMME((MyArray_1>= 2)*(MyArray_1<))

MyArray_1 n'a pas de référence sur la feuille et reste en mémoire

pour savoir dans mon tableau qui est inclu dans une boucle et dont le
contenu change à chaque fois, combien de chiffre sont compris dans une
certaine fourchette.


merci


Si je comprenet-is-clear
Nomme les plages: ex: plg1,plg2,plg3,plg4
Est ce cela, la rep à ta question?
=SOMME((plg1=O18)*(plg2=P18)*(plg3=Q18)*(plg4=R18))
"PST" 46c90553$0$27393$
Bonjour

ces deux formules me donnent 1 si les quatres conditions sont réunies


=SOMME((O11:O17=O18)*(P11:P17=P18)*(Q11:Q17=Q18)*(R11:R17=R18 ))

=SOMMEPROD((O11:O17=O18)*(P11:P17=P18)*(Q11:Q17=Q18)*(R11:R17= R18))

Comment faire pour que les plages soient remplacées par des tableaux qui
sont mémoire, aucune référence sur la feuille, si la condition es t
remplie alors seulement le résulat est inscrit sur la feuille.

juste besoin de la syntaxe pour remplacer les plages par les tableaux s i
possible

O11:O17 par Myarray_1
p11:p17 par Myarray_2
q11:q17 par Myarray_3
r11:r17 par Myarray_4

merci




Publicité
Poster une réponse
Anonyme