[VBA] Tableau - Transfert de données dans feuille

Le
Péhemme
Bonjour à Tous,

Avec W7 - Excel 2010, je m'entraine à maitriser les tableaux
Pour le moment, ce sont eux qui font ce qu'ils veulent, mais je m'accroche
(enfin, j'essaye).
D'où ma question :
Pour quelle raison lorsque j'écris :
Range(Cells(10, 12), Cells(10 + UBound(MonTblo), 12)).Value =
WorksheetFunction.Transpose(MonTblo)
la première ligne renseignée est "L11" et non pas "L10" comme je pense
l'avoir écrit avec Cells(10,12) ?

Merci d'avance de votre aide
Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #26353370
bonjour Michel,

vérifie la valeur de MonTblo(0)
cette valeur est peut être égal à ""

isabelle

Le 2015-05-18 11:08, Péhemme a écrit :
Bonjour à Tous,

Avec W7 - Excel 2010, je m'entraine à maitriser les tableaux...
Pour le moment, ce sont eux qui font ce qu'ils veulent, mais je m'accroche
(enfin, j'essaye).
D'où ma question :
Pour quelle raison lorsque j'écris :
Range(Cells(10, 12), Cells(10 + UBound(MonTblo), 12)).Value > WorksheetFunction.Transpose(MonTblo)
la première ligne renseignée est "L11" et non pas "L10" comme je pense l'avoir
écrit avec Cells(10,12) ?

Merci d'avance de votre aide
Michel

Péhemme
Le #26353372
Bonjour Isabelle,
Vi, vi, vi !
Je présentais que c'était un problème d'indice.
En mettant : Option Base 1
Je n'ai effectivement plus ce problème.
Merci de ton aide.
Bien amicalement
Michel

"isabelle" a écrit dans le message de groupe de discussion :
mjd17t$on8$

bonjour Michel,

vérifie la valeur de MonTblo(0)
cette valeur est peut être égal à ""

isabelle

Le 2015-05-18 11:08, Péhemme a écrit :
Bonjour à Tous,

Avec W7 - Excel 2010, je m'entraine à maitriser les tableaux...
Pour le moment, ce sont eux qui font ce qu'ils veulent, mais je m'accroche
(enfin, j'essaye).
D'où ma question :
Pour quelle raison lorsque j'écris :
Range(Cells(10, 12), Cells(10 + UBound(MonTblo), 12)).Value > WorksheetFunction.Transpose(MonTblo)
la première ligne renseignée est "L11" et non pas "L10" comme je pense
l'avoir
écrit avec Cells(10,12) ?

Merci d'avance de votre aide
Michel

Publicité
Poster une réponse
Anonyme