Version stable et sysv-rc-bootsplash

Le
Alexandre
Bonjour,

je suis en stable et je souhaite installer sysv-rc-bootsplash qui est dans les dépôts instables.

Cependant, les dépendances suivantes me sont demandées:

--
#aptitude install sysv-rc-bootsplash
Les NOUVEAUX paquets suivants vont être installés :
sysv-rc-bootsplash
Les paquets suivants seront mis à jour :
bootsplash libfreetype6 zlib1g
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
grub grub-efi grub-pc
4 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 988 non mis à jour.
Il est nécessaire de télécharger 4917ko d'archives. Après dépaquetage, 385ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
libc6-i686: Pré-Dépend: libc6 (= 2.3.6.ds1-13etch2) mais 2.6.1-1+b1 doit être installé.
locales: Dépend: glibc-2.3.6.ds1-1 qui est un paquet virtuel
libc6-dev: Dépend: libc6 (= 2.3.6.ds1-13etch2) mais 2.6.1-1+b1 doit être installé.
libc6: Est en conflit avec: tzdata (< 2007e-2) mais 2007d-1 est installé et a été conservé
Resolving dependencies
Les actions suivantes permettront de résoudre ces dépendances :

Supprimer les paquets suivants :
linux-kernel-headers

Installer les paquets suivants :
linux-libc-dev [2.6.22-4 (unstable)]

Mettre à jour les paquets suivants :
binutils [2.17-3 (stable, now) -> 2.18-1 (unstable)]
libc6-dev [2.3.6.ds1-13etch2 (stable, now) -> 2.6.1-1+b1 (unstable)]
libc6-i686 [2.3.6.ds1-13etch2 (stable, now) -> 2.6.1-1+b1 (unstable)]
locales [2.3.6.ds1-13etch2 (stable, now) -> 2.6.1-2 (unstable)]
tzdata [2007d-1 (now) -> 2007g-1 (unstable)]

Le score est de -500

Accepter cette solution ? [Y/n/q/?] q
--
Les tutos sur le net disent que l'installation ne pose pas de pb.

Mais j'ai lu sur la liste qu'il était déconseillé d'installer des paquets unstable sur une version stable car les versions de libc ne sont pas les mêmes.

Donc avez vous une méthode pour installer proprement ce paquet?

En vous remerciant de votre aide.

--
()()()-()()()-()()()--)()()(-)()()(-)()()(
-()-()--()-()--()-()--)(-)(--)(-)(--)(-)(-
()-()-()()()-()()()-)()()(-)()()(-)(-)(


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Hugues LARRIVE
Le #9597251
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig1C1612E4F259B2C8C2260B8C
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Alexandre a écrit :
Bonjour,

je suis en stable et je souhaite installer sysv-rc-bootsplash qui est d ans les dépôts instables.

Cependant, les dépendances suivantes me sont demandées:

----------------------------------------------------------------------- ------------------------
#aptitude install sysv-rc-bootsplash
Les NOUVEAUX paquets suivants vont être installés :
sysv-rc-bootsplash
Les paquets suivants seront mis à jour :
bootsplash libfreetype6 zlib1g
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
grub grub-efi grub-pc
4 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 98 8 non mis à jour.
Il est nécessaire de télécharger 4917ko d'archives. Après dép aquetage, 385ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
libc6-i686: Pré-Dépend: libc6 (= 2.3.6.ds1-13etch2) mais 2.6.1- 1+b1 doit être installé.
locales: Dépend: glibc-2.3.6.ds1-1 qui est un paquet virtuel
libc6-dev: Dépend: libc6 (= 2.3.6.ds1-13etch2) mais 2.6.1-1+b1 do it être installé.
libc6: Est en conflit avec: tzdata (< 2007e-2) mais 2007d-1 est insta llé et a été conservé
Resolving dependencies...
Les actions suivantes permettront de résoudre ces dépendances :

Supprimer les paquets suivants :
linux-kernel-headers

Installer les paquets suivants :
linux-libc-dev [2.6.22-4 (unstable)]

Mettre à jour les paquets suivants :
binutils [2.17-3 (stable, now) -> 2.18-1 (unstable)]
libc6-dev [2.3.6.ds1-13etch2 (stable, now) -> 2.6.1-1+b1 (unstable)]
libc6-i686 [2.3.6.ds1-13etch2 (stable, now) -> 2.6.1-1+b1 (unstable)]
locales [2.3.6.ds1-13etch2 (stable, now) -> 2.6.1-2 (unstable)]
tzdata [2007d-1 (now) -> 2007g-1 (unstable)]

Le score est de -500

Accepter cette solution ? [Y/n/q/?] q
----------------------------------------------------------------------- ------------------------
Les tutos sur le net disent que l'installation ne pose pas de pb.

Mais j'ai lu sur la liste qu'il était déconseillé d'installer des paquets unstable sur une version stable car les versions de libc ne sont pas les mêmes.

Donc avez vous une méthode pour installer proprement ce paquet?



apt-get install bootsplash-theme-debian
apt-get source bootsplash -t unstable
apt-get build-dep bootsplash
cd bootspash-3.3/
dpkg-buildpackage
cd ..
dpkg -i
dpkg -i bootsplash_3.3-8_i386.deb
apt-get source sysv-rc-bootsplash
apt-get build-dep sysv-rc-bootsplash
cd sysv-rc-bootsplash-1.0.5/
dpkg-buildpackage
cd ..
dpkg -i dpkg -i sysv-rc-bootsplash_1.0.5-4_all.deb
En vous remerciant de votre aide.







--------------enig1C1612E4F259B2C8C2260B8C
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFG3SfbNdTZuHWpgVIRAu09AJ925DZRj6s1onBc+8+88/zeZNDj3gCdHb7N
0J/Nk5AS4K+QwZnlgDWwBHs =EVTa
-----END PGP SIGNATURE-----

--------------enig1C1612E4F259B2C8C2260B8C--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Alexandre
Le #9597161
Le 04/09 de l'année 2007, vers 11 heures et 39 minutes, Hugues LARRIVE écrivait:
apt-get install bootsplash-theme-debian
apt-get source bootsplash -t unstable
apt-get build-dep bootsplash
cd bootspash-3.3/
dpkg-buildpackage
cd ..
dpkg -i bootsplash_3.3-8_i386.deb
apt-get source sysv-rc-bootsplash
apt-get build-dep sysv-rc-bootsplash
cd sysv-rc-bootsplash-1.0.5/
dpkg-buildpackage
cd ..
dpkg -i dpkg -i sysv-rc-bootsplash_1.0.5-4_all.deb



Cela fonctionne parfaitement, je note la méthode.

En plus, la bonne version de bootsplash est choisie...

merci :)


--
---()()()----()()()----()()()--)()()(----)()()(----)()()(---
-()----()--()-()-----()----()--)(----)(-----)(-)(--)(----)(-
()----()----()()()----()()()----)()()(----)()()(----)(----)(


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme