Vieux toshiba et restart foireux

Le
Hugolino
[X-post: fcolc,fcsp - fu2: fcolc]

Salut,

J'ai un vieux Toshiba Satellite S1800-514 sur lequel tourne une Debian
Lenny. Je crois que la machine date de septembre 2002.

Le problème de ce portable est qu'il ne redémarre pas avec la commande
'shutdown -r now' (très chiant quand on ne s'en rappelle plus et qu'on
tape cette commande par ssh).

Il y a aussi un Windows XP SP2 sur le disque de ce portable, et avec
Windows, pas de problème, le portable s'éteint ou redémarre
correctement (au moment du redémarrage, le témoin s'éteint une petite
seconde, puis se rallume).

Sous Debian Lenny, le portable s'éteint correctement, par contre, la
commande 'shutdown -r now' si elle fait son boulot correctement (arrêt
des services, démontage correct des partitions, etc) laisse le portable
dans un état "bloqué":
* Les deux derniers messages affichés sont:
- Will now restart
- Restarting system
* l'écran s'éteint mais le témoin de mise sous tension reste allumé.
* si on presse brièvement le bouton de mise sous tension, le portable
ne réagit pas.
* il faut presser presser le bouton de mise sous tension pendant
plusieurs secondes (il y a alors 4 bips) pour *éteindre* le portable,
puis on peut enfin redémarrer la machine en pressant à nouveau ce
bouton.

J'ai fait un tour dans le BIOS qui affiche fièrement "ACPI BIOS version
1.0" (mais puisque je n'y ai pas vu de mention d'un constructeur de BIOS,
j'imagine qu'il a été fait par Toshiba).

Je soupçonne fortement un problème d'ACPI, du à l'age vénérable de la
machine.

J'ai fouillé les archives et j'ai trouvé quelques pistes à explorer,
mais comme ça concernait les versions 2.4 du noyau, je n'y crois pas
trop.


Merci de votre aide.


--
> Voici mon problème, j'ai deux PCs relies par des cartes ethernet,
> configures avec le protocole PPP.
-+- Romain in Guide du linuxien pervers - "Ils sont fous ces romains !" -+-
Hugo (né il y a 1 390 847 329 secondes)
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Droger Jean-Paul
Le #6688761
Hugolino a exprimé avec précision :
[X-post: fcolc,fcsp - fu2: fcolc]

Salut,

J'ai un vieux Toshiba Satellite S1800-514 sur lequel tourne une Debian
Lenny. Je crois que la machine date de septembre 2002.

Le problème de ce portable est qu'il ne redémarre pas avec la commande
'shutdown -r now' (très chiant quand on ne s'en rappelle plus et qu'on
tape cette commande par ssh).

Il y a aussi un Windows XP SP2 sur le disque de ce portable, et avec
Windows, pas de problème, le portable s'éteint ou redémarre
correctement (au moment du redémarrage, le témoin s'éteint une petite
seconde, puis se rallume).

Sous Debian Lenny, le portable s'éteint correctement, par contre, la
commande 'shutdown -r now' si elle fait son boulot correctement (arrêt
des services, démontage correct des partitions, etc) laisse le portable
dans un état "bloqué":
* Les deux derniers messages affichés sont:
- Will now restart
- Restarting system
* l'écran s'éteint mais le témoin de mise sous tension reste allumé.
* si on presse brièvement le bouton de mise sous tension, le portable
ne réagit pas.
* il faut presser presser le bouton de mise sous tension pendant
plusieurs secondes (il y a alors 4 bips) pour *éteindre* le portable,
puis on peut enfin redémarrer la machine en pressant à nouveau ce
bouton.

J'ai fait un tour dans le BIOS qui affiche fièrement "ACPI BIOS version
1.0" (mais puisque je n'y ai pas vu de mention d'un constructeur de BIOS,
j'imagine qu'il a été fait par Toshiba).

Je soupçonne fortement un problème d'ACPI, du à l'age vénérable de la
machine.

J'ai fouillé les archives et j'ai trouvé quelques pistes à explorer,
mais comme ça concernait les versions 2.4 du noyau, je n'y crois pas
trop.


Merci de votre aide.


si windows y arrive, je pense plutot que ta Debian a un petit défaut à
quelque part ... et si tu la remettais (Linux a en général une fonction
"réparation" assez performante, sinon y recoller la version à partir de
rien ne doit pas poser un problème immense!

--
Pour m'envoyer un mail, remplacer anti par droger et manama par
wanadoo; to send me directly a mail replace anti with droger and manama
with wanadoo;


julien
Le #6689641
J'ai fait un tour dans le BIOS qui affiche fièrement "ACPI BIOS version
1.0" (mais puisque je n'y ai pas vu de mention d'un constructeur de BIOS,
j'imagine qu'il a été fait par Toshiba).

Je soupçonne fortement un problème d'ACPI, du à l'age vénérable de la
machine.
Peut-être un problème de DSDT ?

Je t'invite à aller sur ce lien :
http://serval2412.free.fr/dsdt.xhtml

C'est une pauvre page que je me suis faite car j'en avais marre de
devoir retrouver les infos.
Evidemment, cette page pourrait largement être améliorée, corrigée, etc.

Hugolino
Le #6692011
Le 23-05-2008, Droger Jean-Paul
Hugolino a exprimé avec précision :
Je soupçonne fortement un problème d'ACPI, du à l'age vénérable de la
machine.

J'ai fouillé les archives et j'ai trouvé quelques pistes à explorer,
mais comme ça concernait les versions 2.4 du noyau, je n'y crois pas
trop.


Merci de votre aide.


si windows y arrive, je pense plutot que ta Debian a un petit défaut à
quelque part ... et si tu la remettais (Linux a en général une fonction
"réparation" assez performante, sinon y recoller la version à partir de
rien ne doit pas poser un problème immense!


Oui, puis je pourrais ré-installer aussi, hein ! (avec formatage bas
niveau tant qu'à faire...)


--
woman.rpm (super program, no documentation)
Hugo (né il y a 1 390 956 665 secondes)


Hugolino
Le #6691991
Le 23-05-2008, julien
J'ai fait un tour dans le BIOS qui affiche fièrement "ACPI BIOS version
1.0" (mais puisque je n'y ai pas vu de mention d'un constructeur de BIOS,
j'imagine qu'il a été fait par Toshiba).

Je soupçonne fortement un problème d'ACPI, du à l'age vénérable de la
machine.
Peut-être un problème de DSDT ?

Je t'invite à aller sur ce lien :
http://serval2412.free.fr/dsdt.xhtml

C'est une pauvre page que je me suis faite car j'en avais marre de
devoir retrouver les infos.
Evidemment, cette page pourrait largement être améliorée, corrigée, etc.


OK, merci. Je teste et je vous dis quoi...


--
je copie le fichier rpm dans un répertoire et l'installe, maintenant
je ne sais pas lancer l'appli car elle ne s'est pas mise dans le menu
"Démarrer-Programmes".
-+- Stéph in Guide du linuxien pervers : "install.exe il est ou?" -+-


jp willm
Le #6824731
Hello,



J'ai un vieux Toshiba Satellite S1800-514 sur lequel tourne une Debian
Lenny. Je crois que la machine date de septembre 2002.

Le problème de ce portable est qu'il ne redémarre pas avec la commande
'shutdown -r now' (très chiant quand on ne s'en rappelle plus et qu'on
tape cette commande par ssh).


Je soupçonne fortement un problème d'ACPI, du à l'age vénérable de la
machine.


J'ai par hasard lu un tuto intéressant au sujet des ACPI mal codés :
http://serval2412.free.fr/dsdt.xhtml


--
jp willm
http://perso.orange.fr/willms/index.html

Publicité
Poster une réponse
Anonyme