Visualiser les doublons

Le
JeanYvesGascon
Bonjour à toutes et tous,

Je rencontre un souci sous un tableau partagé avec la saisie de
doublons.

En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/AA)
En colonne B : date de fin (nommée Fin B2:B300, format JJ/MM/AA,
supérieur ou égale à An)
En colonne C : Lieux (Nommée Lieux C2:C300, liste de
validation en Feuill 2 A2:A60)
En colonne D : Nom (Nommée Nom D2:D300)
En colonne E : Prénom /.
En colonne J : I (Nommée Midi J2:J300; liste de
validation en Feuill 2 D2:D3)
En colonne K : G (Nommée Gouter K2:K300; liste de
validation en Feuill 2 D2:D3)
En colonne L : E (Nommée Etude L2:L300; liste de
validation en Feuill 2 D2:D3)

Je souhaite mettre en place un système d'alerte visuelle sur le risque
de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
dates qui peuvent se chevaucher

Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critère=
s
comme ci-dessous.

=SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Midi=
$J2)*(Gouter=$K2)*(Etude=$L2))>1

EN théorie, cela aurait fonctionné, mais diantre que nenni !!!

Ou est ce que le bas blesse ???

Je vous remercie toutes et tous de vos éclairages.

Si necessaire, je peux poster un fichier exemple.

Bon courage

Jean-Yves
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JeanYvesGascon
Le #21308931
On 3 mar, 19:32, JeanYvesGascon
Bonjour à toutes et tous,

Je rencontre un souci sous un tableau partagé avec la saisie de
doublons.

En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/AA)
En colonne B : date de fin      (nommée Fin B2:B300, format JJ/MM /AA,
supérieur ou égale à An)
En colonne C : Lieux             (Nommée Lieux C2:C300, lis te de
validation en Feuill 2 A2:A60)
En colonne D : Nom              (Nommée Nom D2:D300)
En colonne E : Prénom  .../....
En colonne J : I                     (Nommée Midi J 2:J300; liste de
validation en Feuill 2 D2:D3)
En colonne K : G                  (Nommée Gouter K2:K 300; liste de
validation en Feuill 2 D2:D3)
En colonne L : E                   (Nommée Etude L2:L 300; liste de
validation en Feuill 2 D2:D3)

Je souhaite mettre en place un système d'alerte visuelle sur le risque
de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
dates qui peuvent se chevaucher

Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critè res
comme ci-dessous.

=SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Midi =
$J2)*(Gouter=$K2)*(Etude=$L2))>1

EN théorie, cela aurait fonctionné, mais diantre que nenni !!!

Ou est ce que le bas blesse ???

Je vous remercie toutes et tous de vos éclairages.

Si necessaire, je peux poster un fichier exemple.

Bon courage

Jean-Yves



Re Bonsoir,

En question complémentaire, y aurait il une solution en VBA ?

Re merci

Jean-Yves
Daniel.C
Le #21309341
Bonsoir.
pas facile de se faire une idée. Peux-tu poster un classeur exemple sur
www.cijoint.fr en effaçant les données confidentielles ?
Daniel

Bonjour à toutes et tous,

Je rencontre un souci sous un tableau partagé avec la saisie de
doublons.

En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/AA)
En colonne B : date de fin (nommée Fin B2:B300, format JJ/MM/AA,
supérieur ou égale à An)
En colonne C : Lieux (Nommée Lieux C2:C300, liste de
validation en Feuill 2 A2:A60)
En colonne D : Nom (Nommée Nom D2:D300)
En colonne E : Prénom .../....
En colonne J : I (Nommée Midi J2:J300; liste de
validation en Feuill 2 D2:D3)
En colonne K : G (Nommée Gouter K2:K300; liste de
validation en Feuill 2 D2:D3)
En colonne L : E (Nommée Etude L2:L300; liste de
validation en Feuill 2 D2:D3)

Je souhaite mettre en place un système d'alerte visuelle sur le risque
de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
dates qui peuvent se chevaucher

Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critères
comme ci-dessous.

=SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Midi > $J2)*(Gouter=$K2)*(Etude=$L2))>1

EN théorie, cela aurait fonctionné, mais diantre que nenni !!!

Ou est ce que le bas blesse ???

Je vous remercie toutes et tous de vos éclairages.

Si necessaire, je peux poster un fichier exemple.

Bon courage

Jean-Yves
JB
Le #21309621
Bonsoir,

http://cjoint.com/?ddvsi1k3Fq

JB


On 3 mar, 19:32, JeanYvesGascon
Bonjour à toutes et tous,

Je rencontre un souci sous un tableau partagé avec la saisie de
doublons.

En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/AA)
En colonne B : date de fin      (nommée Fin B2:B300, format JJ/MM /AA,
supérieur ou égale à An)
En colonne C : Lieux             (Nommée Lieux C2:C300, lis te de
validation en Feuill 2 A2:A60)
En colonne D : Nom              (Nommée Nom D2:D300)
En colonne E : Prénom  .../....
En colonne J : I                     (Nommée Midi J 2:J300; liste de
validation en Feuill 2 D2:D3)
En colonne K : G                  (Nommée Gouter K2:K 300; liste de
validation en Feuill 2 D2:D3)
En colonne L : E                   (Nommée Etude L2:L 300; liste de
validation en Feuill 2 D2:D3)

Je souhaite mettre en place un système d'alerte visuelle sur le risque
de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
dates qui peuvent se chevaucher

Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critè res
comme ci-dessous.

=SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Midi =
$J2)*(Gouter=$K2)*(Etude=$L2))>1

EN théorie, cela aurait fonctionné, mais diantre que nenni !!!

Ou est ce que le bas blesse ???

Je vous remercie toutes et tous de vos éclairages.

Si necessaire, je peux poster un fichier exemple.

Bon courage

Jean-Yves
JeanYvesGascon
Le #21309601
On 3 mar, 20:59, Daniel.C
Bonsoir.
pas facile de se faire une idée. Peux-tu poster un classeur exemple sur www.cijoint.fren effaçant les données confidentielles ?
Daniel



> Bonjour à toutes et tous,

> Je rencontre un souci sous un tableau partagé avec la saisie de
> doublons.

> En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/A A)
> En colonne B : date de fin      (nommée Fin B2:B300, format JJ/ MM/AA,
> supérieur ou égale à An)
> En colonne C : Lieux             (Nommée Lieux C2:C300, l iste de
> validation en Feuill 2 A2:A60)
> En colonne D : Nom              (Nommée Nom D2:D300)
> En colonne E : Prénom  .../....
> En colonne J : I                     (Nommée Midi J2:J300; liste de
> validation en Feuill 2 D2:D3)
> En colonne K : G                  (Nommée Gouter K2 :K300; liste de
> validation en Feuill 2 D2:D3)
> En colonne L : E                   (Nommée Etude L2 :L300; liste de
> validation en Feuill 2 D2:D3)

> Je souhaite mettre en place un système d'alerte visuelle sur le risqu e
> de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
> dates qui peuvent se chevaucher

> Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs crit ères
> comme ci-dessous.

> =SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Mid i=
> $J2)*(Gouter=$K2)*(Etude=$L2))>1

> EN théorie, cela aurait fonctionné, mais diantre que nenni !!!

> Ou est ce que le bas blesse ???

> Je vous remercie toutes et tous de vos éclairages.

> Si necessaire, je peux poster un fichier exemple.

> Bon courage

> Jean-Yves




Bonsoir Daniel

Voici le fichier

http://www.cijoint.fr/cjlink.php?file=cj201003/cijv2RCgms.xls

Merci

Jean-Yves
Daniel.C
Le #21310441
Ta mise en forme conditionnelle fonctionne chez moi, tant sur XL2003
que sur XL2007.
Daniel

On 3 mar, 20:59, Daniel.C
Bonsoir.
pas facile de se faire une idée. Peux-tu poster un classeur exemple
surwww.cijoint.fren effaçant les données confidentielles ? Daniel



Bonjour à toutes et tous,



Je rencontre un souci sous un tableau partagé avec la saisie de
doublons.



En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/AA)
En colonne B : date de fin      (nommée Fin B2:B300, format JJ/MM/AA,
supérieur ou égale à An)
En colonne C : Lieux             (Nommée Lieux C2:C300, liste de
validation en Feuill 2 A2:A60)
En colonne D : Nom              (Nommée Nom D2:D300)
En colonne E : Prénom  .../....
En colonne J : I                     (Nommée Midi J2:J300; liste de
validation en Feuill 2 D2:D3)
En colonne K : G                  (Nommée Gouter K2:K300; liste de
validation en Feuill 2 D2:D3)
En colonne L : E                   (Nommée Etude L2:L300; liste de
validation en Feuill 2 D2:D3)



Je souhaite mettre en place un système d'alerte visuelle sur le risque
de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
dates qui peuvent se chevaucher



Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critères
comme ci-dessous.



=SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Midi >>> $J2)*(Gouter=$K2)*(Etude=$L2))>1



EN théorie, cela aurait fonctionné, mais diantre que nenni !!!
Ou est ce que le bas blesse ???



Je vous remercie toutes et tous de vos éclairages.
Si necessaire, je peux poster un fichier exemple.
Bon courage



Jean-Yves






Bonsoir Daniel

Voici le fichier

http://www.cijoint.fr/cjlink.php?file=cj201003/cijv2RCgms.xls

Merci

Jean-Yves
Daniel.C
Le #21310431
... sauf que les lignes entièrement vides sont considérées comme
doublons.
Daniel

Ta mise en forme conditionnelle fonctionne chez moi, tant sur XL2003 que sur
XL2007.
Daniel

On 3 mar, 20:59, Daniel.C
Bonsoir.
pas facile de se faire une idée. Peux-tu poster un classeur exemple
surwww.cijoint.fren effaçant les données confidentielles ? Daniel



Bonjour à toutes et tous,



Je rencontre un souci sous un tableau partagé avec la saisie de
doublons.



En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/AA)
En colonne B : date de fin      (nommée Fin B2:B300, format JJ/MM/AA,
supérieur ou égale à An)
En colonne C : Lieux             (Nommée Lieux C2:C300, liste de
validation en Feuill 2 A2:A60)
En colonne D : Nom              (Nommée Nom D2:D300)
En colonne E : Prénom  .../....
En colonne J : I                     (Nommée Midi J2:J300; liste de
validation en Feuill 2 D2:D3)
En colonne K : G                  (Nommée Gouter K2:K300; liste de
validation en Feuill 2 D2:D3)
En colonne L : E                   (Nommée Etude L2:L300; liste de
validation en Feuill 2 D2:D3)



Je souhaite mettre en place un système d'alerte visuelle sur le risque
de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
dates qui peuvent se chevaucher



Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critères
comme ci-dessous.



=SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Midi >>>> $J2)*(Gouter=$K2)*(Etude=$L2))>1



EN théorie, cela aurait fonctionné, mais diantre que nenni !!!
Ou est ce que le bas blesse ???



Je vous remercie toutes et tous de vos éclairages.
Si necessaire, je peux poster un fichier exemple.
Bon courage



Jean-Yves






Bonsoir Daniel

Voici le fichier

http://www.cijoint.fr/cjlink.php?file=cj201003/cijv2RCgms.xls

Merci

Jean-Yves
JeanYvesGascon
Le #21311711
On 3 mar, 23:26, Daniel.C
... sauf que les lignes entièrement vides sont considérées comme
doublons.
Daniel



> Ta mise en forme conditionnelle fonctionne chez moi, tant sur XL2003 qu e sur
> XL2007.
> Daniel

>> On 3 mar, 20:59, Daniel.C >>> Bonsoir.
>>> pas facile de se faire une idée. Peux-tu poster un classeur exemple
>>> surwww.cijoint.freneffaçant les données confidentielles ? Daniel

>>>> Bonjour à toutes et tous,

>>>> Je rencontre un souci sous un tableau partagé avec la saisie de
>>>> doublons.

>>>> En colonne A : date de départ (nommée Debut A2:A300, format JJ/M M/AA)
>>>> En colonne B : date de fin      (nommée Fin B2:B300, format JJ/MM/AA,
>>>> supérieur ou égale à An)
>>>> En colonne C : Lieux             (Nommée Lieux C2:C300 , liste de
>>>> validation en Feuill 2 A2:A60)
>>>> En colonne D : Nom              (Nommée Nom D2:D300)
>>>> En colonne E : Prénom  .../....
>>>> En colonne J : I                     (Nommée M idi J2:J300; liste de
>>>> validation en Feuill 2 D2:D3)
>>>> En colonne K : G                  (Nommée Gouter K2:K300; liste de
>>>> validation en Feuill 2 D2:D3)
>>>> En colonne L : E                   (Nommée Etude L2:L300; liste de
>>>> validation en Feuill 2 D2:D3)

>>>> Je souhaite mettre en place un système d'alerte visuelle sur le ri sque
>>>> de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
>>>> dates qui peuvent se chevaucher

>>>> Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs cr itères
>>>> comme ci-dessous.

>>>> =SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*( Midi=
>>>> $J2)*(Gouter=$K2)*(Etude=$L2))>1

>>>> EN théorie, cela aurait fonctionné, mais diantre que nenni !!!
>>>> Ou est ce que le bas blesse ???

>>>> Je vous remercie toutes et tous de vos éclairages.
>>>> Si necessaire, je peux poster un fichier exemple.
>>>> Bon courage

>>>> Jean-Yves

>> Bonsoir Daniel

>> Voici le fichier

>>http://www.cijoint.fr/cjlink.php?file=cj201003/cijv2RCgms.xls

>> Merci

>> Jean-Yves- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Bonjour à vous deux et à tous les autres

Merci de vos contributions.
Grâce à JB, pour éviter les lignes vides, il faut introduire (A2<> "" )
à la formule matricielle de MFC.
Ceci fonctionne correctement.

Mon souci est ailleurs.
Dans la notion de chevauchement de date.

Par exemple, le même lieux , même personne, même service
noté une première fois absent du 1/3 au 11/3, une seconde fois absent
du 11/3 au 21/3 et une troisième fois du 21/3 au 31/3

En toute logique , ces trois données sont des doublons partiels en
puissance, mais la formule ne semble pas convenir :

=SOMMEPROD((A2<> "")*(Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=
$D2)*(Midi=$J2)*(Gouter=$K2)*(Etude=$L2))>1

Cela vient il d'une mauvaise lecture des seuils de dates ?

Merci de votre aide.

Cordialement

Jean-Yves
Daniel.C
Le #21312041
On 3 mar, 23:26, Daniel.C
... sauf que les lignes entièrement vides sont considérées comme
doublons.
Daniel



Ta mise en forme conditionnelle fonctionne chez moi, tant sur XL2003 que
sur XL2007.
Daniel



On 3 mar, 20:59, Daniel.C
Bonsoir.
pas facile de se faire une idée. Peux-tu poster un classeur exemple
surwww.cijoint.freneffaçant les données confidentielles ? Daniel
Bonjour à toutes et tous,









Je rencontre un souci sous un tableau partagé avec la saisie de
doublons.









En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/AA)
En colonne B : date de fin      (nommée Fin B2:B300, format JJ/MM/AA,
supérieur ou égale à An)
En colonne C : Lieux             (Nommée Lieux C2:C300, liste de
validation en Feuill 2 A2:A60)
En colonne D : Nom              (Nommée Nom D2:D300)
En colonne E : Prénom  .../....
En colonne J : I                     (Nommée Midi J2:J300; liste de
validation en Feuill 2 D2:D3)
En colonne K : G                  (Nommée Gouter K2:K300; liste de
validation en Feuill 2 D2:D3)
En colonne L : E                   (Nommée Etude L2:L300; liste de
validation en Feuill 2 D2:D3)









Je souhaite mettre en place un système d'alerte visuelle sur le risque
de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
dates qui peuvent se chevaucher









Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critères
comme ci-dessous.









=SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Midi >>>>>> $J2)*(Gouter=$K2)*(Etude=$L2))>1









EN théorie, cela aurait fonctionné, mais diantre que nenni !!!
Ou est ce que le bas blesse ???









Je vous remercie toutes et tous de vos éclairages.
Si necessaire, je peux poster un fichier exemple.
Bon courage









Jean-Yves









Bonsoir Daniel





Voici le fichier





http://www.cijoint.fr/cjlink.php?file=cj201003/cijv2RCgms.xls
Merci





Jean-Yves- Masquer le texte des messages précédents -





- Afficher le texte des messages précédents -



Bonjour à vous deux et à tous les autres

Merci de vos contributions.
Grâce à JB, pour éviter les lignes vides, il faut introduire (A2<> "")
à la formule matricielle de MFC.
Ceci fonctionne correctement.

Mon souci est ailleurs.
Dans la notion de chevauchement de date.

Par exemple, le même lieux , même personne, même service
noté une première fois absent du 1/3 au 11/3, une seconde fois absent
du 11/3 au 21/3 et une troisième fois du 21/3 au 31/3

En toute logique , ces trois données sont des doublons partiels en
puissance, mais la formule ne semble pas convenir :

=SOMMEPROD((A2<> "")*(Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom > $D2)*(Midi=$J2)*(Gouter=$K2)*(Etude=$L2))>1

Cela vient il d'une mauvaise lecture des seuils de dates ?

Merci de votre aide.

Cordialement

Jean-Yves



Bonjour.
regarde si :
=SOMMEPROD(($A2<>"")*(Debut>=MIN((Nom=$D2)*Debut))*(Fin<=MAX((Nom=$D2)*Fin))*(Lieux=$C2)*(Nom=$D2)*(Midi=$J2)*(Gouter=$K2)*(Etude=$L2))>1
peut convenir.
Daniel
JeanYvesGascon
Le #21312721
On 4 mar, 11:03, Daniel.C
> On 3 mar, 23:26, Daniel.C >> ... sauf que les lignes entièrement vides sont considérées comme
>> doublons.
>> Daniel

>>> Ta mise en forme conditionnelle fonctionne chez moi, tant sur XL2003 que
>>> sur XL2007.
>>> Daniel

>>>> On 3 mar, 20:59, Daniel.C >>>>> Bonsoir.
>>>>> pas facile de se faire une idée. Peux-tu poster un classeur exemp le
>>>>> surwww.cijoint.freneffaçant les données confidentielles ? Danie l
>>>>>> Bonjour à toutes et tous,

>>>>>> Je rencontre un souci sous un tableau partagé avec la saisie de
>>>>>> doublons.

>>>>>> En colonne A : date de départ (nommée Debut A2:A300, format JJ /MM/AA)
>>>>>> En colonne B : date de fin      (nommée Fin B2:B300, forma t JJ/MM/AA,
>>>>>> supérieur ou égale à An)
>>>>>> En colonne C : Lieux             (Nommée Lieux C2:C3 00, liste de
>>>>>> validation en Feuill 2 A2:A60)
>>>>>> En colonne D : Nom              (Nommée Nom D2:D30 0)
>>>>>> En colonne E : Prénom  .../....
>>>>>> En colonne J : I                     (Nommée Midi J2:J300; liste de
>>>>>> validation en Feuill 2 D2:D3)
>>>>>> En colonne K : G                  (Nommée Gout er K2:K300; liste de
>>>>>> validation en Feuill 2 D2:D3)
>>>>>> En colonne L : E                   (Nommée Etu de L2:L300; liste de
>>>>>> validation en Feuill 2 D2:D3)

>>>>>> Je souhaite mettre en place un système d'alerte visuelle sur le risque
>>>>>> de lignes saisie plusieurs fois avec les mêmes valeurs ou avec d es
>>>>>> dates qui peuvent se chevaucher

>>>>>> Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critères
>>>>>> comme ci-dessous.

>>>>>> =SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2) *(Midi=
>>>>>> $J2)*(Gouter=$K2)*(Etude=$L2))>1

>>>>>> EN théorie, cela aurait fonctionné, mais diantre que nenni !!!
>>>>>> Ou est ce que le bas blesse ???

>>>>>> Je vous remercie toutes et tous de vos éclairages.
>>>>>> Si necessaire, je peux poster un fichier exemple.
>>>>>> Bon courage

>>>>>> Jean-Yves

>>>> Bonsoir Daniel

>>>> Voici le fichier

>>>>http://www.cijoint.fr/cjlink.php?file=cj201003/cijv2RCgms.xls
>>>> Merci

>>>> Jean-Yves- Masquer le texte des messages précédents -

>> - Afficher le texte des messages précédents -

> Bonjour à vous deux et à tous les autres

> Merci de vos contributions.
> Grâce à JB, pour éviter les lignes vides, il faut introduire (A2< > "")
> à la formule matricielle de MFC.
> Ceci fonctionne correctement.

> Mon souci est ailleurs.
> Dans la notion de chevauchement de date.

> Par exemple, le même lieux , même personne, même service
> noté une première fois absent du 1/3 au 11/3, une seconde fois abse nt
> du 11/3 au 21/3 et une troisième fois du 21/3 au 31/3

> En toute logique , ces trois données sont des doublons partiels en
> puissance, mais la formule ne semble pas convenir :

> =SOMMEPROD((A2<> "")*(Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom =
> $D2)*(Midi=$J2)*(Gouter=$K2)*(Etude=$L2))>1

> Cela vient il d'une mauvaise lecture des seuils de dates ?

> Merci de votre aide.

> Cordialement

> Jean-Yves

Bonjour.
regarde si :
=SOMMEPROD(($A2<>"")*(Debut>=MIN((Nom=$D2)*Debut))*(Fin<=MAX((Nom =$D2)*Fin)­)*(Lieux=$C2)*(Nom=$D2)*(Midi=$J2)*(Gouter=$K2)*(Etu de=$L2))>1
peut convenir.
Daniel- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Daniel,

Je n'arrive à saisir le sens de ton ajout.

(Debut>=MIN((Nom=$D2)*Debut))*(Fin<=MAX((Nom=$D2)*Fin)­)

C'est surtout la référence "Nom" qui m'interpelle .

Je vais essayer ceci

(Debut>=MIN((Fin=$B2)*(Debut))*(Fin<=MAX((Debut=$A2)*(Fin))

Et je te tiens informer

Cordialement

Jean-Yves
Daniel.C
Le #21313201
Par exeemple, MAX((Nom=$D2)*Fin) renvoie la date de fin maximale
correspondant au nom situé en D2.
N'hésite pas à demander des explications plus détaillées.
Daniel

On 4 mar, 11:03, Daniel.C
On 3 mar, 23:26, Daniel.C
... sauf que les lignes entièrement vides sont considérées comme
doublons.
Daniel





Ta mise en forme conditionnelle fonctionne chez moi, tant sur XL2003 que
sur XL2007.
Daniel







On 3 mar, 20:59, Daniel.C
Bonsoir.
pas facile de se faire une idée. Peux-tu poster un classeur exemple
surwww.cijoint.freneffaçant les données confidentielles ? Daniel
Bonjour à toutes et tous,













Je rencontre un souci sous un tableau partagé avec la saisie de
doublons.













En colonne A : date de départ (nommée Debut A2:A300, format JJ/MM/AA)
En colonne B : date de fin      (nommée Fin B2:B300, format JJ/MM/AA,
supérieur ou égale à An)
En colonne C : Lieux             (Nommée Lieux C2:C300, liste de
validation en Feuill 2 A2:A60)
En colonne D : Nom              (Nommée Nom D2:D300)
En colonne E : Prénom  .../....
En colonne J : I                     (Nommée Midi J2:J300; liste de
validation en Feuill 2 D2:D3)
En colonne K : G                  (Nommée Gouter K2:K300; liste de
validation en Feuill 2 D2:D3)
En colonne L : E                   (Nommée Etude L2:L300; liste de
validation en Feuill 2 D2:D3)













Je souhaite mettre en place un système d'alerte visuelle sur le risque
de lignes saisie plusieurs fois avec les mêmes valeurs ou avec des
dates qui peuvent se chevaucher
Donc, j'ai élaboré depuis A2 une formule de MFC à plusieurs critères
comme ci-dessous.













=SOMMEPROD((Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom=$D2)*(Midi >>>>>>>> $J2)*(Gouter=$K2)*(Etude=$L2))>1
EN théorie, cela aurait fonctionné, mais diantre que nenni !!!
Ou est ce que le bas blesse ???
Je vous remercie toutes et tous de vos éclairages.
Si necessaire, je peux poster un fichier exemple.
Bon courage













Jean-Yves













Bonsoir Daniel









Voici le fichier









http://www.cijoint.fr/cjlink.php?file=cj201003/cijv2RCgms.xls
Merci









Jean-Yves- Masquer le texte des messages précédents -




- Afficher le texte des messages précédents -


Bonjour à vous deux et à tous les autres
Merci de vos contributions.
Grâce à JB, pour éviter les lignes vides, il faut introduire (A2<> "")
à la formule matricielle de MFC.
Ceci fonctionne correctement.



Mon souci est ailleurs.
Dans la notion de chevauchement de date.
Par exemple, le même lieux , même personne, même service
noté une première fois absent du 1/3 au 11/3, une seconde fois absent
du 11/3 au 21/3 et une troisième fois du 21/3 au 31/3
En toute logique , ces trois données sont des doublons partiels en
puissance, mais la formule ne semble pas convenir :
=SOMMEPROD((A2<> "")*(Debut>=$A2)*(Fin<=$B2)*(Lieux=$C2)*(Nom >>> $D2)*(Midi=$J2)*(Gouter=$K2)*(Etude=$L2))>1
Cela vient il d'une mauvaise lecture des seuils de dates ?
Merci de votre aide.



Cordialement



Jean-Yves



Bonjour.
regarde si :
=SOMMEPROD(($A2<>"")*(Debut>=MIN((Nom=$D2)*Debut))*(Fin<=MAX((Nom=$D2)*Fin)­)*(Lieux=$C2)*(Nom=$D2)*(Midi=$J2)*(Gouter=$K2)*(Etude=$L2))>1
peut convenir.
Daniel- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Daniel,

Je n'arrive à saisir le sens de ton ajout.

(Debut>=MIN((Nom=$D2)*Debut))*(Fin<=MAX((Nom=$D2)*Fin)­)

C'est surtout la référence "Nom" qui m'interpelle .

Je vais essayer ceci

(Debut>=MIN((Fin=$B2)*(Debut))*(Fin<=MAX((Debut=$A2)*(Fin))

Et je te tiens informer

Cordialement

Jean-Yves
Publicité
Poster une réponse
Anonyme