[WB11] problème avec MySQL

Le
Lt_PyL
Salut à tous,

J'ai un soucis

J'ai voulu tester Webdev avec MySQL et je tombe sur une bizarrerie:
Bien qu'il me soit possible d'accéder à ma base depuis un client MySQL
(EMS) et depuis l'analyse (je peux même editer le fichier avec WDmap),
il m'est impossible d'y accéder depuis le site php généré par webdev (en
RAD c'était un test).

je me retrouve systématiquement avec ça:
-

Erreur d'éxécution de la page .
Vous avez appelé la fonction HCreationSiInexistant.
La connexion à la base <test> sur <www.monsite.com> a échouée.
Message retournée par la base : Access denied for user
'test'@'Serveur' (using password: YES)

-

l'utilisateur "test" a pourtant bien accès à la base "test" (depuis
wdmap, EMS ou même le client MySQL de base!).

Par contre, si j'active le Disable Grant Table, comme par magie, j'ai
accès à tout (ce qui est loin d'être souhaitable, nous en conviendrons,
mais néanmoins parfaitement logique)

NOTE: l'utilisateur "test" dispose pourtant de TOUTES les permissions
(création de table, lecture, écriture, ..)

La connexion définie dans l'analyse est pourtant valide: les tests de
connexions passent, et l'accès à la modification du fichier à travers
wdmap en sont la preuve
Même les livedata sont nickel!

Alors à votre avis, où est le problème?


merci d'avance
PyL
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
news
Le #14460691
Attention que le navigateur soit pas réglé en sécurité trop élévée

Attention aussi ca marche pas en PHP5

Certaines parties du RAd ne marchent pas
notamment les zones répétées




"Lt_PyL" f0sitg$ctn$
Salut à tous,

J'ai un soucis...

J'ai voulu tester Webdev avec MySQL et je tombe sur une bizarrerie:
Bien qu'il me soit possible d'accéder à ma base depuis un client MySQL
(EMS) et depuis l'analyse (je peux même editer le fichier avec WDmap),
il m'est impossible d'y accéder depuis le site php généré par webdev (en
RAD... c'était un test).

je me retrouve systématiquement avec ça:
----------------------------------------

Erreur d'éxécution de la page .
Vous avez appelé la fonction HCreationSiInexistant.
La connexion à la base Message retournée par la base : Access denied for user
'test'@'Serveur' (using password: YES)

----------------------------------------

l'utilisateur "test" a pourtant bien accès à la base "test" (depuis
wdmap, EMS ou même le client MySQL de base!).

Par contre, si j'active le Disable Grant Table, comme par magie, j'ai
accès à tout (ce qui est loin d'être souhaitable, nous en conviendrons,
mais néanmoins parfaitement logique)

NOTE: l'utilisateur "test" dispose pourtant de TOUTES les permissions
(création de table, lecture, écriture, .....)

La connexion définie dans l'analyse est pourtant valide: les tests de
connexions passent, et l'accès à la modification du fichier à travers
wdmap en sont la preuve...
Même les livedata sont nickel!

Alors à votre avis, où est le problème?


merci d'avance
PyL


patrice
Le #14460681
"Lt_PyL" news:f0sitg$ctn$
----------------------------------------

Erreur d'éxécution de la page .
Vous avez appelé la fonction HCreationSiInexistant.
La connexion à la base Message retournée par la base : Access denied for user
'test'@'Serveur' (using password: YES)




ca fait ca quand la machine ou l'utilisateur n'est pas décrit dans une des
tables de la db 'mysql' pour les droits de connexion.
symptome: ca marche depuis la machine de dev, ca marche plus depuis le
serveur

quand vous dites que ca fonctionne avec d'autre soft, lancez vous ces softs
depuis la meme machine que le site php incriminé ?
Lt_PyL
Le #14460651
patrice a écrit :
"Lt_PyL" news:f0sitg$ctn$
----------------------------------------

Erreur d'éxécution de la page .
Vous avez appelé la fonction HCreationSiInexistant.
La connexion à la base Message retournée par la base : Access denied for user
'test'@'Serveur' (using password: YES)




ca fait ca quand la machine ou l'utilisateur n'est pas décrit dans une des
tables de la db 'mysql' pour les droits de connexion.
symptome: ca marche depuis la machine de dev, ca marche plus depuis le
serveur

quand vous dites que ca fonctionne avec d'autre soft, lancez vous ces softs
depuis la meme machine que le site php incriminé ?



depuis la console mysql du serveur, aucun problème
depuis un poste distant, avec la console mysql, aucun problème
les livedata de webdev (sur poste distant), aucun problème

en accès web depuis un poste distant => erreur
en accès web depuis le serveur (en local, donc) => erreur

je vais vérifier qu'il ne s'agît pas d'un problème de version de PHP,
comme semble le signaler News

--
Lt_PyL
Lt_PyL
Le #14460641
Damned!

Moi qui ai justement PHP5!

Pour les zones répétées et autres nids à bugs, j'évite de m'en servir...
en fait, je n'utilisai le RAD que dans le but de tester la faisabilité
d'un projet...

Manque de bol....

bon, je vais voir si y'a pas une solution chez pcsoft (une màj miracle?)...

merci beaucoup

--
Lt_PyL

news a écrit :
Attention que le navigateur soit pas réglé en sécurité trop élévée

Attention aussi ca marche pas en PHP5

Certaines parties du RAd ne marchent pas
notamment les zones répétées




"Lt_PyL" f0sitg$ctn$
Salut à tous,

J'ai un soucis...

J'ai voulu tester Webdev avec MySQL et je tombe sur une bizarrerie:
Bien qu'il me soit possible d'accéder à ma base depuis un client MySQL
(EMS) et depuis l'analyse (je peux même editer le fichier avec WDmap),
il m'est impossible d'y accéder depuis le site php généré par webdev (en
RAD... c'était un test).

je me retrouve systématiquement avec ça:
----------------------------------------

Erreur d'éxécution de la page .
Vous avez appelé la fonction HCreationSiInexistant.
La connexion à la base Message retournée par la base : Access denied for user
'test'@'Serveur' (using password: YES)

----------------------------------------

l'utilisateur "test" a pourtant bien accès à la base "test" (depuis
wdmap, EMS ou même le client MySQL de base!).

Par contre, si j'active le Disable Grant Table, comme par magie, j'ai
accès à tout (ce qui est loin d'être souhaitable, nous en conviendrons,
mais néanmoins parfaitement logique)

NOTE: l'utilisateur "test" dispose pourtant de TOUTES les permissions
(création de table, lecture, écriture, .....)

La connexion définie dans l'analyse est pourtant valide: les tests de
connexions passent, et l'accès à la modification du fichier à travers
wdmap en sont la preuve...
Même les livedata sont nickel!

Alors à votre avis, où est le problème?


merci d'avance
PyL






news
Le #14460631
DU ST

Les difficultés que vous avez rencontrées proviennent de la version de PHP.
En effet, il est nécessaire d'utiliser une version 4.2.x au minimum, sans
aller jusqu'aux versions 5.x. En effet, il n'y a pas de compatibilité
ascendante de PHP 5 avec PHP 4, il faudra de nouveaux développements pour
permettre la génération de sites s'exécutant en PHP 5.



"Lt_PyL" f0sp2q$dmo$
patrice a écrit :
"Lt_PyL" news:f0sitg$ctn$
----------------------------------------

Erreur d'éxécution de la page .
Vous avez appelé la fonction HCreationSiInexistant.
La connexion à la base Message retournée par la base : Access denied for user
'test'@'Serveur' (using password: YES)




ca fait ca quand la machine ou l'utilisateur n'est pas décrit dans une
des
tables de la db 'mysql' pour les droits de connexion.
symptome: ca marche depuis la machine de dev, ca marche plus depuis le
serveur

quand vous dites que ca fonctionne avec d'autre soft, lancez vous ces
softs
depuis la meme machine que le site php incriminé ?



depuis la console mysql du serveur, aucun problème
depuis un poste distant, avec la console mysql, aucun problème
les livedata de webdev (sur poste distant), aucun problème

en accès web depuis un poste distant => erreur
en accès web depuis le serveur (en local, donc) => erreur

je vais vérifier qu'il ne s'agît pas d'un problème de version de PHP,
comme semble le signaler News

--
Lt_PyL


Publicité
Poster une réponse
Anonyme