[WB12] Accès refuser sur des fichiers distants (win 2003)

Le
Sébasiten B.
Bonjour,

Depuis que j'ai migré mes sites (WEBDEV) sur un serveur Win 2003 avec
Apache 2.2, l'accès aux fichiers style "\serveurepmonfichier.pdf"
est impossible.
Il me dit que le fichier est inaccessible (accès refusé)

Le serveur où sont les données est un serveur win 2000

Avez vous une idée?

(Le support de Webdev m'ont dit que cela venait d'un paramétrage d'un
utilisateur sur lequel il faut mettre des droits spéciaux mais je ne
vois pas où configurer cela.)

Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébasiten B.
Le #16478821
Gilles a écrit :
"Sébasiten B." a pensé très fort :
Bonjour,

Depuis que j'ai migré mes sites (WEBDEV) sur un serveur Win 2003 avec
Apache 2.2, l'accès aux fichiers style "\serveurrepmonfichier.pdf"
est impossible.
Il me dit que le fichier est inaccessible (accès refusé)

Le serveur où sont les données est un serveur win 2000

Avez vous une idée?

(Le support de Webdev m'ont dit que cela venait d'un paramétrage d'un
utilisateur sur lequel il faut mettre des droits spéciaux mais je ne
vois pas où configurer cela.)



Ton service Apache est lancé par un utilisateur (par défaut "local
system account" en anglais).
Tu essayes d'accéder à un dossier sur lequel le compte systeme local n'a
pas les droits. Si c'est sur un autre serveur, ca sera impossible avec
cet utilisateur.

Si c'est sur ton propre serveur, pourquoi utiliser les chemins UNC? avec
un chemin complet, ca devrait marcher.

Sinon tu peux très bien dire à ton service de démarrer avec un autre
utilisateur spécifique qui aura les droits sur les dossiers qui vont
bien, quelles que soit les machines (attention!! trop de droits = faille
de sécurité).

C'est un problème 100% Windows, rien à voir avec Windev/Webdev.





Merci pour ta réponse.
Effectivement c'est notre propre serveur. Qu'est ce que tu entends par
chemin complet ? Le serveur 2003 (où sont lancés les sites webs) est
différents du serveur 2000 qui lui contient les fichiers que je veux
accéder.

Pour un test, j'ai mis le compte administrateur pour faire tourner le
service d'apache. Et maintenant, j'ai un message : "Echec d'ouverture de
session nom d'utilisateur inconnu ou mot de passe incorrect"

Est du fait que les mots de passe administrateur sont différents sur les
deux serveurs?
Petite précision aussi le serveur web (donc en 2003) n'est pas sur le
domaine.

Faut-il créer donc un même utilisateur sur chaque serveur ?
Sébastien B.
Le #16479221
Sébasiten B. a écrit :
Gilles a écrit :
"Sébasiten B." a pensé très fort :
Bonjour,

Depuis que j'ai migré mes sites (WEBDEV) sur un serveur Win 2003 avec
Apache 2.2, l'accès aux fichiers style "\serveurrepmonfichier.pdf"
est impossible.
Il me dit que le fichier est inaccessible (accès refusé)

Le serveur où sont les données est un serveur win 2000

Avez vous une idée?

(Le support de Webdev m'ont dit que cela venait d'un paramétrage d'un
utilisateur sur lequel il faut mettre des droits spéciaux mais je ne
vois pas où configurer cela.)



Ton service Apache est lancé par un utilisateur (par défaut "local
system account" en anglais).
Tu essayes d'accéder à un dossier sur lequel le compte systeme local
n'a pas les droits. Si c'est sur un autre serveur, ca sera impossible
avec cet utilisateur.

Si c'est sur ton propre serveur, pourquoi utiliser les chemins UNC?
avec un chemin complet, ca devrait marcher.

Sinon tu peux très bien dire à ton service de démarrer avec un autre
utilisateur spécifique qui aura les droits sur les dossiers qui vont
bien, quelles que soit les machines (attention!! trop de droits =
faille de sécurité).

C'est un problème 100% Windows, rien à voir avec Windev/Webdev.





Merci pour ta réponse.
Effectivement c'est notre propre serveur. Qu'est ce que tu entends par
chemin complet ? Le serveur 2003 (où sont lancés les sites webs) est
différents du serveur 2000 qui lui contient les fichiers que je veux
accéder.

Pour un test, j'ai mis le compte administrateur pour faire tourner le
service d'apache. Et maintenant, j'ai un message : "Echec d'ouverture de
session nom d'utilisateur inconnu ou mot de passe incorrect"

Est du fait que les mots de passe administrateur sont différents sur les
deux serveurs?
Petite précision aussi le serveur web (donc en 2003) n'est pas sur le
domaine.

Faut-il créer donc un même utilisateur sur chaque serveur ?



Juste pour signaler qu'il fallait bien créer un user identique sur
chaque serveur et lancer apache avec cet user.
maintenant tout fonctionne bien

merci
Publicité
Poster une réponse
Anonyme