[WB14] Affichage image - Pb de cache ?

Le
Yannick
Bonjour

Je rencontre le problème suivant :

Dans une zône répétée, un objet image (de type généré) et un bouton.

Sur le clic du bouton :
- Par un exe tiers, en ligne de commande, j'effectue une rotation de
90° sur l'image
- J'efface la zone repétée
- Je recharge la zone répétée avec l'image modifiée

Résultat : l'image affichée est celle d'origine -> comme si celle-ci
était restée dans un cache du navigateur !!!

Problème identique avec IE & Firefox


Des idées pour contourner ce problème ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Roumégou Eric
Le #20622181
Yannick a couché sur son écran :
Bonjour

Je rencontre le problème suivant :

Dans une zône répétée, un objet image (de type généré) et un bouton.

Sur le clic du bouton :
- Par un exe tiers, en ligne de commande, j'effectue une rotation de 90° sur
l'image
- J'efface la zone repétée
- Je recharge la zone répétée avec l'image modifiée

Résultat : l'image affichée est celle d'origine -> comme si celle-ci était
restée dans un cache du navigateur !!!

Problème identique avec IE & Firefox


Des idées pour contourner ce problème ?



essayer de rajouter les META Pragma Nocache ?? mais j'y crois pas trop
renommer le fichier ?


--
Eric Roumégou
Webmaster des wtablettes
http://cerbermail.com/?qE7t4Qvilo
(cliquez sur le lien ci-dessus pour me contacter en privé)
Yannick
Le #20622491
Roumégou Eric a émis l'idée suivante :
Yannick a couché sur son écran :
Bonjour

Je rencontre le problème suivant :

Dans une zône répétée, un objet image (de type généré) et un bouton.

Sur le clic du bouton :
- Par un exe tiers, en ligne de commande, j'effectue une rotation de 90°
sur l'image
- J'efface la zone repétée
- Je recharge la zone répétée avec l'image modifiée

Résultat : l'image affichée est celle d'origine -> comme si celle-ci était
restée dans un cache du navigateur !!!

Problème identique avec IE & Firefox


Des idées pour contourner ce problème ?



essayer de rajouter les META Pragma Nocache ?? mais j'y crois pas trop
renommer le fichier ?



J'ai pris la solution de renommer (Fabrice m'a répondu la même chose
sur l'autre forum)
C'est pas génial, mais ça marche...

Merci
Publicité
Poster une réponse
Anonyme