WD10 - Hrecherche

Le
tornade69
Bonjour a tous,

j'ai le problème suivant : la recherche ne marche pas, mais je ne sais
pas pourquoi. La velur de numact est de 3 et il y un enregistrement
avec IDHisto = 3

HOuvre(Histo)
HOuvre(Societe_Histo)
SI ModeOuverture=2 ALORS
HRecherche(Histo,IDHisto,numact,hIdentique)
Trace(Histo.IDHisto)
Trace(Histo.Sujet)
SI HTrouve(Histo) ALORS
HLitPremier(Histo)
FichierVersEcran(FEN_Activites)
Table_Societe_Histo..RubriqueParcourue="IDHisto"
Table_Societe_Histo..Filtre=Histo.IDHisto
FIN
FIN

Je ne vois pas ou est le bug
Merci pour votre aide

Tornade69
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
mat
Le #14612411
wrote:
...
HLitPremier(Histo)


...
Bonsoir,

cette ligne lit le premier enregistrement du fichier.

On pourrait le remplacer avec HLit() mais moi, je ferais

SI HLitRecherchePremier(Histo,IDHisto,numact) ALORS
FichierVersEcran(FEN_Activites)
Table_Societe_Histo..RubriqueParcourue="IDHisto"
Table_Societe_Histo..Filtre=Histo.IDHisto
...


Salutations
Mat
joseph cvjetic
Le #14612401
Pas bon
HRecherche(Histo,IDHisto,numact,hIdentique)
il faut faire la recherche sur la bonne clè
HRecherche(Histo,clé-numact,numact,hIdentique)
la ça doit aller
J Cvjetic




Bonjour a tous,

j'ai le problème suivant : la recherche ne marche pas, mais je ne sais
pas pourquoi. La velur de numact est de 3 et il y un enregistrement
avec IDHisto = 3

HOuvre(Histo)
HOuvre(Societe_Histo)
SI ModeOuverture=2 ALORS
HRecherche(Histo,IDHisto,numact,hIdentique)
Trace(Histo.IDHisto)
Trace(Histo.Sujet)
SI HTrouve(Histo) ALORS
HLitPremier(Histo)
FichierVersEcran(FEN_Activites)
Table_Societe_Histo..RubriqueParcourue="IDHisto"
Table_Societe_Histo..Filtre=Histo.IDHisto
FIN
FIN

Je ne vois pas ou est le bug
Merci pour votre aide

Tornade69
tornade69
Le #14612351
On 31 août, 07:09, "joseph cvjetic"
Pas bon
HRecherche(Histo,IDHisto,numact,hIdentique)
il faut faire la recherche sur la bonne clè
HRecherche(Histo,clé-numact,numact,hIdentique)
la ça doit aller
J Cvjetic




Merci pour cette réponse, mais je ne comprends pas
Table Histo : IDHisto --> IdAuto --->Indentification unique de la
table
numact : Variable qui contient le numéro d'histo que je recherche

Donc la clé de la table Histo c'est bien IDHisto ??

Mais je crois que mon erreur n'est pas la !!!! Je fait un hrecherche
puis hlitpremier (mais je ne suis pas sur une requette) donc a chaque
fois je reprends le premier enregistrement !!!!

Donc j'ai transformer en :

HOuvre(Histo)
HOuvre(Societe_Histo)
SI ModeOuverture=2 ALORS
HLitRecherche(Histo,IDHisto,numact,hIdentique) // c'est avec cela
que ca marche

Trace(Histo.IDHisto)
Trace(Histo.Sujet)
SI HTrouve(Histo) ALORS
//HLitPremier(Histo) --> c'est ca qui fait tout foirrer
FichierVersEcran(FEN_Activites)
Table_Societe_Histo..RubriqueParcourue="IDHisto"
Table_Societe_Histo..Filtre=Histo.IDHisto
FIN
FIN

Un grand Merci à tous de votre aide,

Tornade69
joseph cvjetic
Le #14612331
oui c'est juste

On 31 août, 07:09, "joseph cvjetic"
Pas bon
HRecherche(Histo,IDHisto,numact,hIdentique)
il faut faire la recherche sur la bonne clè
HRecherche(Histo,clé-numact,numact,hIdentique)
la ça doit aller
J Cvjetic




Merci pour cette réponse, mais je ne comprends pas
Table Histo : IDHisto --> IdAuto --->Indentification unique de la
table
numact : Variable qui contient le numéro d'histo que je recherche

Donc la clé de la table Histo c'est bien IDHisto ??

Mais je crois que mon erreur n'est pas la !!!! Je fait un hrecherche
puis hlitpremier (mais je ne suis pas sur une requette) donc a chaque
fois je reprends le premier enregistrement !!!!

Donc j'ai transformer en :

HOuvre(Histo)
HOuvre(Societe_Histo)
SI ModeOuverture=2 ALORS
HLitRecherche(Histo,IDHisto,numact,hIdentique) // c'est avec cela
que ca marche

Trace(Histo.IDHisto)
Trace(Histo.Sujet)
SI HTrouve(Histo) ALORS
//HLitPremier(Histo) --> c'est ca qui fait tout foirrer
FichierVersEcran(FEN_Activites)
Table_Societe_Histo..RubriqueParcourue="IDHisto"
Table_Societe_Histo..Filtre=Histo.IDHisto
FIN
FIN

Un grand Merci à tous de votre aide,

Tornade69
Publicité
Poster une réponse
Anonyme