[WD10] Utilisation de HttpJauge()

Le
Juanito
Bonjour,

J'utilise httpRequete pour récupérer un fichier. Cependant, comme il
peut être volumineux je veux mettre une jauge.

J'ai fait :

reslancement est un booléen

HTTPJauge(JAUGE_Jauge1) // Jauge_Jauge1 est un champ jauge
reslancement =
HTTPRequête("http://www.monsite/telechargement/MonFichier.exe")
SI reslancement = Vrai ALORS
fSauveTexte("c:TotoMonFichier.exe",HTTPDonneRésultat())
FIN
HTTPJauge("")

Cependant, la jauge ne se remplit pas au fur et à mesure mais
uniquement à la fin, ce qui n'est pas vraiment utile pour une jauge.

Aurais-je raté quelque chose ?

Merci d'avance

Jean
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Juanito
Le #14472781
Juanito avait écrit le 21/11/2007 :
Bonjour,

J'utilise httpRequete pour récupérer un fichier. Cependant, comme il peut
être volumineux je veux mettre une jauge.

J'ai fait :

reslancement est un booléen

HTTPJauge(JAUGE_Jauge1) // Jauge_Jauge1 est un champ jauge
reslancement =
HTTPRequête("http://www.monsite/telechargement/MonFichier.exe")
SI reslancement = Vrai ALORS
fSauveTexte("c:TotoMonFichier.exe",HTTPDonneRésultat())
FIN
HTTPJauge("")

Cependant, la jauge ne se remplit pas au fur et à mesure mais uniquement à la
fin, ce qui n'est pas vraiment utile pour une jauge.

Aurais-je raté quelque chose ?

Merci d'avance

Jean



Je me réponds, en Windev 11 cela fonctionne mais pas en 10 ...

Y a-t-il autre chose à faire en 10 pour que cela fonctionne ?

Jean
Publicité
Poster une réponse
Anonyme