WD11 40m - Problème avec ascenseur horizontal dans treeview

Le
Val
Bonjour

Depuis le passage à WD11 40m, les ascenseurs horizontaux des treeview ne
fonctionnent plus correctement.
En fait ils se comportent comme avec la très ancienne WD7 comme
quoi, quand il y a des régressions avec WD, elles sont violentes !

Je m'explique, sachant que ce dysfonctionnement peut être mis en évidence
avec l'exemple "WD Tree View" fournit avec WD11.

Ainsi, je démarre l'exemple "WD Tree View" puis je modifie la taille
horizonatale du treeview pour que l'ascenseur horizontal dudit treeview
s'affiche.
Puis je clique sur la barre centrale de l'ascenseur horizontal et, tout en
maintenant le bouton de la souris appuyé, je glisse la barre centrale de
l'ascenseur vers la droite
Le truc tout bête quoi

Dans des conditions normales, le treeview doit se décaler vers la droite et
la barre centrale de l'ascenseur horizontal aussi.
Là si le treeview se décale bien vers la droite la barre centrale ne
bouge pas !
Donc, lorsque la largeur du treeview est importante, il s'en suit un
pataquesse d'effet minable à l'écran comme vous pouvez l'imaginez car la
barre ne bouge pas, tandis que le treeview se déplace.

Pffuu

Bon, j'ai restauré une image disque avec la 35f et tout redevient normal.
Oui mais bon quand je ré-installe la maj vers la 40m, le
dysfonctionnement ré-apparaît !
La 40m est donc bien en cause.

J'ai testé sur 3 machines pareil.

Bon je suis donc condamné à laisser en WD11-35f tous les projets à
l'intérieur desquels j'utilise les treeview car, sans être mauvaise langue,
je pense qu'il faudra attendre WD12 ou WD13 pour que cela soit corrigé.

Comme déjà dit Pffuu

A+

Val
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Georges Peyre
Le #14662941
Bonjour

Val avait prétendu :
je pense qu'il faudra attendre WD12 ou WD13 pour que cela soit corrigé.



Sauf, peut-être si tu signales ce problème au ST immédiatement, sans
attendre le changement de version suivante : à mon avis, plus un
problème leur est signalé tard dans une version, plus il a de chance
d'être reconduit à la version suivante !

Cordialement,

--
Elle est pas belle la vie ?
Val
Le #14662931
Bonjour Georges

"Georges Peyre"
Bonjour

Val avait prétendu :
je pense qu'il faudra attendre WD12 ou WD13 pour que cela soit corrigé.



Sauf, peut-être si tu signales ce problème au ST immédiatement, sans
attendre le changement de version suivante : à mon avis, plus un problème
leur est signalé tard dans une version, plus il a de chance d'être
reconduit à la version suivante !

Cordialement,

--



Tu sais, je dois faire partie des développeurs WD "malheureux" puisque,
depuis de nombreuses années que je signale des bugs aux ST, je n'ai jamais
vu ces bugs être corrigés dans la version en cours.
C'est pourquoi et concernant ce dysfonctionnement, je ne me fais pas d'idée
là dessus ... qu'il soit signalé dans 2 heures ou dans 3 mois, il faudra
attendre WD12 !
Ceci dit, si on le signale dans 4 ou 5 mois, là il faudra peut-être attendre
WD13 ...
Hé hé ... donc, quand j'aurais un peu de temps et comme je le fais
habituellement, je ferais une fenêtre pour bien mettre en évidence le
problème car sinon j'aurais droit à l'habituelle réponse qui nous fait
tousser "... nous n'avons pas réussi à reproduire et patati et patata ...)

A+

val
Georges Peyre
Le #14662911
Val a formulé la demande :
Hé hé ... donc, quand j'aurais un peu de temps et comme je le fais
habituellement, je ferais une fenêtre pour bien mettre en évidence le
problème car sinon j'aurais droit à l'habituelle réponse qui nous fait
tousser "... nous n'avons pas réussi à reproduire et patati et patata ...)




Je ne pense pas qu'une fenêtre sera plus explicite que ton explication
verbale car elle ne démontrera pas le mouvement anormal du curseur.

Je te confirme que le problème se passe sur n'importe quel tree-view de
n'importe quelle fenêtre.

Donc, si tu leur précises que, dans un champ tree-view ...

-1- La barre-curseur de l'ascenseur horizontal n'accompagne pas le
curseur de la souris ( bouton gauche de la souris maintenu ) lors de
son déplacement de droite à gauche et inversement.

-2- La barre-curseur se déplace d'un seul coup seulement au relachement
du bouton gauche de la souris

-3- Le fond du tree-view se déplace bien en même temps que le curseur
de la souris.

-4- Ce problème ne se produit pas sur l'ascenseur vertical.


... cà devrait aller !

--
Elle est pas belle la vie ?
Michel HERRSCHER
Le #14662861
Et qu'il suffit de faire cela sur l'exemple treeview fourni.



Dans un message Georges Peyre disait :

Val a formulé la demande :
Hé hé ... donc, quand j'aurais un peu de temps et comme je le fais
habituellement, je ferais une fenêtre pour bien mettre en évidence le
problème car sinon j'aurais droit à l'habituelle réponse qui nous fait
tousser "... nous n'avons pas réussi à reproduire et patati et patata
...)



Je ne pense pas qu'une fenêtre sera plus explicite que ton explication
verbale car elle ne démontrera pas le mouvement anormal du curseur.

Je te confirme que le problème se passe sur n'importe quel tree-view de
n'importe quelle fenêtre.

Donc, si tu leur précises que, dans un champ tree-view ...

-1- La barre-curseur de l'ascenseur horizontal n'accompagne pas le
curseur de la souris ( bouton gauche de la souris maintenu ) lors de
son déplacement de droite à gauche et inversement.

-2- La barre-curseur se déplace d'un seul coup seulement au relachement
du bouton gauche de la souris

-3- Le fond du tree-view se déplace bien en même temps que le curseur
de la souris.

-4- Ce problème ne se produit pas sur l'ascenseur vertical.


... cà devrait aller !





--
Michel HERRSCHER CONSULTANT
Tel : +33450870912
http://www.mhc.herrscher.fr
Président de WINDASSO - Association des utilisateurs WxxDEV(c)
http://www.windasso.org
Val
Le #14662801
"Michel HERRSCHER" esgj88$nf5$
Et qu'il suffit de faire cela sur l'exemple treeview fourni.





Humm ... faut arrêter de croire ou de faire croire que la présentation d'un
dysfonctionnement auprès du ST est une chose facile et que cela se fait en 2
ou 3 clics de souris.
Dire cela c'est:
- soit dire n'importe quoi
- soit faire preuve d'une méconnaissance totale de la machinerie PC-SOFT

En fait, ceux d'entre nous qui ont du s'y reprendre à plusieurs fois pour
faire valider un comportement anormal de WD sont nombreux et ce même lorsque
le comportement anormal était flagrant et qu'il suffisait de manipuler un
exemple fournit avec WD pour constater les faits.
Ainsi, j'utilise WD depuis la version 4, donc je connais WD et PC-SOFT et la
réponse bateau du genre "effectivement le comportant est particulier mais
pas anormal", ou bien encore "les tests réalisés avec la version xxx de
WINDEV présente sur notre site Internet ne nous ont pas permis de reproduire
l'anomalie décrite", je les connais et ce même si, comme déjà dit, il
suffisait de manipuler un exemple fournit avec WD pour constater les faits.

Val
Georges Peyre
Le #14662541
Val a écrit :
"Michel HERRSCHER" esgj88$nf5$
Et qu'il suffit de faire cela sur l'exemple treeview fourni.





Humm ... faut arrêter de croire ou de faire croire que la présentation d'un
dysfonctionnement auprès du ST est une chose facile et que cela se fait en 2
ou 3 clics de souris.
Dire cela c'est:
- soit dire n'importe quoi
- soit faire preuve d'une méconnaissance totale de la machinerie PC-SOFT



Moi aussi je travaille sur Windev depuis la WD4 et pour avoir été un
professionnel de la maintenance durant 30 ans je trouve parfaitement
justifié qu'il soit demandé des précisions à une DI :
De plus, demander poliment, sans agressivité, et surtout sans avoir au
préalable copieusement agoni de reproches le ST avant de faire une
demande permet aussi d'avoir une réponse positive du ST.

D'où la réponse du ST à ma demande d'intervention ( texte explicatif
sans projet de test ) sur le tree-view :
<< J'ai lu votre description avec attention et je vous remercie pour sa
précision. J'ai immédiatement enregistré et transmis vos éléments à
notre équipe Développement et à notre équipe Qualité.
L'incident a été enregistré avec la référence 52955. Merci d'utiliser
cette référence si vous contactez le Support Technique Gratuit sur le
même sujet.
etc ...>>

--
Elle est pas belle la vie ?
Val
Le #14660331
"Georges Peyre"
Moi aussi je travaille sur Windev depuis la WD4 et pour avoir été un
professionnel de la maintenance durant 30 ans je trouve parfaitement
justifié qu'il soit demandé des précisions à une DI :



Tu enfonces des portes ouvertes.
En effet, où as-tu lu que je disais le contraire dans mon post ?
Si tu lis entre les lignes, alors sache que tu lis très mal car quand je dis
qu'il faut arrêter de croire ou de faire croire que la présentation d'un
dysfonctionnement auprès du ST est une chose facile et que cela se fait en 2
ou 3 clics de souris, c'est justement parce qu'un développeur qui a bûché
sur le mauvais fonctionnement d'un bout de code doit, lorsqu'il constate que
la cause dudit mauvais fonctionnement est engendré par un bug de WD, faire
preuve d'une certaine retenue et ne pas requêter au ST en 2 ou 3 clics de
souris.
En effet et même si je n'ai pas moi-même oeuvré dans la maintenance durant
30 ans, j'en ai passé tout autant dans diverses activités professionnelles
aussi enrichissantes sur le plan des rapports humains et, bien évidemment,
j'ai appris à respecter les autres et je pars moi aussi du principe que,
quand on constate quelque chose d'anormal sur un produit de quelque nature
que ce soit, il faut donner le maximum de précisions à celui ou a celle à
qui on va s'adresser pour demander des comptes.
Ne pas le faire, c'est-à-dire par exemple signaler un dysfonctionnement au
ST de Pc-Soft par mail en 2 ou 3 clics de souris, c'est-à-dire:
- en usant d'une formulation 'texto"
- sans prendre le soin de présenter les faits proprement et lisiblement
- sans étayer les faits par des preuves irréfutables prouvant que le code du
développeur n'est pas en cause et que sa machine n'est pas en cause non plus
- sans se mettre à la place de celui ou de celle qui va devoir reproduire la
situation pour constater les faits

... c'est ne pas respecter le membre du ST qui va traiter la requête et,
comme déjà dit, faire preuve d'une méconnaissance totale de la machinerie
PC-SOFT en dénigrant le travail qui est fait par le ST au niveau de
l'organisation du traitement des requêtes.

Donc et comme déjà dit, quand un développeur lève un bug de WD qui lui a
fait perdre pas mal de temps, il ne doit pas immédiatement téléphoner ou
requêter en 2 ou 3 clics de souris au ST. Il n'est pas, me semble t'il, dans
les meilleures dispositions pour le faire.


De plus, demander poliment, sans agressivité, et surtout sans avoir au
préalable copieusement agoni de reproches le ST avant de faire une demande
permet aussi d'avoir une réponse positive du ST.


Et oui, d'où le fait, quand on est développeur, de ne pas faire les choses
précipitamment et en 2 ou 3 clics de souris.


D'où la réponse du ST à ma demande d'intervention ( texte explicatif sans
projet de test ) sur le tree-view :
<< J'ai lu votre description avec attention et je vous remercie pour sa
précision. J'ai immédiatement enregistré et transmis vos éléments à notre
équipe Développement et à notre équipe Qualité.
L'incident a été enregistré avec la référence 52955. Merci d'utiliser
cette référence si vous contactez le Support Technique Gratuit sur le même
sujet.
etc ...>>



Pour ce qui me concerne, j'ai pris certaines dispositions pour ne pas avoir
à trop souffrir de ce dysfonctionnement.
Il n'empêche que j'ai quand même signalé les faits au ST par mail ce samedi
3/03 en prenant soin pour ma part de leur fournir une fenêtre créé
spécialement pour cette occasion et dans laquelle l'anomalie était largement
mise en évidence.
J'ai reçu la même réponse que toi ce mardi après-midi, à savoir "J'ai lu
votre description avec attention et je vous remercie pour sa précision. J'ai
immédiatement enregistré et transmis vos éléments à notre équipe
Développement et à notre équipe Qualité. L'incident a été enregistré avec la
référence 52955. Merci d'utiliser cette référence si vous contactez le
Support Technique Gratuit sur le même sujet etc ..."

Par conséquent, ta méthode "texte explicatif sans projet de test" (qui n'est
certainement pas à considérer comme une requête effectuée en 2 ou 3 clics de
souris au sens où moi je l'entend) et ma méthode "texte explicatif avec
fenêtre de test" ont obtenu les mêmes résultats.
Et alors ?
La belle affaire !
Et oui, la belle affaire car cela ne veut absolument rien dire.
En effet, ta requête aura peut-être été traitée avant la mienne et, le bug
ayant été découvert grâce à ta requête, ma requête plus cossue que la tienne
n'aura donc pas été examinée en profondeur. Oui mais bon, l'inverse est
possible également, à savoir que c'est ma requête plus cossue et mieux
étayée que la tienne qui aura été traitée avant la tienne et que c'est la
mienne qui aura mis en évidence l'incident et que c'est ta requête à toi qui
n'aura pas été examinée en profondeur. Dans cette situation, il est
également possible que ta seule requête non étayée par une fenêtre de test
n'aurait pas suffi à mettre en évidence l'incident.
Et alors ?
Comme déjà dit, la belle affaire et il ne sert donc à rien de tirer la
couverture à soit en mettant en avant le résultat d'une méthode ou d'une
autre.
Ce qui compte avant tout et au delà de la reconnaissance de l'incident par
le ST qui n'est pas le plus important car le correctif ne va certainement
pas tomber demain (ni après-demain), c'est que chacun sache qu'il y a un
problème sur l'ascenseur horizontal des treeview avec WD11 ... et c'est ça
le plus important.
Oui, je dis bien avec WD11 et non pas seulement depuis la version 40m de
WD11 car, même avec la version 35f, le problème se pose dans certaines
circonstances que je n'ai pas encore réussi à mettre totalement en évidence
(si toi tu as réussi à le faire, merci de nous éclairer des faits).
Enfin bon ... espérons que tout cela sera corrigé en Décembre 2007 dans WD12
!

A+

Val
Publicité
Poster une réponse
Anonyme