[WD11] associé bouton..image à un memo image

Le
patrice
J'ai pas l'impression que cela fonctionne

ca affecte bien une valeur, mais il semblerait que ca soit pas vraiment
compatible

y a t'il une astuce ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Romain PETIT
Le #14585431
patrice a écrit :
J'ai pas l'impression que cela fonctionne

ca affecte bien une valeur, mais il semblerait que ca soit pas vraiment
compatible

y a t'il une astuce ?



Il me semble qu'il faille d'abord extraire le mémo..
cf. HExtraitMemo(...)

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
patrice
Le #14585401
ca me gave d'utiliser hextraitmemo parce que cela va produire plein de petit
fichier temporaire.
mais il semble que je n'ai pas le choix :

bouton.image=champ_image => cela fonctionne

champ_image=fichier.memo_image => cela fonctionne
bouton.image=champ_image => cela ne fonctionne pas

ma conclusion: bouton.image ne marche qu'avec un fichier image et pas avec
une image en mémoire
ma conclusion bis: ca craint ....


"Romain PETIT" news:
patrice a écrit :
> J'ai pas l'impression que cela fonctionne
>
> ca affecte bien une valeur, mais il semblerait que ca soit pas vraiment
> compatible
>
> y a t'il une astuce ?

Il me semble qu'il faille d'abord extraire le mémo..
cf. HExtraitMemo(...)

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)




Romain PETIT
Le #14581911
patrice a pensé très fort :

bouton.image=champ_image => cela ne fonctionne pas



Ah si, ça devrait fonctionner ça.
Vérifie le style de ton bouton.
(2 points : bouton..image =champ_image)

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
patrice
Le #14581891
"Romain PETIT" news:
patrice a pensé très fort :

> bouton.image=champ_image => cela ne fonctionne pas

Ah si, ça devrait fonctionner ça.
Vérifie le style de ton bouton.
(2 points : bouton..image =champ_image)



bouton.image=champ_image fonctionne pour une image du catalogue
mais si tu fait
champ_image=mon_fichier.rubrique_memo_image
bouton.image=champ_image

alors champ_image vaut bien l'image du fichier, mais bouton.image ne vaut
rien du tout
Romain PETIT
Le #14581881
patrice a présenté l'énoncé suivant :

alors champ_image vaut bien l'image du fichier, mais bouton.image ne vaut
rien du tout



Je viens de faire le test, cela fonctionne parfaitement en 7.5.

sFichierLocal est une chaîne = "c:poignedemain_small.jpg"
Image1 = sFichierLocal // champs image
Bouton1..Image = Image1 // le bouton a bien l'image.

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
Romain PETIT
Le #14581871
Romain PETIT a exprimé avec précision :

Je viens de faire le test, cela fonctionne parfaitement en 7.5.



Ah oui, pardon, ça ne marche pas avec le mémo binaire dans un fichier
HF...


sFichierLocal est une chaîne = "c:poignedemain_small.jpg"
HCréationSiInexistant(Fichierimage)
BOUCLE
SI PAS HLitPremier(Fichierimage,IDFichierimage) ALORS
HAttacheMémo(Fichierimage,Image,sFichierLocal)
HAjoute(Fichierimage)
SINON
SORTIR
FIN
FIN
Image1= Fichierimage.Image // l'image s'affiche bien
Bouton1..Image = Image1 // rien, nada


Conclusion : extraire le fichier sur le disque...

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
Publicité
Poster une réponse
Anonyme