WD11 - Creation d'archive

Le
michel T.
Bonjour.

Voici le code que j'ai mis en place pour création d'une archive .zip ou
.wdz et ça ne me remplit pas l'archive. Je ne comprends vraiment pas
pourquoi.

/début_code

//Déclaration et initialisation des variables
NomArchive est une chaîne = "Sauvegarde.zip"
CheminArchive est une chaîne
ListeFichier est une chaîne
ResCréationArchive est un entier
NbFichier est un entier

// Sélection du chemin de l'archive
CheminArchive = fRepSélecteur("", "Sélection du répertoire", "Sélection
du dossier où placer l'archive")
// Vérification du chemin et recherche d'erreur
SI CheminArchive <> "" ALORS
Info("Le répertoire sélectionné est : "+CheminArchive)
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN

// Création de l'archive "NomArchive"
ResCréationArchive = zipCrée(NomArchive,
ComplèteRep(CheminArchive)+NomArchive)

// Ajout de fichiers si l'archive a été créée
SI ResCréationArchive = 0 ALORS
Info("L'archive est : "+NomArchive) //vérification du renvoi, à suppr
après validation test
Info("Son chemin est : "+CheminArchive) //idem
// Ajout des fichiers dans l'archive
ResCréationArchive =
zipAjouteListeFichier(NomArchive,"*.fic"+RC+"*.ndx"+RC+"*.mmo")
FIN
// Affichage du message d'erreur si les fichiers n'ont pas été ajoutés
SI ResCréationArchive <> 0 ALORS
Erreur(zipMsgErreur(ResCréationArchive))
FIN

// Liste des fichiers de l'archive
ListeFichier = zipListeFichier(NomArchive) //vérification du renvoi, à
suppr après validation test

// Nombre de fichiers contenus dans l'archive
NbFichier = zipNbFichier(NomArchive) //vérification du renvoi, à suppr
après validation test

zipFerme(NomArchive)
Info("Sauvegarde terminée")

Si vous pouvez me dépanner, Merci :-)


--
amicalement,
michel

Chaque fois qu'on peut dire quelque chose en quatre mots, c'est pas la
peine de s'étaler. (Jean Yanne)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michel T.
Le #14624671
Bonjour

ma réponse à michel T. qui écrivait dans
le samedi 30 juin 2007 à 17:01 dans
fr.comp.developpement.agl.windev......

Bonjour.

Voici le code que j'ai mis en place pour création d'une archive .zip ou
.wdz et ça ne me remplit pas l'archive. Je ne comprends vraiment pas
pourquoi.



J'ai oublié, message renvoyé : "le chemin fourni n'est pas valide".


--
amicalement,
michel

Le clou souffre autant que le trou. (Proverbe hollandais)
Juanito
Le #14624651
Bonjour,

Je me demande si le nom des fichiers à intégrer dans le zip ne doit pas
être un nom complet. Dans l'aide de ZipAjouteFichier() il est indiqué
que l'utilisation des caractères joker "*" et "?" n'est pas autorisé.
Il en est peut-être de même pour ZipAjouteListeFichier() ?

Cordialement

Jean


michel T. a présenté l'énoncé suivant :
Bonjour.

Voici le code que j'ai mis en place pour création d'une archive .zip ou
.wdz et ça ne me remplit pas l'archive. Je ne comprends vraiment pas
pourquoi.

/début_code

//Déclaration et initialisation des variables
NomArchive est une chaîne = "Sauvegarde.zip"
CheminArchive est une chaîne
ListeFichier est une chaîne
ResCréationArchive est un entier
NbFichier est un entier

// Sélection du chemin de l'archive
CheminArchive = fRepSélecteur("", "Sélection du répertoire", "Sélection
du dossier où placer l'archive")
// Vérification du chemin et recherche d'erreur
SI CheminArchive <> "" ALORS
Info("Le répertoire sélectionné est : "+CheminArchive)
SINON
// Affichage du message d'erreur
Erreur(ErreurInfo(errMessage))
FIN

// Création de l'archive "NomArchive"
ResCréationArchive = zipCrée(NomArchive,
ComplèteRep(CheminArchive)+NomArchive)

// Ajout de fichiers si l'archive a été créée
SI ResCréationArchive = 0 ALORS
Info("L'archive est : "+NomArchive) //vérification du renvoi, à suppr
après validation test
Info("Son chemin est : "+CheminArchive) //idem
// Ajout des fichiers dans l'archive
ResCréationArchive > zipAjouteListeFichier(NomArchive,"*.fic"+RC+"*.ndx"+RC+"*.mmo")
FIN
// Affichage du message d'erreur si les fichiers n'ont pas été ajoutés
SI ResCréationArchive <> 0 ALORS
Erreur(zipMsgErreur(ResCréationArchive))
FIN

// Liste des fichiers de l'archive
ListeFichier = zipListeFichier(NomArchive) //vérification du renvoi, à
suppr après validation test

// Nombre de fichiers contenus dans l'archive
NbFichier = zipNbFichier(NomArchive) //vérification du renvoi, à suppr
après validation test

zipFerme(NomArchive)
Info("Sauvegarde terminée")

Si vous pouvez me dépanner, Merci :-)


michel T.
Le #14624601
Bonjour

ma réponse à Juanito qui écrivait dans
le dimanche 1 juillet 2007 à 12:12 dans
fr.comp.developpement.agl.windev......

Je me demande si le nom des fichiers à intégrer dans le zip ne doit pas
être un nom complet. Dans l'aide de ZipAjouteFichier() il est indiqué
que l'utilisation des caractères joker "*" et "?" n'est pas autorisé.
Il en est peut-être de même pour ZipAjouteListeFichier() ?



Non, il est bien spécifié dans l'aide que les caractères génériques sont
autorisés ;-)

--
amicalement,
michel

La preuve que le pape ne connait rien à l'utilisation du préservatif,
c'est qu'il l'a mis à l'index. (André Santini)
Juanito
Le #14624591
Bonjour,

Je n'ai pas vu explicitement l'autorisation des jokers dans l'aide mais
le dimanche je n'ai pas toujours les yeux biens ouverts.

Dans le ZipCree() tu mets le nom du fichier zip avec son extension en
premier argument. J'ai l'impression que dans cet argument il faut
mettre un nom fictif et non pas le nom du fichier zip. Du style
"MonArchive" et par "MonArchive.ZIP". Xela ne change peut-être pas
grand chose mais bon ...

Sinon, quelle fonction Zip te donne l'erreur ?

Jean

Il se trouve que michel T. a formulé :
Bonjour

ma réponse à Juanito qui écrivait dans
le dimanche 1 juillet 2007 à 12:12 dans
fr.comp.developpement.agl.windev......

Je me demande si le nom des fichiers à intégrer dans le zip ne doit pas
être un nom complet. Dans l'aide de ZipAjouteFichier() il est indiqué
que l'utilisation des caractères joker "*" et "?" n'est pas autorisé.
Il en est peut-être de même pour ZipAjouteListeFichier() ?



Non, il est bien spécifié dans l'aide que les caractères génériques sont
autorisés ;-)


michel T.
Le #14624581
Bonjour

ma réponse à Juanito qui écrivait dans
le dimanche 1 juillet 2007 à 14:46 dans
fr.comp.developpement.agl.windev......

Dans le ZipCree() tu mets le nom du fichier zip avec son extension en
premier argument. J'ai l'impression que dans cet argument il faut
mettre un nom fictif et non pas le nom du fichier zip.



Dans l'exemple de l'aide sur zipCrée, il est donné : "sav_compress.zip".
N'oublie aps que c'est une chaine, entre ""


--
amicalement,
michel

De tous ceux qui n'ont rien à dire, les plus agréables sont ceux qui se
taisent. (Coluche)
michel T.
Le #14624571
Bonjour

ma réponse à Juanito qui écrivait dans
le dimanche 1 juillet 2007 à 14:46 dans
fr.comp.developpement.agl.windev......

Sinon, quelle fonction Zip te donne l'erreur ?



message renvoyé : "le chemin fourni n'est pas valide".


--
amicalement,
michel

Il vaut mieux prêter à sourire que donner à réfléchir. (Les Nuls)
frederic.genevier
Le #14624541
Bonjour,


// Création de l'archive MonArchive
ResCréationArchive = zipCrée("MonArchive",
ComplèteRep(CheminArchive)+NomArchive)

zipFerme("MonArchive")

_____________________________

Ils ne savaient pas que c'était impossible, alors ils l'ont fait.
[ Mark Twain ]
michel T.
Le #14624531
Bonjour

ma réponse à qui écrivait dans
le dimanche 1 juillet 2007 à 20:46 dans
fr.comp.developpement.agl.windev......

Bonjour,

// Création de l'archive MonArchive
ResCréationArchive = zipCrée("MonArchive",
ComplèteRep(CheminArchive)+NomArchive)

zipFerme("MonArchive")



Oui, ben.... c'est ce que j'ai fait ?


--
amicalement,
michel

La dictature c'est «Ferme ta gueule !», la démocratie c'est «Cause
toujours !» (Coluche)
Tracks
Le #14624521
Remplace NomArchive par "MonArchine"
Tracks
Le #14624511
Remplace NomArchive par "MonArchive"
Publicité
Poster une réponse
Anonyme