[WD11] Drag and Drop programmé sur champ Liste

Le
Fredo G-MDI
Bonjour à tous,

soit un champ Liste ou je veux gérer le drag and drop de façon programmé. Le
champ est Source/Cible, le but étant de pouvoir déplacer des éléments de la
liste avec des drags and drops. Quand je suis en mode automatique et que je
veux positionner un élément de ma liste entre deux lignes j'ai un trait qui
se dessine m'indiquant une insertion de ligne. Comment puis-je faire pour
dessiner ce même trait en mode programmé ? J'aimerai qu'au survol des
éléments ceux-ci se sélectionne (bandeau de sélection) et que quand ma
souris est entre deux lignes que le curseur m'affiche le trait !

Merci d'avance pour vos réponses
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #14497861
Le Mon, 23 Jun 2008 11:35:54 +0200, Fredo G-MDI écrit:

Bonjour à tous,

soit un champ Liste ou je veux gérer le drag and drop de façon
programmé. Le
champ est Source/Cible, le but étant de pouvoir déplacer des éléments de
la
liste avec des drags and drops. Quand je suis en mode automatique et que
je
veux positionner un élément de ma liste entre deux lignes j'ai un trait
qui
se dessine m'indiquant une insertion de ligne. Comment puis-je faire pour
dessiner ce même trait en mode programmé ? J'aimerai qu'au survol des
éléments ceux-ci se sélectionne (bandeau de sélection) et que quand ma
souris est entre deux lignes que le curseur m'affiche le trait !

Merci d'avance pour vos réponses




A faire dans le survol avec _dnd.champxxx et _dnd.sourisxxx ?


--
JB
Fredo G-MDI
Le #14497851
Ci-dessous le code :

à l'initialisation de mon champ :

LISTE_TYPE_GROUPE..DndSource = dndAuto

LISTE_TYPE_GROUPE..DndCible = dndAuto

DnDEvénement("_Lacher","LISTE_TYPE_GROUPE",dndLâcher)

DnDEvénement("_DebutGlisser","LISTE_TYPE_GROUPE",dndDébutGlisser)

DnDEvénement("_SurSurvol","LISTE_TYPE_GROUPE",dndSurvol)



Procedure _SurSurvol

SELON _DND.ChampCible

CAS LISTE_TYPE_GROUPE..Nom

DnDAccepte(dndDéplacer)

DnDCurseur(dndDéfaut)

i est un entier =
ListeInfoXY(LISTE_TYPE_GROUPE,tiNumLigne,_DND.SourisPosX,_DND.SourisPosY)

Trace(i)

ListeSelectPlus(LISTE_TYPE_GROUPE,i)

AUTRE CAS

DnDAccepte(dndInterdit)

FIN



Cela n'a pas l'effet escompté


"JB"
Le Mon, 23 Jun 2008 11:35:54 +0200, Fredo G-MDI écrit:

Bonjour à tous,

soit un champ Liste ou je veux gérer le drag and drop de façon
programmé. Le
champ est Source/Cible, le but étant de pouvoir déplacer des éléments de
la
liste avec des drags and drops. Quand je suis en mode automatique et que
je
veux positionner un élément de ma liste entre deux lignes j'ai un trait
qui
se dessine m'indiquant une insertion de ligne. Comment puis-je faire pour
dessiner ce même trait en mode programmé ? J'aimerai qu'au survol des
éléments ceux-ci se sélectionne (bandeau de sélection) et que quand ma
souris est entre deux lignes que le curseur m'affiche le trait !

Merci d'avance pour vos réponses




A faire dans le survol avec _dnd.champxxx et _dnd.sourisxxx ?


--
JB


Fredo G-MDI
Le #14497841
A l'initialisation c bien DnDProgrammé et pas DnDAuto c'était juste pour mon
test

"JB"
Le Mon, 23 Jun 2008 11:35:54 +0200, Fredo G-MDI écrit:

Bonjour à tous,

soit un champ Liste ou je veux gérer le drag and drop de façon
programmé. Le
champ est Source/Cible, le but étant de pouvoir déplacer des éléments de
la
liste avec des drags and drops. Quand je suis en mode automatique et que
je
veux positionner un élément de ma liste entre deux lignes j'ai un trait
qui
se dessine m'indiquant une insertion de ligne. Comment puis-je faire pour
dessiner ce même trait en mode programmé ? J'aimerai qu'au survol des
éléments ceux-ci se sélectionne (bandeau de sélection) et que quand ma
souris est entre deux lignes que le curseur m'affiche le trait !

Merci d'avance pour vos réponses




A faire dans le survol avec _dnd.champxxx et _dnd.sourisxxx ?


--
JB


JB
Le #14497831
Le Mon, 23 Jun 2008 12:24:44 +0200, Fredo G-MDI écrit:

Ci-dessous le code :

à l'initialisation de mon champ :



[...]
i est un entier > ListeInfoXY(LISTE_TYPE_GROUPE,tiNumLigne,_DND.SourisPosX,_DND.SourisPosY)

Trace(i)

ListeSelectPlus(LISTE_TYPE_GROUPE,i)

AUTRE CAS

DnDAccepte(dndInterdit)

FIN



Cela n'a pas l'effet escompté


[...]
L'indice de la ligne est-il bien ramené ? (trace(i))



--
JB
Fredo G-MDI
Le #14497821
Oui c'est le cas et c'est le bon indice
"JB"
Le Mon, 23 Jun 2008 12:24:44 +0200, Fredo G-MDI écrit:

Ci-dessous le code :

à l'initialisation de mon champ :



[...]
i est un entier >> ListeInfoXY(LISTE_TYPE_GROUPE,tiNumLigne,_DND.SourisPosX,_DND.SourisPosY)

Trace(i)

ListeSelectPlus(LISTE_TYPE_GROUPE,i)

AUTRE CAS

DnDAccepte(dndInterdit)

FIN



Cela n'a pas l'effet escompté


[...]
L'indice de la ligne est-il bien ramené ? (trace(i))



--
JB


JB
Le #14497801
Le Mon, 23 Jun 2008 12:41:55 +0200, Fredo G-MDI écrit:

Oui c'est le cas et c'est le bon indice
"JB"
Le Mon, 23 Jun 2008 12:24:44 +0200, Fredo G-MDI écrit:

Ci-dessous le code :

à l'initialisation de mon champ :



[...]
i est un entier >>> ListeInfoXY(LISTE_TYPE_GROUPE,tiNumLigne,_DND.SourisPosX,_DND.SourisPosY)

Trace(i)

ListeSelectPlus(LISTE_TYPE_GROUPE,i)

AUTRE CAS

DnDAccepte(dndInterdit)

FIN



Cela n'a pas l'effet escompté


[...]
L'indice de la ligne est-il bien ramené ? (trace(i))



--
JB






Juste pour voir , changer couleur de fond au lieu de selectplus ?


--
JB
Fredo G-MDI
Le #14497791
C'est au moment où je lache le bouton gauche que la couleur de fond change
et non pas au survol !! étrange
"JB"
Le Mon, 23 Jun 2008 12:41:55 +0200, Fredo G-MDI écrit:

Oui c'est le cas et c'est le bon indice
"JB"
Le Mon, 23 Jun 2008 12:24:44 +0200, Fredo G-MDI écrit:

Ci-dessous le code :

à l'initialisation de mon champ :



[...]
i est un entier >>>> ListeInfoXY(LISTE_TYPE_GROUPE,tiNumLigne,_DND.SourisPosX,_DND.SourisPosY)

Trace(i)

ListeSelectPlus(LISTE_TYPE_GROUPE,i)

AUTRE CAS

DnDAccepte(dndInterdit)

FIN



Cela n'a pas l'effet escompté


[...]
L'indice de la ligne est-il bien ramené ? (trace(i))



--
JB






Juste pour voir , changer couleur de fond au lieu de selectplus ?


--
JB


Fredo G-MDI
Le #14497781
Un FenRepeint() ou Multitache(-1) m'affiche la couleur demandée au survol
par contre il y a un effet de clignotement pas très joli, arf...

"JB"
Le Mon, 23 Jun 2008 12:41:55 +0200, Fredo G-MDI écrit:

Oui c'est le cas et c'est le bon indice
"JB"
Le Mon, 23 Jun 2008 12:24:44 +0200, Fredo G-MDI écrit:

Ci-dessous le code :

à l'initialisation de mon champ :



[...]
i est un entier >>>> ListeInfoXY(LISTE_TYPE_GROUPE,tiNumLigne,_DND.SourisPosX,_DND.SourisPosY)

Trace(i)

ListeSelectPlus(LISTE_TYPE_GROUPE,i)

AUTRE CAS

DnDAccepte(dndInterdit)

FIN



Cela n'a pas l'effet escompté


[...]
L'indice de la ligne est-il bien ramené ? (trace(i))



--
JB






Juste pour voir , changer couleur de fond au lieu de selectplus ?


--
JB


Fredo G-MDI
Le #14497771
Merci pour ton aide JB, j'ai réussi à avoir ce que je voulais, plus de
clignotement et sélection de la ligne au survol. Il ne me manque plus que le
dessin du trait, chose sur laquelle je n'ai encore aucune idée.

"JB"
Le Mon, 23 Jun 2008 12:41:55 +0200, Fredo G-MDI écrit:

Oui c'est le cas et c'est le bon indice
"JB"
Le Mon, 23 Jun 2008 12:24:44 +0200, Fredo G-MDI écrit:

Ci-dessous le code :

à l'initialisation de mon champ :



[...]
i est un entier >>>> ListeInfoXY(LISTE_TYPE_GROUPE,tiNumLigne,_DND.SourisPosX,_DND.SourisPosY)

Trace(i)

ListeSelectPlus(LISTE_TYPE_GROUPE,i)

AUTRE CAS

DnDAccepte(dndInterdit)

FIN



Cela n'a pas l'effet escompté


[...]
L'indice de la ligne est-il bien ramené ? (trace(i))



--
JB






Juste pour voir , changer couleur de fond au lieu de selectplus ?


--
JB


JB
Le #14497761
Le Mon, 23 Jun 2008 15:03:19 +0200, Fredo G-MDI écrit:

Merci pour ton aide JB, j'ai réussi à avoir ce que je voulais, plus de
clignotement et sélection de la ligne au survol. Il ne me manque plus
que le
dessin du trait, chose sur laquelle je n'ai encore aucune idée.

"JB"
Le Mon, 23 Jun 2008 12:41:55 +0200, Fredo G-MDI écrit:




[...]

--
JB






Juste pour voir , changer couleur de fond au lieu de selectplus ?


--
JB






Serait bien de donner la solution finale pour tout le monde.
Sur les NG , il est recommandé de répondre 'après' ce qui permet de garder
la lisibilité.


--
JB
Publicité
Poster une réponse
Anonyme