[WD11] Problème de cumul

Le
Progidevs
Bonjour,

Depuis hier je m'arrache les cheveux avec un bout de code tous simple,
mais qui ne réagit comme il le devrait.

Je cherche une valeur numérique dans une colonne de table mémoire,
numérique aussi, qui fait partie d'un superchamp. Le code la trouve et
récupère le n° de la ligne correspondant. Ce n° de ligne me sert
ensuite à incrémenter une cellule numérique sur la même ligne. Ca
fonctionne au premier passage, au deuxième, ça me remet la cellule à
zéro à la ligne "TableCherche" et ré-incrémente de 1 à la ligne
suivante.
Un bout de code pour être + clair :

[Code]
HLitPremier

SI nMois <> 0 ALORS
i = TableCherche(SC_SuperChamp1.TABLE.MOIS, nMois)
SI i > 0 ALORS
SC_SuperChamp1.TABLE.REALISES[i] += 1
FIN
FIN
HLitSuivant
[/Code]

Merci par avance pour vos suggestions.
Olivier

--

Olivier
cliquez ci dessous pour me répondre
http://cerbermail.com/?vKlEv56lgz
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
patrice
Le #17280821
Progidevs a écrit :
Bonjour,

Depuis hier je m'arrache les cheveux avec un bout de code tous simple,
mais qui ne réagit comme il le devrait.

Je cherche une valeur numérique dans une colonne de table mémoire,
numérique aussi, qui fait partie d'un superchamp. Le code la trouve et
récupère le n° de la ligne correspondant. Ce n° de ligne me sert ensuite
à incrémenter une cellule numérique sur la même ligne. Ca fonctionne au
premier passage, au deuxième, ça me remet la cellule à zéro à la ligne
"TableCherche" et ré-incrémente de 1 à la ligne suivante.
Un bout de code pour être + clair :

[Code]
HLitPremier...

SI nMois <> 0 ALORS
i = TableCherche(SC_SuperChamp1.TABLE.MOIS, nMois)
SI i > 0 ALORS
SC_SuperChamp1.TABLE.REALISES[i] += 1
FIN
FIN
HLitSuivant...
[/Code]

Merci par avance pour vos suggestions.
Olivier




si c'est une table fichier, chaque champ est remis à jour à la relecture
du fichier.
faut modifier directement le fichier ou bien (me rappelle plus le nom
exact, un truc genre tableenregistre, )
Progidevs
Le #17290081
patrice a formulé la demande :
Progidevs a écrit :
Bonjour,

Depuis hier je m'arrache les cheveux avec un bout de code tous simple, mais
qui ne réagit comme il le devrait.

Je cherche une valeur numérique dans une colonne de table mémoire,
numérique aussi, qui fait partie d'un superchamp. Le code la trouve et
récupère le n° de la ligne correspondant. Ce n° de ligne me sert ensuite à
incrémenter une cellule numérique sur la même ligne. Ca fonctionne au
premier passage, au deuxième, ça me remet la cellule à zéro à la ligne
"TableCherche" et ré-incrémente de 1 à la ligne suivante.
Un bout de code pour être + clair :

[Code]
HLitPremier...

SI nMois <> 0 ALORS
i = TableCherche(SC_SuperChamp1.TABLE.MOIS, nMois)
SI i > 0 ALORS
SC_SuperChamp1.TABLE.REALISES[i] += 1
FIN
FIN
HLitSuivant...
[/Code]

Merci par avance pour vos suggestions.
Olivier




si c'est une table fichier, chaque champ est remis à jour à la relecture du
fichier.
faut modifier directement le fichier ou bien (me rappelle plus le nom exact,
un truc genre tableenregistre, )



Bien sûr, quand on a la tête dans le guidon, on fini par ne plus voir
les freins.
Merci Patrice.

--
---
Olivier
cliquez ci dessous pour me répondre
http://cerbermail.com/?vKlEv56lgz
---
Publicité
Poster une réponse
Anonyme