[WD11] WDMemoBinaire

Le
Fredo G-MDI
Bonjour à tous

lorsque j'essaie d'insérer une image dans ma base de données via
WDMemoBinaire, si le nom a une ' exemple :
"C:Mes ImagesL'écurie.JPG" l'insertion ne se réalise pas correctement
après avoir remplacé les ' par des ''. A l'insertion j'ai donc quelque chose
comme cela :
INSERT INTO MaTable (MaTable.monImage) VALUES ({WDMemoBinaire('C:Mes
ImagesL''écurie.JPG')}), mais cela ne fonctionne pas. Faut-il remplacer les
'' par un autre caractère ?

Des idées ?

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
patrice
Le #14507561
on dirait que tu met des ' pour délimiter la chaine, ce qui oblige à quoter
le ' du fichier
utilise des guillemets "pour quoter la chaine et donc ne quote pas ' du
fichier

"Fredo G-MDI" news:4846874c$0$10490$
Bonjour à tous

lorsque j'essaie d'insérer une image dans ma base de données via
WDMemoBinaire, si le nom a une ' exemple :
"C:Mes ImagesL'écurie.JPG" l'insertion ne se réalise pas correctement
après avoir remplacé les ' par des ''. A l'insertion j'ai donc quelque


chose
comme cela :
INSERT INTO MaTable (MaTable.monImage) VALUES ({WDMemoBinaire('C:Mes
ImagesL''écurie.JPG')}), mais cela ne fonctionne pas. Faut-il remplacer


les
'' par un autre caractère ?

Des idées ?

Merci




Fredo G-MDI
Le #14507551
Je mets des ' pour quoter la chaine car c'est la syntaxe de WDMemoBinaire

"patrice" 48468c36$0$878$
on dirait que tu met des ' pour délimiter la chaine, ce qui oblige à
quoter
le ' du fichier
utilise des guillemets "pour quoter la chaine et donc ne quote pas ' du
fichier

"Fredo G-MDI" news:4846874c$0$10490$
Bonjour à tous

lorsque j'essaie d'insérer une image dans ma base de données via
WDMemoBinaire, si le nom a une ' exemple :
"C:Mes ImagesL'écurie.JPG" l'insertion ne se réalise pas correctement
après avoir remplacé les ' par des ''. A l'insertion j'ai donc quelque


chose
comme cela :
INSERT INTO MaTable (MaTable.monImage) VALUES ({WDMemoBinaire('C:Mes
ImagesL''écurie.JPG')}), mais cela ne fonctionne pas. Faut-il remplacer


les
'' par un autre caractère ?

Des idées ?

Merci








patrice
Le #14507531
Effectivement, alors pas d'autre solution que de renommer le fichier avec
insertion et/ou remonter le pb au st

"Fredo G-MDI" news:48468ca0$0$1470$
Je mets des ' pour quoter la chaine car c'est la syntaxe de WDMemoBinaire

"patrice" 48468c36$0$878$
> on dirait que tu met des ' pour délimiter la chaine, ce qui oblige à
> quoter
> le ' du fichier
> utilise des guillemets "pour quoter la chaine et donc ne quote pas ' du
> fichier
>
> "Fredo G-MDI" > news:4846874c$0$10490$
>> Bonjour à tous
>>
>> lorsque j'essaie d'insérer une image dans ma base de données via
>> WDMemoBinaire, si le nom a une ' exemple :
>> "C:Mes ImagesL'écurie.JPG" l'insertion ne se réalise pas correctement
>> après avoir remplacé les ' par des ''. A l'insertion j'ai donc quelque
> chose
>> comme cela :
>> INSERT INTO MaTable (MaTable.monImage) VALUES ({WDMemoBinaire('C:Mes
>> ImagesL''écurie.JPG')}), mais cela ne fonctionne pas. Faut-il


remplacer
> les
>> '' par un autre caractère ?
>>
>> Des idées ?
>>
>> Merci
>>
>>
>
>




Fredo G-MDI
Le #14507521
Quel dommage ! Je suis partit pour copie du fichier et renommage en
remplaçant les ' par des _ mais bon c'est vraiment le genre de solution qui
ne me plaît guère (c'est l'impression de faire du bricolage qui me stresse)

"patrice" 484691c4$0$882$
Effectivement, alors pas d'autre solution que de renommer le fichier avec
insertion et/ou remonter le pb au st

"Fredo G-MDI" news:48468ca0$0$1470$
Je mets des ' pour quoter la chaine car c'est la syntaxe de WDMemoBinaire

"patrice" 48468c36$0$878$
> on dirait que tu met des ' pour délimiter la chaine, ce qui oblige à
> quoter
> le ' du fichier
> utilise des guillemets "pour quoter la chaine et donc ne quote pas '
> du
> fichier
>
> "Fredo G-MDI" > news:4846874c$0$10490$
>> Bonjour à tous
>>
>> lorsque j'essaie d'insérer une image dans ma base de données via
>> WDMemoBinaire, si le nom a une ' exemple :
>> "C:Mes ImagesL'écurie.JPG" l'insertion ne se réalise pas
>> correctement
>> après avoir remplacé les ' par des ''. A l'insertion j'ai donc quelque
> chose
>> comme cela :
>> INSERT INTO MaTable (MaTable.monImage) VALUES ({WDMemoBinaire('C:Mes
>> ImagesL''écurie.JPG')}), mais cela ne fonctionne pas. Faut-il


remplacer
> les
>> '' par un autre caractère ?
>>
>> Des idées ?
>>
>> Merci
>>
>>
>
>








Publicité
Poster une réponse
Anonyme