[WD12] utilisation accès natif SQLServer

Le
wd_newbie
Bonjour,

je suis en train de travailler sur une nouvelle application, pour
celle-ci j'ai réussi à décider mon employer de casser sa tirelire pou=
r
acquérir WD12 + l'accès natif SQLserver.

Pour mes tests, j'ai installé la version Express de SQLserver 2005 sur
mon portable, j'utilise le logiciel "SQL server Management Studio
Express" pour créer la structutre de ma base de données.

La ou le bas blesse, c'est que, une fois des modifs exécutées sur la
structure de la base (ajout d'un champ, d'une table) , je dois (si
j'ai bien compris) synchroniser ma base de données avec mon analyse
WD.

Je clique sur mon menu "Synchroniser l'analyse avec des bases
externes" => "vérifier toutes les tables" => BOUM !! Windev 12 a
rencontré un problème et doit fermer "

-
WinDev12.exe - Erreur d'application
-
L'instruction à "0x733276ac" emploie l'adresse mémoire "0x051a5d30".
La mémoire ne peut pas être "read".
=
-

Bref le gros plantage et il est 5heures du mat' et je n'ai pas
l'impression d'avancer

Help !! y'a t'il quelqu'un qui bosse avec l'acces natif et ou cela
fonctionne !! je galère

Merci d'avance

Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
tjfromparis
Le #18002151
quand j'ai des soucis avec windev, je ferme WD, je supprime le
repertoire cpl (dans le rep du projet)

quelle version de SQLexpress ?
en mode test ca fonctionne ?



On 30 nov, 05:04, wd_newbie
Bonjour,

je suis en train de travailler sur une nouvelle application, pour
celle-ci j'ai réussi à décider mon employer de casser sa tirelire p our
acquérir WD12 + l'accès natif SQLserver.

Pour mes tests, j'ai installé la version Express de SQLserver 2005 sur
mon portable, j'utilise le logiciel "SQL server Management Studio
Express" pour créer la structutre de ma base de données.

La ou le bas blesse, c'est que, une fois des modifs exécutées sur la
structure de la base (ajout d'un champ, d'une table) , je dois (si
j'ai bien compris) synchroniser ma base de données avec mon analyse
WD.

Je clique sur mon menu "Synchroniser l'analyse avec des bases
externes" => "vérifier toutes les tables" => BOUM !! Windev 12 a
rencontré un problème et doit fermer ..."

----------------------------------------------
WinDev12.exe - Erreur d'application
----------------------------------------------
L'instruction à "0x733276ac" emploie l'adresse mémoire "0x051a5d30".
La mémoire ne peut pas être "read".
------------------------------------------------------------------------- ---------------------------------

Bref le gros plantage ... et il est 5heures du mat' et je n'ai pas
l'impression d'avancer ...

Help !! y'a t'il quelqu'un qui bosse avec l'acces natif et ou cela
fonctionne !! je galère ...

Merci d'avance

Olivier


wd_newbie
Le #18009011
On 30 nov, 10:32, "" wrote:
quand j'ai des soucis avec windev, je ferme WD, je supprime le
repertoire cpl (dans le rep du projet)

quelle version de SQLexpress ?
en mode test ca fonctionne ?




La version est SQL express 2005 et c'est justement en mode test que
cela me plante ...

Olivier
tjfromparis
Le #18011261
pour determiner si ca viens de l'access à la base ou de ton projet, tu
peux pas créer un projet vide, en utilisant le meme acces natif (juste
avec une tables systemes ou une table bidon que tu cré).


Dans ton projet , ca plante à la connection ou à un endroit
particulier ?


On 30 nov, 23:05, wd_newbie
On 30 nov, 10:32, "" wrote:

> quand j'ai des soucis avec windev, je ferme WD, je supprime le
> repertoire cpl (dans le rep du projet)

> quelle version de SQLexpress ?
> en mode test ca fonctionne ?

La version est SQL express 2005 et c'est justement en mode test que
cela me plante ...

Olivier


wd_newbie
Le #18011571
On 1 déc, 09:48, "" wrote:
pour determiner si ca viens de l'access à la base ou de ton projet, tu
peux pas créer un projet vide, en utilisant le meme acces natif (juste
avec une tables systemes ou une table bidon que tu cré).

Dans ton projet , ca plante à la connection ou à un endroit
particulier ?

On 30 nov, 23:05, wd_newbie
> On 30 nov, 10:32, "" > wrote:

> > quand j'ai des soucis avec windev, je ferme WD, je supprime le
> > repertoire cpl (dans le rep du projet)

> > quelle version de SQLexpress ?
> > en mode test ca fonctionne ?

> La version est SQL express 2005 et c'est justement en mode test que
> cela me plante ...

> Olivier



A vrai dire, la connexion elle même est OK, je peux lire , mettre a
jour les données sasn soucis.

C'est vraiment l'utilisation de la fonction de synchronisation de
l'analyse qui plante.

Par exemple, je rajoute un champ dans ma base de donnée et dand WD, je
choisi l'option "Synchroniser l'analyse avec les bases de données
externes" pour synchroniser la base et l'analyse et boum ...
plantage.

Olivier
tjfromparis
Le #18013621
t'as pas un reliquat de vieilles connections en ADO, oleDB ou autres
qui y trainent ?

travaille sur une copie de ton projet :
- supprimer et recréer la connection peut etre


On 1 déc, 11:27, wd_newbie
On 1 déc, 09:48, "" wrote:



> pour determiner si ca viens de l'access à la base ou de ton projet, t u
> peux pas créer un projet vide, en utilisant le meme acces natif (just e
> avec une tables systemes ou une table bidon que tu cré).

> Dans ton projet , ca plante à la connection ou à un endroit
> particulier ?

> On 30 nov, 23:05, wd_newbie
> > On 30 nov, 10:32, "" > > wrote:

> > > quand j'ai des soucis avec windev, je ferme WD, je supprime le
> > > repertoire cpl (dans le rep du projet)

> > > quelle version de SQLexpress ?
> > > en mode test ca fonctionne ?

> > La version est SQL express 2005 et c'est justement en mode test que
> > cela me plante ...

> > Olivier

A vrai dire, la connexion elle même est OK, je peux lire , mettre a
jour les données sasn soucis.

C'est vraiment l'utilisation de la fonction de synchronisation de
l'analyse qui plante.

Par exemple, je rajoute un champ dans ma base de donnée et dand WD, je
choisi l'option "Synchroniser l'analyse avec les bases de données
externes" pour synchroniser la base et l'analyse et boum ...
plantage.

Olivier


wd_newbie
Le #18021441
On 1 déc, 14:47, "" wrote:
t'as pas un reliquat de vieilles connections en ADO, oleDB ou autres
qui y trainent ?

travaille sur une copie de ton projet :
- supprimer et recréer la connection peut etre

On 1 déc, 11:27, wd_newbie
> On 1 déc, 09:48, "" > wrote:

> > pour determiner si ca viens de l'access à la base ou de ton projet, tu
> > peux pas créer un projet vide, en utilisant le meme acces natif (ju ste
> > avec une tables systemes ou une table bidon que tu cré).

> > Dans ton projet , ca plante à la connection ou à un endroit
> > particulier ?

> > On 30 nov, 23:05, wd_newbie
> > > On 30 nov, 10:32, "" > > > wrote:

> > > > quand j'ai des soucis avec windev, je ferme WD, je supprime le
> > > > repertoire cpl (dans le rep du projet)

> > > > quelle version de SQLexpress ?
> > > > en mode test ca fonctionne ?

> > > La version est SQL express 2005 et c'est justement en mode test que
> > > cela me plante ...

> > > Olivier

> A vrai dire, la connexion elle même est OK, je peux lire , mettre a
> jour les données sasn soucis.

> C'est vraiment l'utilisation de la fonction de synchronisation de
> l'analyse qui plante.

> Par exemple, je rajoute un champ dans ma base de donnée et dand WD, j e
> choisi l'option "Synchroniser l'analyse avec les bases de données
> externes" pour synchroniser la base et l'analyse et boum ...
> plantage.

> Olivier



Installation de WD 12 sur un PC tout beau tout neuf, pas de vieux
relent de vieilleries qui trainent (ADO ou autre, je n'ai meme pas
réinstallé VB6.0).

Je vais essaye sur une copie du projet, mais j'en suis tjrs a la phase
de test, j'ai essayé plusieurs fois...vous savez Test1/test2/ :-)

Si je trouve la soluce , je la posterai ici, en attendant je prends
toutes idées !

Amicalement

Olivier
tjfromparis
Le #18028231
la base SQL est sur ton poste ? (en local donc)
les connections avec autres passent ? sqlwb par ex
t'as verifié que les connections sont autorisés sur le serveur pour
les named pipe et tcp ?


On 2 déc, 10:43, wd_newbie
On 1 déc, 14:47, "" wrote:



> t'as pas un reliquat de vieilles connections en ADO, oleDB ou autres
> qui y trainent ?

> travaille sur une copie de ton projet :
> - supprimer et recréer la connection peut etre

> On 1 déc, 11:27, wd_newbie
> > On 1 déc, 09:48, "" > > wrote:

> > > pour determiner si ca viens de l'access à la base ou de ton proje t, tu
> > > peux pas créer un projet vide, en utilisant le meme acces natif ( juste
> > > avec une tables systemes ou une table bidon que tu cré).

> > > Dans ton projet , ca plante à la connection ou à un endroit
> > > particulier ?

> > > On 30 nov, 23:05, wd_newbie
> > > > On 30 nov, 10:32, "" > > > > wrote:

> > > > > quand j'ai des soucis avec windev, je ferme WD, je supprime le
> > > > > repertoire cpl (dans le rep du projet)

> > > > > quelle version de SQLexpress ?
> > > > > en mode test ca fonctionne ?

> > > > La version est SQL express 2005 et c'est justement en mode test q ue
> > > > cela me plante ...

> > > > Olivier

> > A vrai dire, la connexion elle même est OK, je peux lire , mettre a
> > jour les données sasn soucis.

> > C'est vraiment l'utilisation de la fonction de synchronisation de
> > l'analyse qui plante.

> > Par exemple, je rajoute un champ dans ma base de donnée et dand WD, je
> > choisi l'option "Synchroniser l'analyse avec les bases de données
> > externes" pour synchroniser la base et l'analyse et boum ...
> > plantage.

> > Olivier

Installation de WD 12 sur un PC tout beau tout neuf, pas de vieux
relent de vieilleries qui trainent (ADO ou autre, je n'ai meme pas
réinstallé VB6.0).

Je vais essaye sur une copie du projet, mais j'en suis tjrs a la phase
de test, j'ai essayé plusieurs fois...vous savez Test1/test2/ :-)

Si je trouve la soluce , je la posterai ici, en attendant je prends
toutes idées !

Amicalement

Olivier


wd_newbie
Le #18037891
On 2 déc, 22:57, "" wrote:
la base SQL est sur ton poste ? (en local donc)
les connections avec autres passent ? sqlwb par ex
t'as verifié que les connections sont autorisés sur le serveur pour
les named pipe et tcp ?




TCP est activé, les named pipe ne le sont pas, je peux utiliser
l'application (je n'ai que deux tables de test) , les liaisons
fonctionnent.

C'est au moment ou je veux synchroniser la structure que ça plante ...

A propos , vous savez ou trouver de la doc spécifique sur cet accès
natif ? , l'aide fournie n'est pas très garni a ce sujet

Olivier
tjfromparis
Le #18038641
demain je vais installer l'access natif et faire 2/3 tests

t'as acces au serveur ?

log toi en admin sur le serveur SQL
essaie de choper la requete que windev envoi au moment de la synchro
de l'analyse

On 3 déc, 21:02, wd_newbie
On 2 déc, 22:57, "" wrote:

> la base SQL est sur ton poste ? (en local donc)
> les connections avec autres passent ? sqlwb par ex
> t'as verifié que les connections sont autorisés sur le serveur pour
> les named pipe et tcp ?

TCP est activé, les named pipe ne le sont pas,  je peux utiliser
l'application (je n'ai que deux tables de test) , les liaisons
fonctionnent.

C'est au moment ou je veux synchroniser la structure que ça plante ...

A propos , vous savez ou trouver de la doc spécifique sur cet accès
natif ? , l'aide fournie n'est pas très garni a ce sujet

Olivier


wd_newbie
Le #18041051
On 3 déc, 22:05, "" wrote:
demain je vais installer l'access natif et faire 2/3 tests

t'as acces au serveur ?

log toi en admin sur le serveur SQL
essaie de choper la requete que windev envoi au moment de la synchro
de l'analyse

On 3 déc, 21:02, wd_newbie
> On 2 déc, 22:57, "" > wrote:

> > la base SQL est sur ton poste ? (en local donc)
> > les connections avec autres passent ? sqlwb par ex
> > t'as verifié que les connections sont autorisés sur le serveur po ur
> > les named pipe et tcp ?

> TCP est activé, les named pipe ne le sont pas, je peux utiliser
> l'application (je n'ai que deux tables de test) , les liaisons
> fonctionnent.

> C'est au moment ou je veux synchroniser la structure que ça plante .. .

> A propos , vous savez ou trouver de la doc spécifique sur cet accès
> natif ? , l'aide fournie n'est pas très garni a ce sujet

> Olivier



OK merci pour ton aide, je vais essayer de voir la requete WD

Olivier
Publicité
Poster une réponse
Anonyme