[WD55] Wdmodfic

Le
Bruno
Bonjour,

nous avons encore un logiciel sous WD55 (la version sous WD15 est en
cours de dev).
Le problème : sous Windows 7 64 bits, impossible de lancer le wdmodfic,
une astuce ?

Merci

--
Bruno A

suivre ce lien pour répondre :
http://cerbermail.com/?TF4s3h4ejs
;)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe Vidal
Le #22927591
Le 15/12/2010 15:20, Bruno a écrit :
Bonjour,

nous avons encore un logiciel sous WD55 (la version sous WD15 est en
cours de dev).
Le problème : sous Windows 7 64 bits, impossible de lancer le wdmodfic,
une astuce ?



Bonjour,

utiliser le wdmodfic32 de windev 7.5, qui lui est compatible...

cf le code source du wdinst de wd7.5 pour voir les différences de la
ligne d'appel, et modifier ton wdinst 5.5 en conséquence (NB: moi
j'ajoute manuellement au jeu d'install le wdmodfic32 et ses dll ainsi
que le wdd de mon appli, et j'ai modifie le code du wdinst pour le gérer)
Bruno
Le #22927641
Philippe Vidal a exprimé avec précision :


Bonjour,

utiliser le wdmodfic32 de windev 7.5, qui lui est compatible...

cf le code source du wdinst de wd7.5 pour voir les différences de la ligne
d'appel, et modifier ton wdinst 5.5 en conséquence (NB: moi j'ajoute
manuellement au jeu d'install le wdmodfic32 et ses dll ainsi que le wdd de
mon appli, et j'ai modifie le code du wdinst pour le gérer)



Oui je viens de voir ça. On est en train de récuperer une version 7.5
de WD.

Merci

--
Bruno A

suivre ce lien pour répondre :
http://cerbermail.com/?TF4s3h4ejs
;)
Bruno
Le #22927801

cf le code source du wdinst de wd7.5 pour voir les différences de la ligne
d'appel



Je reviens vers toi, comment avoir le code source de wdinst, on ne le
trouve pas ?!!

Merci

--
Bruno A

suivre ce lien pour répondre :
http://cerbermail.com/?TF4s3h4ejs
;)
Philippe Vidal
Le #22927791
Le 15/12/2010 16:37, Bruno a écrit :

cf le code source du wdinst de wd7.5 pour voir les différences de la
ligne d'appel



Je reviens vers toi, comment avoir le code source de wdinst, on ne le
trouve pas ?!!

Merci




il est dans les exemples wd
Philippe Vidal
Le #22927851
Le 15/12/2010 16:50, Philippe Vidal a écrit :
Le 15/12/2010 16:37, Bruno a écrit :

cf le code source du wdinst de wd7.5 pour voir les différences de la
ligne d'appel



Je reviens vers toi, comment avoir le code source de wdinst, on ne le
trouve pas ?!!

Merci




il est dans les exemples wd



c'est "wdsetup" en fait
Bruno
Le #22927921

il est dans les exemples wd



c'est "wdsetup" en fait



Avec la version téléchargé, on ne l'a pas..... grrrr :-(

--
Bruno A

suivre ce lien pour répondre :
http://cerbermail.com/?TF4s3h4ejs
;)
Bruno
Le #22928001
Philippe Vidal vient de nous annoncer :


c'est "wdsetup" en fait



Je remercie beaucoup celui qui pourrait m'envoyer le projet d'exemple
WDSETUP, ou bien un copier-coller du code contenant la syntaxe d'appel
du wdmodfic32.EXE.

b.abratanski(à enlever)@yahoo.fr

--
Bruno A

suivre ce lien pour répondre :
http://cerbermail.com/?TF4s3h4ejs
;)
Philippe Vidal
Le #22928161
Le 15/12/2010 17:19, Bruno a écrit :
Philippe Vidal vient de nous annoncer :


c'est "wdsetup" en fait



Je remercie beaucoup celui qui pourrait m'envoyer le projet d'exemple
WDSETUP, ou bien un copier-coller du code contenant la syntaxe
d'appel du wdmodfic32.EXE.

b.abratanski(à enlever)@yahoo.fr




Alors c'est dans la proc ExecMaodifAuto de la fen Installe :

juste après la ligne :
sAna=Inst.RepTravail+""+rendNomSeul(Inst.NomAnalyse)+".wdd"

je remplace toute la suite par :
LigneCde=""""+sAna+""""" /WD /F /NOLOC"
LigneCde=LigneCde+" /REP="+Inst.RepDest+"data"

NomEXE=Inst.RepTravail+"wdmodfic32.exe"

sModAuto=""""+NomEXE+""" "+LigneCde

si pas DDELance(sModAuto,DDEActif,Vrai) alors
// "WDMODFIC32.EXE non trouvé"
Erreur(NomEXE,"",MessTraduit(2022))
// L'exécution de l'installation continue
fin

voili voilou!
Bruno
Le #22929541
Philippe Vidal a utilisé son clavier pour écrire :


Alors c'est dans la proc ExecMaodifAuto de la fen Installe :

juste après la ligne :
sAna=Inst.RepTravail+""+rendNomSeul(Inst.NomAnalyse)+".wdd"

je remplace toute la suite par :
LigneCde=""""+sAna+""""" /WD /F /NOLOC"
LigneCde=LigneCde+" /REP="+Inst.RepDest+"data"

NomEXE=Inst.RepTravail+"wdmodfic32.exe"

sModAuto=""""+NomEXE+""" "+LigneCde

si pas DDELance(sModAuto,DDEActif,Vrai) alors
// "WDMODFIC32.EXE non trouvé"
Erreur(NomEXE,"",MessTraduit(2022))
// L'exécution de l'installation continue
fin

voili voilou!



Merci, on essaye ça et si on a des difficultés, je me permettrai de
reposter un message.

--
Bruno A

suivre ce lien pour répondre :
http://cerbermail.com/?TF4s3h4ejs
;)
Bruno
Le #22929571

Merci, on essaye ça et si on a des difficultés, je me permettrai de reposter
un message.



Petites questions ?

On a des données dans
D:temp : OK
D:temptest : pas OK, pourquoi ?

Alors que si à la place du repertoire des données dans la ligne de
commande (/REP=), on indique le repertoire du .rep, pas de souci....

Est-ce qu'il y a un parametre pour scanner des sous-repertoires ?

merci

--
Bruno A

suivre ce lien pour répondre :
http://cerbermail.com/?TF4s3h4ejs
;)
Publicité
Poster une réponse
Anonyme